View Full Version : Boot problem with DT 4.03

07.03.2006, 18:09

I have a very strange boot problem with Daemon Tools v4.03: Once I install them (and do the necessary reboot), the boot process stops even before any windows screen, right after the bios has finished and the IDE HD is accesses. Only a black cursor blinking remains.

I tried this on 2 clean installs, with the same result. In my opinion it might be a problem with the MSI motherboard (Athlon CIP with VIA Chipset) and the new SCSI pass through layer, as DT 3.47 work fine and I didn't experience any other problems prior (so no direct hardware fault here).

Has anyone had this problem before?

07.03.2006, 19:10
When exactly does it hang?
If Windows does not even start to load, sptd layer can NOT be the cause, as it is not loaded at that point already.

12.03.2006, 08:33

The exact "Hang location" is after the bios has booted ok and before the black "Windows XP" startup screen appears (right after the disk access). It must have to do something with the sptd layer, as everything starts ok without them - so no misconfigured bios or harddisk error. I can reproduce this phaenomenon after a clean install.

I believe it is an incompatibility with the MSI motherboard (KT3 Ultra2 with VIA Apollo KT 333 chipset) and the startup routines.

I agree with you, that it is probably not related to the .sys/driver files, but maybe the sptd alters something in the boot process as well.

B.t.w. I have the same problem with the new Alcohol version, which uses a similar technology for CD emulation to my knowledge.

04.04.2006, 19:31
I have the exact same issue... right after I installed Daemon Tools, it asked me to reboot... I did, and after reboot, it would sit with just a blinking cursor, right after the bios screen... it isn't even checking the hard drive. I tried several things to fix, but still no go... I'd rather not have to go through a whole reformat unless absolutely necessary.

Here's what I tried:
In recovery console:
chkdsk /r

Also, tried a repair on the windows installation... this didn't help either.

Any ideas?

05.04.2006, 14:49
have you tried renaming sptd.sys and seeing if that helps??

05.04.2006, 20:38
Yes, I just tried renaming sptd.sys and doing a chkdsk /r, as the support email suggested... still won't boot. Any other suggestions???



07.04.2006, 18:13
I'll try suggesting some possible solutions.

1. Did you try rebooting your XP in Safe Mode? If it luckily works, you could try uninstalling DAEMON from within. Note that you'll have to delete sptd.sys and dtscsi.sys manually after the uninstall procedure.

2. If the Safe Mode doesn't work, then I'm afraid deleting or renaming drivers propably wouldn't help either - but you could still try renaming dtscsi.sys and see if that works.

3. Turn off your computer, unplug all optical IDE cables (your CD-ROM cables) then in BIOS setting, disable all CD-ROM, SCSI, RAID settings. Only enable your primary IDE HDD then reboot in Safe Mode.

4. If even this fails, take the drastic method : unplug all USB, Firewire, game console and even your printer. Leave only your keyboard, mouse and monitor plugged. In BIOS, disable all interfaces such as USB ports, Serial/Parallel ports, Firewire(IEEE 1394) ports, Game/Midi ports, as well as Lan and Sound (if your mobo comes with). Disable PnP OS capability. Basically, close all interfaces except your primary IDE HDD, keboard, mouse and monitor. Reboot in Safe Mode.

14.04.2006, 08:08
I also had the booting problem you described and tried the fixes listed and there was no way my PC was going to start up without me doing a clean install.
If you have the capabilities/software have a look and see if there is a recognisable filesystem because in my cases (yes plural) the filesystem could not be recognised by windows and was listed as an 'unknown' filesystem.
You can read a bit more about the fun I have been having in this DT forum thread (http://www.daemon-tools.cc/dtcc/t11087-major-crashescorruption-and-403.html) because I have been in DT hell <sniff>.
The reason I respond here is that I also have an MSI mobo with VIA KT333 chipset as did another respondent in this thread and I thought this snippet may have been been worth bringing to the attention of the coders as it may help them.
I certainly hope that you guys don't have as much grief as I have had (with 4.03) as I can not run the latest version of DT without serious, serious, serious problems. I can successfully run the 3.47 version which is the option I am taking until the solution becomes apparent.

14.04.2006, 15:44
It seems I have also a big problemm with my Deamon 4.00
I 've instal it on my brothers pc for the game: NFSMW and the first month it was fine. an just yesterday when he startet his pc, ...
nothing. I 've try to start it in his safe mode, but he keep on saying that he was looking for "SPTD.sys" ore I can press "esc" but that haven't got any efect:confused: he just woudn't start up:mad:
can someone tell me how I can start his pc back on???


14.04.2006, 19:20
I have the same problem. I have installed DT 4.03HE (as I remember), a restart was needed in order to install SPTD driver, afterwards the installation ran normally, I used DT, but during subsequent restarts Windows hang up on me :(. It stopped just when that first blue progress bars is running on screen. Safe mode is working, so I have set SPTD driver not to start and I can use WIndows (without DT of course :((). This did not happen with previous versions.


30.04.2006, 00:24
im having the same problem but i cant even get far enough to re-install xp or to run it in safe mode. it is a msi k8 neo2 mother board. the computer was working fine off a new install of xp (less then 12h old). i had an older version of daemon tools that worked well. so when i installed it on April 25th it came up with a critical error which i thought was odd because i had it running the night before with he same xp program. so this morning i installed xp and then installed the new daemon tools and the thing crashed. so what should i do to get the thing to post? also dose this mean i will not ever be able to run daemon tools?

01.05.2006, 16:48
My XP computer did the same, crashing duing s/u. I could either boot in safe mode, but if I did not hit ESC to not load SPTD, the computer would just turn itself off.

I booted in Safe mode and everything was fine.

I restarted and the same problem occurred, the computer would not complete the boot process. It just turned itself off during the boot (presumably right after the drivers loaded).

So When I turned it on the next time I held down the control key and then it said KEYBOARD FAILURE and began to boot, then just wouldn't respond so I had to hold down the power button :mad: (I HATE doing that) and it turned off. The next time the boot menu asked me how I wanted to restart I said LAST KNOWN GOOD Configuration and the boot completed. At this point the WHENU Save Now popup appeared and said that it was finishing installing. After I allowed it through the firewall, Spybot, and something else it finished installing and everything works.

Before these endless list of crashes, it is important to note that Daemon Tools WhenU Search Bar was not listed in the Add/Remove programs list, neither was WhenU Save Now listed separately.

I believe after you get all of the apps included in the bundle (I emphasise ALL) that it will work fine, I've already mounted and unmounted several images.

Hope this Long (sorry :confused:) description helps someone.