View Full Version : Error : "Virtual SCSI Driver not found"

12.07.2003, 12:43
After (clean)installing Windows 2000 (SP4) today, I installed Daemon-Tools v3.33 using the Administrator account.

Then I made a normal(restricted) user account for my brother, and he logged into that account, the message box from DT appeared like this.

"Virtual SCSI Driver not found"

Is this a bug? If not, how can I trouble-shoot this problem?
Isn't there any way to use DT under normal user previledges?

12.07.2003, 12:44
There is no problem with the 'Administrator' account.

12.07.2003, 15:43
Make sure you don't have compatibility set for daemon tools.

13.07.2003, 01:41
I have the very same problem. Clean install of SP4, Daemon Tools gives that error when run from an account lacking Administrator rights. Even Power User rights doesn't cut it.

I'm not sure what you mean by having "compatibility" set for DT. I'm simply running with the default settings, 4 drives, no analog audio, and safedisc on.

Thanks for any help,

13.07.2003, 02:08
If you right-click on daemon tools shortcut, then click compatibility, is anything checked off? If it is, uncheck it.

13.07.2003, 02:31
I'm not sure I understand. The Daemon Tools shortcut is just a regular Windows shortcut. If you mean the Daemon Tools tray icon, then right clicking on it brings up several menus, though not one is named Compatibility. There is one called Emulation. I turned off all of the options there, but that didn't solve the problem.

This is all very strange. Installing DT on SP3 worked fine, even after I upgraded to SP4. Perhaps MS changed some permissions for SP4, which would only take effect on a clean SP4 install?


13.07.2003, 13:01
Yes, i mean desktop shortcut. But i think this shuoldn't be a problem if it works for some user.

From normal user, try running devmgmt.msc and seeing if virtual cdrom's are there.

13.07.2003, 17:05
Yes, as a Power User I can see 4 Generic STEALTH DVD SCSI CdRom Devices, and under "SCSI and RAID controllers" there is also ST3WOLF SCSI Controller.

The problem goes away if I make the user a member of the Administrator group, so it seems to be a permissions problem . But of course that's not a proper and secure solution.


13.07.2003, 18:02
More than likely the problem is some registry permission is set so that normal user cannot access it. I don't know exactly which key is the problem, though. Someone else might know though.

14.07.2003, 17:47
I've had the same problem. Whenever I tried to start Daemon Tools it would give me the error message in this topic title and quit. But, fortunately the solution is simple: Check your device manager. Most probably, the virtual Daeamon SCSI adapter isn't there anymore or is incorrectly installed. If it is still there, uninstall it. Then uninstall Daemon Tools. Reinstall Daemon tools and then run the add new hardware wizard and it'll show up, including one or more virtual DVD drives. There you go, start Deamon Tools again and everything's fine.

25.08.2003, 05:33
i am having the same problem with dtools working for an account that is part of the "Administrators" group but not for users that are part of other groups. also, the first time i installed it i installed it from a non-administrator account (in which it prompted me to run the program as an administrator) and it worked fine before i rebooted, like everyone else seems to experience. however, when i had win2k advanced server there were no problems like this; dtools worked for every user... so i am not sure why others cannot get it to work with 2k (although i probably had an older version.. that might be the solution). i have made sure that daemon.exe is not set to run in a compatibility mode, and i also updated my st3 scsi driver with the driver in windows\inf\, now the device is called "SCSI/RAID Host Controller". in this post: http://www.daemon-tools.cc/portal/viewtopic.php?t=997 pixelaser says it works fine in win2k3 and that it might be a program conflict. however, i do not have any other programs installed at all: no burning programs, no dvd players, etc. i do have this interesting entry in my event viewer:
Event Type: Error
Event Source: Application Error
Event Category: (100)
Event ID: 1000
Date: 8/24/2003
Time: 7:25:27 PM
User: N/A
Computer: SCAR
Faulting application daemon.exe, version, faulting module PGPclientLib.dll, version, fault address 0x0003a8fe.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
0000: 41 70 70 6c 69 63 61 74 Applicat
0008: 69 6f 6e 20 46 61 69 6c ion Fail
0010: 75 72 65 20 20 64 61 65 ure dae
0018: 6d 6f 6e 2e 65 78 65 20 mon.exe
0020: 33 2e 33 33 2e 30 2e 30
0028: 20 69 6e 20 50 47 50 63 in PGPc
0030: 6c 69 65 6e 74 4c 69 62 lientLib
0038: 2e 64 6c 6c 20 38 2e 30 .dll 8.0
0040: 2e 32 2e 30 20 61 74 20 .2.0 at
0048: 6f 66 66 73 65 74 20 30 offset 0
0050: 30 30 33 61 38 66 65 003a8fe

so i tried uninstalling PGP and dtools and then rebooting yadda yadda yadda then installing dtools and guess what! i am still having the problem :(
......so has anyone figured out how to fix this yet? :) thanks

25.08.2003, 13:38
@scar: Perhaps you can try some 3rd party addons from our download section? If this is problem with daemon.exe, then actual drivers for the virtual drive might still be ok.

I've found if you use 'update' on dtools scsi controller is will be renamed to 'SCSI/RAID Host Controller', so this isn't a big issue.

03.09.2003, 23:12
ok i tried awxDTools and FastMount, and neither fixed the problem. also, i thought i would give myself "full control" permissions on the drivers used for the devices, and that did not work. i also found in computer management -> storage -> removable storage -> libraries is a list of the virtual drives. if you right click on them and go to properties, there is a security tab for them. i tried giving myself "full control" permissions on the drives, but i am still getting the error. i hope soon you can figure out what is causing this :)

@scar: Perhaps you can try some 3rd party addons from our download section? If this is problem with daemon.exe, then actual drivers for the virtual drive might still be ok.

I've found if you use 'update' on dtools scsi controller is will be renamed to 'SCSI/RAID Host Controller', so this isn't a big issue.

04.09.2003, 00:16
Fastmount uses daemon.exe indirectly. Can you try daemonscript, as this is written by me, so I will be able to help you if you get an error.

Also make sure you close daemon.exe via task manager before trying with daemonscript.