PDA

View Full Version : My USB Camera doesn't appear in Windows Explorer



Black_Mark
25.03.2006, 08:50
Hi there!!

First of all I have to congratulate the DT team for making such a great tool!!
Everyone who wants to play today's games must have DT installed.
Only the uninstall procedure of it (together with that of SPTD) needs some improvement.



I started this thread so that I don't bump with someone else's troubles' thread!

Firstly, I have to say that I have a ASUS A8N-E mobo (BIOS ver. 1005)
with XP-SP2.
I also have installed the latest version of ZoomBrowser EX software (i.e. 5.5)
along with the (latest) WIA 6.25 USB driver (for the camera).


I was using DT 3.47 with no problems whatsoever.
Not much time ago, I decided to use DT 4.03
so that I can play "Prince of Persia 3",
which, btw, played GREAT!!

When I finished the game, I didn't have any other use for DT.
And that's when I decided to try to access my "Canon PowerShot A400" camera,
and, guess what! There was absolutely no way!!!

(I have to say here that I don't have any problems with my flash memory USB,
or with my USB cable with which I connect my mobile phone to the PC.)

What I mean is that, the camera was recognised in Device Manager,
but there was no letter assigned to it.
Also I cannot see the camera in disk management!!!

And the event manager pop-up that appears whenever I connect the camera
(which was already on, and in "view" mode) was empty!!! (relative link (http://photography-on-the.net/forum/archive/index.php/t-51684.html))


After I tried many things (incl. the install/uninstall of ZoomBrowser + WIA driver, in countless combinations)
-and have read almost the whole forum here!!-,
- I uninstalled DT,
- I uninstalled SPTD (by downloading and typing in a command prompt"sptdinst_x86.exe remove" ) + reboot
- l also manually deleted
secdrv.sys
sptd.sys
sptdxxxx.sys (I can't remember exactly)

Also, because everytime that I booted the PC (after doing all these things mentioned above)
there was a message in EventViewer, saying that the driver sptd was not loaded.
I even used this great tool (by sysinternals.com) called Autoruns (http://www.sysinternals.com/Utilities/autoruns.html)
to delete (in the Drivers>HKLM Services tab) those lines refering to DT,
i.e. sptd.sys, dtscsi.sys, secdrv.sys.


And what has been left in the Registry,
are lines for LEGACY_SPTD
in HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001 + 002 ---> Do I have to delete them also(will it make any difference)?
but not in CurrentcontrolSet anymore (there, it has only been left an empty LEGACY_SPTD key there).



[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\Root\ LEGACY_SPTD]
"NextInstance"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\Root\ LEGACY_SPTD\0000]
"Service"="sptd"
"Legacy"=dword:00000001
"ConfigFlags"=dword:00000000
"Class"="LegacyDriver"
"ClassGUID"="{8ECC055D-047F-11D1-A537-0000F8753ED1}"
"DeviceDesc"="sptd"
"Capabilities"=dword:00000000
"Driver"="{8ECC055D-047F-11D1-A537-0000F8753ED1}\\0044"

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\Root\ LEGACY_SPTD\0000\LogConf]

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\Root\ LEGACY_SPTD\0000\Control]



The sptd-messages have stopped in EventViewer,
but I still can't access my camera in Windows Explorer whatsoever.

The device is recognised as Canon Camera in Dev.Manager
(or Canon Camera #1-#6 when I put it in other USB ports).
But, when, I have already deleted the device in Safe mode + Reboot,
(already on, and in "view" mode)
It's recognised as "Canon PowerShot A400"
but with no other gain!!


I lastly have to mention that I use only fresh batteries,
and that I also have tried external USB hub (my -Sony- monitor's hub)
but with NO SUCCESS!!!!!!!

And to add that: in a friend's PC my camera works ok!!!




So, any help is more than welcome!!
Thank you.

Underheaven
25.03.2006, 09:20
secdrv.sys is a SafeDisc driver (even though it comes with some versions of windows). But with SPTD removed, I don't know what to suggest now.

Black_Mark
27.03.2006, 07:57
Anything else guys?

At least I found this What are Control Sets? What is CurrentControlSet? (http://support.microsoft.com/kb/100010/en-us) in Microsoft's Knowledge Base,
where it says that both ControlSet001+002 are there just for backup purposes.

Underheaven
28.03.2006, 08:41
a little info for you:

Your article applies to Windows NT. The \clone key doesn't exist in 2k/XP/2003/vista. ControlSet001 and ControlSet002 are not just backup copies. One of them is your live and active one.

Maybe you made too many registry modifications that could have led to a USB problem.

Black_Mark
28.03.2006, 22:18
Well pal, thanks for the continous interest!!

Yes, I know that it’s for NT, but apart from the clone-key
all others are the same.

But yes, you’re right.
I’ve found this How Malware hides and is installed as a Service (http://www.bleepingcomputer.com/tutorials/tutorial83.html)
which explains things a little better:


Service entries are stored in the registry under a section called ControlSet.
A ControlSet are located under the following key:
HKEY_LOCAL_MACHINE\SYSTEM

A ControlSet is a complete copy of the configuration that is used to successfully launch services and other critical files & drivers for Windows. When you look under the above key there will always be at least two ControlSets and one CurrentControlSet.

One of these numbered control sets refers to the default configuration that is used when the computers normally boots. The other numbered control set refers to the one used when you choose to boot up using the Last Known Good Configuration.

The last one, CurrentControlSet, is an exact mirror of the ControlSet we had used to boot into Windows, so that if you make a change CurrentControlSet it will automatically appear in the ControlSet it is mirroring and vice-versa.



Nevertheless I didn’t do THAT many changes in registry.
In fact what I only did, was:
1.

Also, because everytime that I booted the PC (after doing all these things mentioned above)
there was a message in EventViewer, saying that the driver sptd was not loaded.
I even used this great tool (by sysinternals.com) called Autoruns
to delete (in the Drivers>HKLM Services tab) those lines refering to DT,
i.e. sptd.sys, dtscsi.sys, secdrv.sys.
and
2. I also deleted whatever sptd entries lied in currentcontrolset and controlset001+002.




I have to add that, before I did the above,
I checked (in NotePad)
the latest registry backup I ‘ve got from my XP –about 2 months old-
(it’s a habit that it’s left to me from Win98SE times..)
and there was absolutetly NO sptd related entry there.
So, I decided to delete those entries.

Calaf
09.04.2006, 02:22
You could perhaps try with windows' "system restore" utility?
Does anybody think it would help?
What does that SPTD driver do anyway?
Has anyone else encountered problems in uninstalling them? 'Cause I wanted to play from my original copy of Fahrenheit and I've read somewhere in this forum that I got to uninstall those drivers first.. I'd like to know from the devs if we gotta do anything else to remove 'em completely, thx!!

Underheaven
09.04.2006, 10:13
Calaf, there is a post entitled "How to remove DAEMON Tools V4" in the Common Problems and Solutions forum. It contains all the information needed to uninstall, if there are any unanswered questions about uninstalling or SPTD that you can't easily find via a forum search let me know.

Black_Mark
10.04.2006, 15:41
You could perhaps try with windows' "system restore" utility?

No, I can't.
In fact I've always "System Restore" to off,
cause it's SUCH A RESOURCE HOG!!!!
Thank you, anyway! :)




Another thing I came upon is that I had this "Sentinel System Driver" installed
(God only knows how it was installed!!)
Anyway I uninstalled it ok (it had a line in Add/Remove Programs).
Unofortunately though, it didn't do any good.
Do you you know if it's related in some way with Daemon Tools?
(I googled it but didn't found anything enlightening)


Also, do you think that my camera-problem
is a matter of a specific service(but which?) that is running while it shouldn't (or the opposite) ?

Btw, I must have stopped κ' disabled:
- "Windows Image Acquisition (WIA)" service
in order my scanner ScanJet 3400c (USB) to work.
(Of course I experimented starting/stopping it,
but it didn't help me with the camera neither)
- "SSDP Discovery Service" (and "uPnP Device Host")
in order not getting "IRQ NOT LESS THAN" crashes (in HTTP.sys or other drivers)
from my nForce4U mobo's Gigabit Ethernet,
when I turn on my router!!!