PDA

View Full Version : awxDTools keeps saying something about a .dll



jjaomni
30.03.2006, 08:52
I turned off secure mode and tried to re-register with the programs short cut and I have both the 64 version of dt and the context shell extension. But it keeps saying can not access the .dll please turn off secure mode

arniWORX
30.03.2006, 12:25
hi!
try to enable the creation of 8.3 filenames with the following command:

fsutil behavior set disable8dot3 0

then reboot and re-register the extension from the start-menu.
i try to fix it in the next build.
regards
arni

g31
30.03.2006, 12:36
i had the same problem, but arniWORX found the problem...


Make sure that you have turned on, the creation of 8.3 (DOS)
filenames. to enable, use the following command:

fsutil behavior set disable8dot3 0

and reboot the computer. after that, re-register this extension
from the start-menu.

jjaomni
01.04.2006, 09:13
still not working for me on x64

Kinlaadare
02.04.2006, 09:30
secure mode is an option of DT...

jjaomni
02.04.2006, 09:42
yeap kinlaadare. i have that option unchecked.

theo. t.
02.04.2006, 17:44
same error, tried using 32bit version of dt and aniworx' shell extension,
tried aniworx' solution but this did not help, still can't register .dll

Cuddles
03.04.2006, 01:33
I get "Unable to access image file" error for some images. Looks like an error in awxDTools because I can mount image with Daemon Tools.

g31
03.04.2006, 10:08
same error, tried using 32bit version of dt and aniworx' shell extension,
tried aniworx' solution but this did not help, still can't register .dll

you have first to disable 8.3 filename creation AND to recreate your DAEMON Tools folder! Just rename you current folder and create a new folder with 8.3 filename. All files should be copied into the new folder. :wink:

EDIT: how to do:

- disable 8.3 filename creation!

- reboot machine

- close Daemon Tools (, if it's running)

- rename your current folder (e.g. 'C:\Programs\Daemon Tools\' to 'C:\Programs\Daemon\')

- create a new folder (should have the name of you old folder, see example: 'C:\Programs\Daemon Tools\')

- copy/move all files from your old folder to the new created (e.g. from 'C:\Programs\Daemon\' to 'C:\Programs\Daemon Tools\')

- delete the old folder (e.g. 'C:\Programs\Daemon\')

this could work.

reason for this is in fact the 8.3 filename creation, but if your current 'Daemon Tools' folder was created without 8.3 filename, you have to recreate it with 8.3 filename creation.

awx said the new version should be able to handle long filenames.

theo. t.
05.04.2006, 17:12
mh, the folder renaming doesn't help
i still get the .dll error message

Underheaven
06.04.2006, 06:31
mh, the folder renaming doesn't help
i still get the .dll error message

Can you see if you have short file names created for your folder using "dir /x" ?

duebel13
07.04.2006, 07:10
On my Win2k SP4 box with all updates installed, awxDTools setup fails with error message "Failed to register this extension".

When I try to manually regsvr32 awxDTools.dll, I get error message "DllRegisterServer in <Path> failed. Return code was: 0x80040201".

Short filename creation is enabled on my machine and actually never was disabled at any time.

Any idea what's going wrong?

theo. t.
07.04.2006, 15:05
Can you see if you have short file names created for your folder using "dir /x" ?

aah, seems like the
fsutil behavior set disable8dot3 0 command hasn't worked ... there are still only short named folders

sd4
08.04.2006, 22:55
is there a fix yet? i tried everything in this thread still dont work. tried reinstalling daemon tool to C:\DAEMON\ dont work

uberost
12.04.2006, 20:27
Hi!!
Iget the problem to awxDtools cant acces deamon.dll (or something very close to that)

Where do i type this:

fsutil behavior set disable8dot3 0

Yeah i know im a noob when it gets to this :) but plz help me out here. using win xp x64

Underheaven
13.04.2006, 02:56
you type it into the black command line window
Start Menu, Programs, Accessories, Command Prompt

CPUWiZ
30.04.2006, 00:46
Thanks Arni!! I ran the tet from a command line rebooted and registered extension from shortcut!! (can't open 'about' extension though)

Sasco
08.05.2006, 01:54
Having the same issue myself, followed g31's guide to fix this, but it still comes up with try turning off secure mode (when it is off) :/

Underheaven
09.05.2006, 09:35
there are still only short named folders
Having NTFS generate short file names (8.3 style) is the goal! You want to see the "~1"

Can you provide a screenshot?

theo. t.
10.05.2006, 17:49
mh, the "~1" is there, but still doesn't work
http://membres.lycos.fr/vuvuss41/picture.JPG

Underheaven
10.05.2006, 22:42
Try to get the DAEMON Tools folder to be listed as ~1. This probably involves a lot of deleting and recreating.

theo. t.
11.05.2006, 16:07
now it is "~1" but aniworx still could load .dll
damn

Underheaven
11.05.2006, 17:14
I'm running out of ideas http://www.daemon-tools.cc/dtcc/images/icons/icon9.gif. Did you uninstall DAEMON Tools and install it to that new folder and delete all the files from the folder DAEMON Tools was previously installed in? Did you uninstall and reinstall AwxDTools? Maybe there's an aniworx registry entry that needs to be deleted.

theo. t.
15.05.2006, 20:28
mh, searching the registry is a good idea
thx

alii
17.05.2006, 06:43
I am running Windows XP 64 bit edition and I was having the same problem with awxDTools not registering. I tried formatting and reinstalling windows but I kept getting the same error. I also tried the other solutions in this thread but they did not work for me. Below is what resolved the daemon.dll issue for me.


Solution:
Download and install "Microsoft Visual C++ 2005 Redistributable" yes the 32 bit version not the 64 bit version (Google it. It should be the first hit). The name of the file is vcredist_x86.exe


Reason:
It seems that the installer lays down only the 64 bit version of C++ files but the x86 or 32 bit version is needed too.


How I figured it out:
I double checked the event viewer Start \ Settings \ Control Panel \ Administrative Tools \ Event Viewer \ System Logs and I saw 3 error messages. One of the error messages was

"Dependent Assembly Microsoft.VC80.MFC could not be found and Last Error was The referenced assembly is not installed on your system."
(Note: if you see DCOM errors in the log, this fix alone may not resolve the issue)

I researched the error and it referenced files that should have been installed by the "Microsoft Visual C++ 2005 Redistributable (x64)" but these files did not work. I then used the 32 bit version "Microsoft Visual C++ 2005 Redistributable" and it worked. I then uninstalled everything, rebooted and installed Daemon Tools then awxDTools. I received the daemon.dll error. I then installed "Microsoft Visual C++ 2005 Redistributable" and "Re-Register Extension". It registered fine. Now I can right click on images and mount them.

I hope this helps.

theo. t.
17.05.2006, 19:04
this is the download link (http://download.microsoft.com/download/6/d/9/6d9bf0d6-0e3a-4d35-801d-9a8173e86d13/vcredist_x86.exe)
i will try it, thx

DigiD
25.05.2006, 08:37
I am running Windows XP 64 bit edition and I was having the same problem with awxDTools not registering. I tried formatting and reinstalling windows but I kept getting the same error. I also tried the other solutions in this thread but they did not work for me. Below is what resolved the daemon.dll issue for me.


Solution:
Download and install "Microsoft Visual C++ 2005 Redistributable" yes the 32 bit version not the 64 bit version (Google it. It should be the first hit). The name of the file is vcredist_x86.exe


Reason:
It seems that the installer lays down only the 64 bit version of C++ files but the x86 or 32 bit version is needed too.


How I figured it out:
I double checked the event viewer Start \ Settings \ Control Panel \ Administrative Tools \ Event Viewer \ System Logs and I saw 3 error messages. One of the error messages was

"Dependent Assembly Microsoft.VC80.MFC could not be found and Last Error was The referenced assembly is not installed on your system."
(Note: if you see DCOM errors in the log, this fix alone may not resolve the issue)

I researched the error and it referenced files that should have been installed by the "Microsoft Visual C++ 2005 Redistributable (x64)" but these files did not work. I then used the 32 bit version "Microsoft Visual C++ 2005 Redistributable" and it worked. I then uninstalled everything, rebooted and installed Daemon Tools then awxDTools. I received the daemon.dll error. I then installed "Microsoft Visual C++ 2005 Redistributable" and "Re-Register Extension". It registered fine. Now I can right click on images and mount them.

I hope this helps.

Indeed this DOES help! I have been searching for a solution for over a month- I configured a few x64 machines and they ALL had the exact same problem. Tried everything in this thread to no avail, but your solution solved it! Thank you so much! It would make sense that the developer would have these libraries installed, and as a result may have overlooked their necessity for the end users- excellent find. This is of course not meant to bash ArniWorx in any way- no one could possibly complain about fabulous free software- but we all have so many variables to deal with, it can be an impossible task to keep up with all of it.

Again, thank you- this is truly excellent fact-finding and troubleshooting on your part.

varimon
29.05.2006, 19:38
u r a god among insects. i never thought i'd find a fix.

Jito463
30.05.2006, 23:47
Just as an aside, I found a way to trick this program into working with Alcohol as well for those interested. I did as suggested and installed the Visual C++ package first (not sure if it actually was required, but better safe than sorry). I then tried installing awxDTools into the Alcohol Soft\Alcohol 120 directory, but it couldn't locate daemon.dll. So I made a copy of alcoholx.dll and renamed the copy to daemon.dll in the same directory and proceded with the install like normal. I've tested and it absolutely does work. Now I don't have to load up Alcohol or set it to start at boot everytime I want to mount/unmount an image.

Jito463
31.05.2006, 03:54
Just an update, I also found out this adds context menu support to the virtual drives themselves upon reboot. I didn't discover this at first because I rarely reboot (and the installation didn't require me to). It still says "Daemon Tools" in the context menu, but at least it's working.

Underheaven
31.05.2006, 04:51
That's a really neat hack Jito

Jito463
31.05.2006, 06:55
I also discovered if I hex-edit the awxDTools.dll file, I can modify the context menu to read Alcohol-Soft instead of Daemon-Tools (just looks better when I'm using Alcohol instead of DT).

Petzi
28.06.2006, 10:35
I have the same problem (failed to register). I'm using Win2k (futils is a part of XP but not for Win2k).

please give me a solution :rolleyes:

Underheaven
28.06.2006, 14:34
I have the same problem (failed to register). I'm using Win2k (futils is a part of XP but not for Win2k).

please give me a solution :rolleyes:
Please upload a screenshot like theo. t. posted. You probably have short filenames already turned on.

Look for the mention of "NtfsDisable8dot3NameCreation" on this webpage: http://www.microsoft.com/technet/security/prodtech/windows2000/secwin2k/swin2k06.mspx

shodanx
13.08.2006, 22:34
I'm still getting failed to register extensionon win2k3 x64

I installed both Visual C++ 2005 Runtime Libraries x86 and Visual C++ 2005 Runtime Libraries x64

then I ran fsutil behavior set disable8dot3 0
then I installed daemon tools in c:\daemon, turned off secure mode and installed awxdtool in c:\daemon

I got the error again , I tried twice to be sure

on win2k3 32bit it works just fine, what's the problem ?

trajan
18.08.2006, 20:40
I am running Windows XP 64 bit edition and I was having the same problem with awxDTools not registering. I tried formatting and reinstalling windows but I kept getting the same error. I also tried the other solutions in this thread but they did not work for me. Below is what resolved the daemon.dll issue for me.


Solution:
Download and install "Microsoft Visual C++ 2005 Redistributable" yes the 32 bit version not the 64 bit version (Google it. It should be the first hit). The name of the file is vcredist_x86.exe


Reason:
It seems that the installer lays down only the 64 bit version of C++ files but the x86 or 32 bit version is needed too.


How I figured it out:
I double checked the event viewer Start \ Settings \ Control Panel \ Administrative Tools \ Event Viewer \ System Logs and I saw 3 error messages. One of the error messages was

"Dependent Assembly Microsoft.VC80.MFC could not be found and Last Error was The referenced assembly is not installed on your system."
(Note: if you see DCOM errors in the log, this fix alone may not resolve the issue)

I researched the error and it referenced files that should have been installed by the "Microsoft Visual C++ 2005 Redistributable (x64)" but these files did not work. I then used the 32 bit version "Microsoft Visual C++ 2005 Redistributable" and it worked. I then uninstalled everything, rebooted and installed Daemon Tools then awxDTools. I received the daemon.dll error. I then installed "Microsoft Visual C++ 2005 Redistributable" and "Re-Register Extension". It registered fine. Now I can right click on images and mount them.

I hope this helps.


This worked beautifully. Thank you!

Ender080
27.08.2006, 19:31
I have the same problem (failed to register). I'm using Win2k (futils is a part of XP but not for Win2k).

please give me a solution :rolleyes:

ok, took me quite long to switch from 3.47 to 4.0.3 because of problems installing sptd and awxDTools (w2ksp4). Now I tried again and got the daemon 4.0.3 running but awxDTools still fails to register the dll. Seems only a few people still use w2k - so not much help here.

What I did and what seems to go wrong:

- tried to install awxDTools -> result is the error when trying to register the dll
- copied all registry settings from a wxpsp1 and put them in my w2k registry with the failed install -> awxDTools appears and seems to work ... at least a little bit
- most of the images (iso, cue, mds - all the same behavior) do not mount with 'unable to open file in kernel mode' error message, but if you put any image to the root directory of any drive it works! (or change all subdirectories to uppercase)

Ok, I found something about wxp and ObCaseInsensitive (interesting for all but win32 like posix) to turn case sensitivity of, what seems to be default on wxp and impossible on w2k. Also somebody mentioned Alcohol 120% accessing images with uppercase file and path (visible in history) and making problems this way.

If you try to mount an image using command line you'll notice that the path is case sensitive. Drive letter and filename are not. Does awxDTools pay attention to this? If not, is it possible to fix it? Or is it possible to make posix case insensitive in w2k?

Maybe this points even to the install problem in w2k although a test with uppercase names failed :confused:

arniWORX, could you please take a look at the problem?

edit by Admin: Please don't post your message more than once. The forums are moderated, which is why your posts don't show up immediately.

Joulesbeef
16.10.2006, 20:27
Uninstall awxdtools
uninstall daemon tools
make sure 8.3 filename creation is on by following steps below:
1. click start
2. click run
3. paste "fsutil behavior set disable8dot3 0"
4. click enter
5. reboot.
install latest daemontools, i have 4.06
right click the tray icon, select options, make sure "secure mode" is not checked
next go here http://ccollomb.free.fr/unlocker/
install unlocker
go to daemontools directory
right click deamon.dll
select unlocker, select unlock all
install awxdtools
reboot
turn back on secure mode on deamon tools
enjoy.:D

hemorrhage
26.04.2007, 20:38
well Joules i tried that i'm running Vista 64bit with all the latest version of everything and i tried your fix and unlocker dosen't even open when i try to open the dll with unlocker what am i supposed to do