View Full Version : DAEMON + Alcohol causes memory leaks?

05.04.2006, 09:43
Here it goes.

DT 4.00 and 4.03 installs and runs fine (POP T2T, PJKK, and The Incredibles so far). However, my computer eventually crashes because of memory leaks. This sometimes takes an overnight to happen.

I used poolmon.exe to diagnose the cause of my system's memory problem, and noticed a constant increase in "Strg paged". This basically meant a kernel-managed driver was causing memory leaks. I had to uninstall practically all drivers, printer, scanner, mmc r/w etc. until I hit the target. The symptom disappeared only after uninstalling DT.

I don't know if this is only happening to me (I'm using XP Pro SP2). Anyone with similar problem? Is this related to SPTD.SYS? Suggestions on how to solve this would be greatly appreciated. Thanks in advance!

05.04.2006, 18:00
I've tried installing DT4.0x on my lab's computer, at school. To check if it causes similar memory lacks. Negative.

poolmon.exe after installing DT returns clean results. No constant increase on "Strg paged" or whatsoever.

Now I'm puzzled. I know DT caused memory leaks at my machine at home : I only uninstalled DT, all the other devices and drivers are left & running but no mem leaks so far.

Could it possibly be other programs/devices interfering with DT? My machine at home has Alcohol 120% and Roxio Easy CD/DVD creator installed (haven't tried uninstalling them yet). My computer at school has none of them, just DT running.

Any suggestions? Now I'm getting frustrated...

05.04.2006, 20:00
My guess is another driver interferring with DAEMON Tools. Try running the StarForce Removal Tool at onlinesecurity-on.com. If that doesn't work I'd paste a list of drivers and see if anyone notices anything unusual (you mentioned you tried to uninstall almost everything but maybe you missed something). And I consider some HP stuff bloatware, maybe one of its drivers is leftover.

06.04.2006, 15:52
Thanks for your advice, Underheaven. I uninstalled Alcohol from my home computer, then re-installed DAEMON with it's most recent version (4.03). No mem leaks.

When DAEMON runs alone, it has no problem. The fact that Alcohol + DAEMON somehow caused all this troubles surprised me at first, but made sense : they both needs the same drive, STPD.SYS, for their CD-ROM emulations.

As far as I'm concerned, up-to-date versions of both softwares wouldn't do harm when combined. It just seems to occur with mismatching versions. I'll try a fresh download of Alcohol, re-install it at see if the problem persists.