View Full Version : Please Help! Error 25001. Device setup error 25021

24.11.2002, 22:43
Hi! I've been using Daemon-Tools for a very long time and I never have any trouble installing newer version. I uninstall the old version, and install version 3.26 and I got this error message. I restarted my computer and still have the same code. Please help! TIA

25.11.2002, 12:11
What is your OS version?

25.11.2002, 14:43

I got the same problem.
This appears during installation.
I run Win2000 SP2, 5.00.2195 exactly.

Thanks for your quick help !

25.11.2002, 17:26
After you get this error please don't press ok, but look into INF folder first:
do you see there 2 oemxxx.inf files (where xxx is some number) - one for ST324KJ SCSI Controller (Hardware ID = *STL324);
INSERT INTO `portal_posts_text` VALUES
another for 'Plug and Play BIOS Extension' (HardwareID = \root\BiosEnum0)?

26.11.2002, 17:37
Can you tell me where the INF folder is?

26.11.2002, 18:21

30.11.2002, 03:21
Yes, I can locate those files, what should do next?
I am using Win2K +Sp3 with nero image drive installed.

01.12.2002, 21:39
I Have the same problem
win 2k sp2 installed, and i can easily install 3.23 but didn't manage to install 3.26. I tried it on several computers, and only on a computer with win xp i managed to install it...
i think it's because my win 2k systems have scsi drives, maybe the daemon-tool is buggy with those systems?
what's wrong?

11.12.2002, 19:18
I am running Windows 98 on an ASUS A7V-133 with the Promise chipset. I was able to fix this error by going to the device manager and reinstalling the "Win95-98 Promise Ultra100 IDE Controller" driver from the ASUS installation CD into the SCSI Controller.

Now that I have it working, I don't want to mess with it to determine why the Promise driver failed to work with DT 3.26.

I will leave that to those more knowledgable than I.

01.01.2003, 18:29
I Have the same problem
Windows Me installed, and i can easily install DAEMON Tools 3.23 too but didn't manage to install DAEMON Tools 3.26. :evil:

So i have start the "Task Manager" if the error comes again.
I have cancel the Installation over the "Task Manager".
The Installation canÒ‘t delete the installed files. (Thats important :!: )

I have restart my computer. Now start DAEMON Tools 3.26 automatically and show the error (No SCSI Controller). I confirmed the error.
After this, i look in the "Device-Manager" and install the "ST324KJ SCSI Controller" and the "Plug and Play BIOS Extension", because the .inf files available in the INF-Folder.

After a restart DAEMON Tools 3.26 start and work without errors. :roll:

02.01.2003, 05:09
Hi. I have the exact code error too. I'm using Windows .Net 2003 and I've install every version of DT without any trouble except v3.26. Now I'm stuck with old version :(Daemon-Tools programmers, please fix it....TIA.

03.01.2003, 03:50
Thanks soo much Daemon Tools coders for fixing this problem. I just downloaded v3.29 and it fixed it. To anyone who have this problem, try install v3.29 and see if it helps.

06.01.2003, 00:46
Hi - since this is my first attempt on these boards, I'll first apologise for if there's a solution to my problem.. I tried to find a solution on my problem first, but couldn't - therefore my post here. :)

Installed Daemon-Tools 3.26 without any errors, but when I rebooted, I get a error message "Virtual SCSI Driver not detected" - I go in device manager, sees a ?-mark in front of the aforementioned driver, I then tries to update this by going in windows' INF folder as mentioned other place in these boards - but it still shows the same error..(It says - cannot start the device - code 10) Where can I get a proper driver, or a new cdrom.sys (again, another post states that it might be an error in this sys-file) - or another solution...?

Or might I be going to reinstall my OS from scratch as VeNoM suggest a not-so-few times ;) (That's something I don't want to, since I'm running a internet-server for my g/f, and she'll wank me up for not having inet-access for the slightest period of time.. women u know...)

And by the way - I cannot d/l the latest version of DT - it's 3.29 right? Your website seems to have a 403 error? (Forbidden)??? is it only beta-testers that are allowed?

Great product - by no doubt, great! Keep on! :)

06.01.2003, 00:53
try http://www.daemon-tools.org/cgi-bin/Scripts/daemon.pl?daemon329.exe

06.01.2003, 01:23
Thank you for the _very_ swift reply!


Btw - could you tell what you made in 3.29? Did you make DT check if any drivers were installed, and if not, then install them, or something like that?

This product keeps getting better, as does the programmers! I give thee my respect *bows*

08.01.2003, 04:10
Haha...Daemon-Tools 3.29 sure fixed the installation problem....and I hope they'll keep it that way cause I don't want to go thru that headache again :)