PDA

View Full Version : SCSI Drivers bugged Nero 6 Ultra.



DarthVaderCode
09.05.2006, 07:57
Operating System: Microsoft Windows XP Professional
Version: 5.1.2600 Service Pack 2 Build 2600
System Type: x86-based PC
Burning Software: Nero 6 Ultra Edition version 6.6.1.4
Anti-virus Software: Norton Antivirus 2003
DAEMON Tools Version: 4.00HE
CD Rewriter: BENQ 4816A CD-RW version 9.EK
DVD Software: cyberlink PowerDVD XP 4.0

Hi there! I'm new to this forum, I'll appreciate any help given. (Pardon my English, I'm from Malaysia)

So, here is my problems:

I was trying to burn an audio CD from my MP3 songs, but halfway through the whole process Nero gave me an error: Invalid block address. So it resulted a corrupted CD-R which I can't use it anymore. Then I thought it was something to do with my burner (Not warmed up yet perhaps?), so I decided to use a CD-RW to burn another audio CD for precaution measures.Guess what? The problem still persist and Nero gave that same error and the burning process failed again.I read Nero's log file and discover it has something to do with the SCSI device, other than DAEMON Tools I didn't installed any SCSI hardware.

I uninstalled DAEMON Tools by using it's uninstaller and reboot my PC, full erase my CD-RW, chose the slowest burning speed, disabled my antivirus, firewall, adware scanner, close any background programs etc. I tried burning the CD again, to my disappointment it failed for the third time. But the strange thing is Nero gave me another type of error: Invalid field in parameter. This time I saved Nero's log file and it looks like this:

3:56:49 PM #35 Text 0 File Mmc.cpp, Line 15784
StartDAO : CD-Text - On

3:56:49 PM #36 Text 0 File Mmc.cpp, Line 20401
Set BUFE: Seamless Link -> ON

3:57:49 PM #37 SCSI -1067 File Cdrdrv.cpp, Line 1442
SCSI Exec, HA 1, TA 1, LUN 0, buffer 0x03E70000
Status: 0x04 (0x01, SCSI_ERR)
HA-Status 0x00 (0x00, OK)
TA-Status 0x02 (0x01, SCSI_TASTATUS_CHKCOND)
Sense Key: 0x05 (KEY_ILLEGAL_REQUEST)
Sense Code: 0x26
Sense Qual: 0x00
CDB Data: 0x2A 0x00 0xFF 0xFF 0xDF 0x31 0x00 0x00 0x1A 0x00 0x00 0x00
Sense Data: 0x70 0x00 0x05 0x00 0x00 0x00 0x00 0x0A
0x00 0x00 0x00 0x00 0x26 0x00

3:57:49 PM #38 CDR -1067 File Writer.cpp, Line 304
Invalid field in parameter

3:57:49 PM #39 Text 0 File ThreadedTransfer.cpp, Line 229
all writers idle, stopping conversion

3:57:49 PM #40 Text 0 File ThreadedTransfer.cpp, Line 223
conversion idle, stopping reader

3:57:49 PM #41 Text 0 File dlgbrnst.cpp, Line 1703
Set remaining time: 0:00,000 (0ms) -> OK

3:57:49 PM #42 Phase 38 File dlgbrnst.cpp, Line 1845
Burn process failed at 8x (1,200 KB/s)

3:57:49 PM #43 Text 0 File AudioCompilationImpl.cpp, Line 828
DRM: DRM burn session terminated.

3:57:49 PM #44 Text 0 File AudioCompilationImpl.cpp, Line 857
DRM: Closing entire DRM handling. Bye.


Existing drivers:
File 'Drivers\PXHELP20.SYS': Ver=2.03.28a, size=20640 bytes, created 12/5/2005 1:12:26 PM

(Prassi/Veritas driver for win 2K)
File 'Drivers\atapi.sys': Ver=5.1.2600.2180 (xpsp_sp2_rtm.040803-2158), size=95360 bytes, created

8/3/2004 10:59:44 PM (Adapter driver for rec)

Registry Keys:
HKLM\Software\Microsoft\Windows NT\CurrentVersion\WinLogon\AllocateCDROMs : 0 (Security Option)

Besides, after I uninstalled DAEMON Tools Nero still able to detect SCSI Devices. As you can see from this small part of Nero's log:

Nero version: 6.3.1.17
Recorder: <ATAPI CD-R/RW 48X16> Version: 9.EK - HA 1 TA 1 - 6.3.1.17
Adapter driver: <atapi> HA 1
Drive buffer : 2048kB
Bus Type : default (0) -> ATAPI, detected: ATAPI
CD-ROM: <ATAPI-CD ROM-DRIVE-52MAX >Version: 52RP - HA 1 TA 0 - 6.3.1.17
Adapter driver: <atapi> HA 1

=== Scsi-Device-Map ===
DiskPeripheral : Maxtor 6E040L0 atapi Port 0 ID 0 DMA: On
CdRomPeripheral : ATAPI-CD ROM-DRIVE-52MAX atapi Port 1 ID 0 DMA: On
CdRomPeripheral : ATAPI CD-R/RW 48X16 atapi Port 1 ID 1 DMA: Off

=== CDRom-Device-Map ===
ATAPI-CD ROM-DRIVE-52MAX F: CDRom0
ATAPI CD-R/RW 48X16 G: CDRom2

A quick check with Wikipedia (http://en.wikipedia.org/wiki/Key_Code_Qualifier) says that "Invalid field in parameter" is one the error code from a SCSI device.

I even tried to uninstall the SCSI/RAID Controller, delete any SCSI drivers under the directory C:\WINDOWS\System 32\drivers such as dtscsi.sys, cdrom.sys, scsiport.sys and sfloppy.sys. But failed, it keeps restoring back itself whenever I try to delete them, except for dtscsi.sys.

So I decided to update my Nero 6 from ver. 6.3.1.17 to 6.6.1.4 and clean the Window's Registry. For your info my CD Rewriter has the latest firmware from BENQ's website.

I try to burn again for the fourth time...it FAILED successfully AGAIN.
A small section of the log showed the problem:

10:34:37 PM #40 SPTI -1067 File SCSIPassThrough.cpp, Line 289
G: CdRom1: SCSIStatus(x02) WinError(0) NeroError(-1067)
Sense Key: 0x05 (KEY_ILLEGAL_REQUEST)
Sense Code: 0x26
Sense Qual: 0x00
CDB Data: 0x2A 00 00 01 D2 6C 00 00 1A 00 00 00
Sense Area: 0x70 00 05 00 00 00 00 0A 00 00 00 00 26
Buffer x04710000: Len xf8a0
0xFA 14 6F 1F 02 2B 50 36 EA 3D C6 43 52 3E 7F 3F
0x52 36 3D 35 0A 33 51 31 93 25 53 27 90 10 17 12
0x4F 0A D7 00 CE 0A A7 F6 16 09 52 EF 42 10 14 EE

10:34:37 PM #41 CDR -1067 File Writer.cpp, Line 311
Invalid field in parameter
G: ATAPI CD-R/RW 48X16

I've read DAEMON's forum and found no one (I think so) has encountered problems like mine.From DAEMON's website I downloaded sptdinst_x86.exe and I'm not sure whether it will solve my problems. Futhermore the new version of DAEMON Tools (v4.03) has a number a bugs (I learned it from users in the forum) and some of them have to reformat their HDD and some can't boot their PC and so on. I don't dare to take any unnecessary risks involved.

One more thing, when DAEMON Tools is installed, the login/welcome screen (immediately after the Windows boot screen) sometimes won't appear, the only thing I see is the busy mouse pointer.I have to reset my PC everytime this happens. After uninstalling it, it didn't happen again.

Please advice. Thanks