View Full Version : Unable to mount image file from a DVD

19.05.2006, 20:25
I have been using daemon tools for years and never have had a problem/bug like this.:confused:

When I try to mount a file, appears an error message saying "Unable to mount image. Unable to open file in kernel mode".

The problem appeared one day, I don't know how. I had been mounting an iso file during days, and just one day that error message began.

I have tried:

- Uninstall/Install D-Tools 4.03 again.
- Uninstall and try 3.47.
- Uninstall SPTD.
- Delete manually dtscsi.sys file and reinstall.
- Search on google and your forums for help.
- Install Alcohol software and can't mount any file. It gives me a similar error "file could not be opened by miniport in kernel mode".
- Run spyware tools.

The only thing, I think that would work will be do a clean installation of Windows XP again.
But how did I get to this situation? I cannot mount or use any program to mount files (!!?)

I have been thinking about the day the mounting process stopped working and maybe I had autostart enabled and the image file was in a DVD. That day when I booted Windows the DVD was not in the DVD unit and Daemon Tools tried to mounted it without success, of course. But it's a no sense.

What is "kernel mode"?

Any suggestions? What can I do?

Thanks in advance.

20.05.2006, 04:03
This could be a problem with the files you're using or the burning program that creates your image files. Have you tried using the exact same image files on a different computer?

20.05.2006, 11:07
Yes, I have the image file recorded in a DVD.
And have tried to mount it using D-Tools on other computers and everything has been successful.

In fact, as I have said before the file was mounting correctly in the same computer until one day stopped working.

The problem is no specific with a file, I cannot mount nothing in that computer since that day even using another mount program.

20.05.2006, 11:46
I had exactly the same problem on my machine. In my case it was caused by enabling case sensitive behaviour for XP. I've already wrote to their support hotline about this error more than a month ago, but failed to get a response so far.
I attach the email I've sent; maybe it helps you with your problem.

it seems DAEMON-Tools are having a problem, when case sensitive behaviour for Interix subsystems (see also http://support.microsoft.com/kb/817921/en-us) is activated on XP. If the accordant registry value (HKLM\System\CurrentControlSet\Control\SessionMana ger\Kernel\ObCaseInsensitive) is set to 0, mounting per command line results in the error "Unable to open file in kernel mode".
While mounting per command line doesn't work at all, mounting via awxdTools only results in an error, when the directory path contains lower case characters. E.g. mounting an image C:\A\B\x.iso works well, while C:\A\b\x.iso or C:\a\B\x.iso or c:\a\b\x.iso results in an error. Please observe that the case of the filename is irrelevant, only that of the path is significant.
After deleting the registry value or setting it to a value other than 0 everything works as it should.
I hope this analysis helps you to locate and remove the error in your software. Please contact me, if you have a solution or should you have further questions.
Best regards

Btw. you have to reboot for the changes to take effect.

20.05.2006, 19:20
Thanks z4rqu0n but your trick didn0t solve the problem.

BUT I think I have isolated the problem, seems that is related to the DVD format.
When I try to mount an image from a DVD using
UDF format I can't mount the file, but if I copy the same image file to my hard disk, then everything works OK!!

Is it a known problem with UDF or a new bug?

24.05.2006, 21:47
No I think UDF is alright becouse I write all of my DVDs in UDF format and I can mount images from it. There might be a problem with your Nero ect. which create wrong UDF format.
(Sorry for my PooR/NooB english)

06.06.2006, 09:35
Then how do you explain that the SAME file on the SAME DVD can be mounted in other computers except in my laptop ...:confused:

18.06.2006, 14:53
i'm having the same problem mounting dvd images that are larger than 4.7gb it seems DT only supports images that fit on a single layer disc & not dual layer.

18.06.2006, 17:21
i'm having the same problem mounting dvd images that are larger than 4.7gb it seems DT only supports images that fit on a single layer disc & not dual layer.
I'm using the latest version of DT and that supports images bigger than 5gb (LOTR Battle for Middle Earth 2).

19.06.2006, 00:07
Just the other day I ripped an image of my Underworld Evolution disc (7.4GB) and mounted it in Alcohol before burning. Since the virtual drives are identical for Alcohol and DTools, that means DTools also supports DVD9 images.