View Full Version : i cant find my cd-rom or burner in my computer

26.11.2002, 03:16
i dont know what i did but i was trying to mount an ISO and i was messin with it and ended up not having my cd-rom drive or my cd burner in my computer. i tried uninstalling and reinstalling both daemon tools, and the drives, with no progress. i tried system restore and it didnt do anything. please someone tell me what ive done wrong and how to fix it

26.11.2002, 03:38

What os do you have? Have you or do you have easy cd installed? What other burning soft do you have? Please provide more details...

26.11.2002, 22:19
sorry itsjust at the time i was quite mad and wanted it fixed as fast as possible.... im running xp, my burning program is hp cd writer. i dont have easy cd creator. any idea whats wrong or do u need more info?

27.11.2002, 00:17
Try this:


27.11.2002, 15:31
i love you! thank you very very much

27.11.2002, 18:03
No big deal - that's what we're here for :)

28.11.2002, 16:56
hi all i have the same problem but i have windows 98 se

please help me i'm despered!!!!

thanks in advence!

28.11.2002, 19:12
Why don't you simply check MS Knowledgebase yourself??
Did you try and delete the drives in device manager and reboot??

20.12.2002, 00:28
OK I checked through the MS Knowledgebase and it did NOT help me resolve these SAME issues. First; my system specs:

733mhz PIII,
ASUS P3V4X mobo,
Windows XP Pro; no SP1 installed.
896mb SDRAM,
2 internal hdds,
2 external hdds,
Acer DVD-ROM 16x40 drive,
TDK 16x10x40 CD-RW,
SB Audigy Platinum w/IEEE 1394 sound card,
3D Prophet II Ultra 64mb vid card

I have used older versions of Daemon Tools with NO problems for quite some time. After upgrading to the 3.26 version, shortly after is when these issues occurred, and as of Tuesday night; 12-17-02, my CD-RW, DVD-Rom, SB Audigy card ALL do not load up on bootup. I HAVE tried uninstalling the devices, rebooting, and allowing WinXP to try to reinstall them. I even tried uninstalling the actual hardware from inside the system, rebooting to allow the registry to clear those devices, then shutting down, reinstalling the hardware, and booting up again. NOTHING WORKED. The device drivers have been corrupted somehow due to Daemon Tools. This is the error they all show in Device Manager when I access the properties of each of these devices:

Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)

Click Troubleshoot to start the troubleshooter for this device.

Nothing on MS's site has helped, and I have looked through a crapload of threads here and NO suggestions have resolved this issue. I'd like to NOT have to reformat my C:\ drive to resolve this issue. So if anyone has an additional suggestions to resolve these major problems, I'd be extremely appreciative for them.

19.01.2003, 05:41
Yupyupyup... Im having same problem, and it hit me haaaaaaard!

No cdrom (ide);
INSERT INTO `portal_posts_text` VALUES
no cd-r (scsi) and no dvd(scsi).
Cannot reinstall, im just getting a code 39; no driver found or corrupt...

And i mean it. I really really mean it.
Coz my harddisk are full, so i cant backup the shit on cd, COZ MY CD-R AINT WORKING!

Agh, agh gaghh, guggh *die*... Ok, im not gonna kill anyone, but -I- will for sure die, die die

19.01.2003, 13:28
any chance of using Windows XP's rollback feature? (or whatever it's called in the english version)


20.01.2003, 07:04
Not at all.
Havent had a reboot on my computer for 3 weeks, so there was no rollback available.

But, after one looooooong night of problem-solving, it finally solved.
But, it was several stages involved:

First, i looked for relevant topics in ms knowledge base, directed to "code 39". Had to do some registry changes there.

next, i had to remove all stuff related to cd burner, of software.
Then a complete reinstall of EZCD creator.
And heck, dont you think it STILL didnt work??
So it ended up with lotsa trials and errors, and Roxios forum gave me a solution:
On their homepages is a tool to FORCE installation of updated software, which i had to use... It showed that the patch didnt install completely all software and aborted in the process, but didnt tell bout it....BAH!

20.01.2003, 08:59
We provide NO support for systems having Easy CD Creator installed.
You could read about it in readme and manual.

05.07.2003, 18:07
My cd drives not only disappeared from My Computer (explorer)as in earlier posts, but from my system entirely(Device manager and New hardware wizard unable to locate either of my IDE cd drives.Also BIOS couldn't find drives either. The new virtual SCSI drive was there but nada on the two originals. System Restore did nothing. I had to uninstall Dtools then shut down computer, remove power cord, remove IDE cable from MB replace and reboot allowing BIOS to redetect (it wouldn't redetect until after I went through the hoops listed above) Any ideas on how to proceed as I would like to have Dtools on this partition(an actual separate hard drive in fact on dual boot computerWin 98SE and Win XP Pro sp1)
I have used many versions of Dtools on my Win 98SE partition on this computer and on all three of my other machines on my LAN and think it is awesome software :) I have many cd's that I prefer to keep in pristine condition in their jewel cases while I use images of them instead.

11.07.2003, 21:36
im using xp sp2 (i think, might be sp1);
INSERT INTO `portal_posts_text` VALUES
p4 @2.02ghz, 512mb ram

my cd drive is missing from my computer. it is still under the device manager, but uninstalling, rebooting and reinstalling has no effect :(. ive also tried the kb way, but it didnt do anything for me and have looked through the kb for something that might help, but there was nothing that worked.

dont know if this will help but...just before the drive disappeared forever (daemon tools has always used the cd drive's letter (e) for some reason, but the cd drive always came back after disabling the virtual drive) i started getting errors when unmounting and disabling the virtual drives, something about the device being locked (while unmounting) and daemon tools crashing when disabling. i have tried uninstalling daemon tools and then reinstalling the drive but again, no effect. is there some way i could fix this without taking my comp apart? (it is still under warranty and if all else fails ill get the store to fix it)

11.07.2003, 21:45
Please post any other burning software installed.

Please also go into device mananger, goto your cdrom properties, and click driver details. Post all drivers listed.

11.07.2003, 22:14
i have blindwrite installed as well.

for drivers...i have:

plz hurry with the response...i have 3 hours until my dad gets home and when he finds out the cd drive is fucked im dead :x

12.07.2003, 00:24
This is a software issue. You should try unininstalling blindwrite. Do you see any errors in cdrom properties?

At worst, a format should fix your problem.

12.07.2003, 00:54
If his dad returns and sees drive is formatted - he's dead twice. :lol:

12.07.2003, 00:58
there are no problems with the cd drive (physically);
INSERT INTO `portal_posts_text` VALUES
the drivers are all installed properly, before i uninstalled clonecd, i could still create an image file from a cd in the drive and before i uninstalled nero,infotool still showed the cd drive, but the drive letter was @:\ where it used to be e:\. the only problem i have is windows (fucking bloatware shit) doesnt know where it is. im thinking that i need to assign it a drive letter but im not sure how to do that in winxp :\

i uninstalled nero, uninstalled the cdrom drive, rebooted, let windows do its shit, rebooted again and still nothing...and formatting isnt an option at this point (80gb hard drive and i have to have this working in...*looks at watch* 20 minutes tops).

12.07.2003, 01:02
Click start, run, type diskmgmt.msc, click ok. From here you can change drive letters.

12.07.2003, 01:18
what i meant was ADD drive letters and i figured it out on my own already :)

diskmgmt.msc only lets you change the drive letters (unless i missed something);
INSERT INTO `portal_posts_text` VALUES
so this is what you have to do:
1) Open the command prompt (start->run, type cmd and click ok)
2) Type in diskpart and hit enter. this brings up what i think is winxp's version of the old fdisk command, but that might not be right...
3) type list volume at the prompt. this will list ALL the drives/partitions that are attatched to the computer, not just the ones windows recognizes.
4) type in select volume #, where # is the number of the volume you want to modify.
5) now, from here you can do two things, remove letter=x or assign letter=x, where x is the drive letter you want to assign/remove (and i hope you know which command does which;)).
6) your drive should now appear in my computer and be accessible from the drive letter you specified.

andareed, thanks for all the help, i appreciate it. i hope the above helps someone else (it is in windows help, under Assign, Change or Remove a Drive Letter if you want a different explaination). thanks again for all the help.

03.07.2007, 17:42
The problem is this
I cannot see the CD-RW icon in My Computer
Yellow icon in device manager against the drive name.
Description shows
"Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)"

This happened after i upgraded to the WinXP from Win98
The drive had worked perfectly for past 4 years...till now. and now also I used it to install the same WinXP....10 min ago!!! So drive failure ruled out. BIOS shows drive correctly.
Win XP SP2
AMD 2000
LG 52X-32X-10X CD-RW GCE8525B
This is What I have tried so far - and prblem not solved yet:
1. Rebooting : Didnt help
2. Removing and Reinstalling the drive in Device Manager : Not useful - it reloads the old drivers
3. Upgrading the driver : Win says it is having the best driver . will not upgrade.
4. The registry edit suggested on the various forums, including this one.
Source: http://support.microsoft.com/kb/320553/
In this I can not find the reg values mentioned .
UpperFilters and LowerFilters,
I searched. They are not present.!!!!
5. I have considered another solution suggested: The device Firmware upgrade for the CD-RW drive itself !! Found it on LG site. The warnings on the site freaked me out....:confused: Will it be really required ??
I request all you good people out there to suggest me further.
I do not wish to re-install. Somehow i suspect a re-install will give same problem again. I am very scared to do that drive hardware upgrade . it may spoil the drive permanently.
Is a good driver of GCE8525B available for WindowsXP-SP2
and Is ther a way to force system to take this new driver?

03.07.2007, 17:59
Upgrades are a bad idea. Anytime someone wants to upgrade their OS, I always recommend they do a fresh install for just this very reason. I wish you luck in finding a solution, but my suggestion would be to skip the troubleshooting and just format the drive.