PDA

View Full Version : "DISK BOOT FAILURE INSERT SYSTEM DISK" error upon startup.



JustSomeRandomGuy
10.07.2006, 05:09
Here's my deal.

Installed Daemon 4 yesterday. Had a bunch of stuff on the computer. I also installed a program called "SD4 Hide" to run a game.

After rebooting, I keep getting the error before the Windows XP boot screen that says, "DISK BOOT FAILURE INSERT SYSTEM DISK AND PRESS ENTER".

If I hit enter a bunch of times, it goes through to Windows. I beat said game. Uninstalled Daemon Tools and I'm still getting the error. I tried disabling spdt in Regedit, and I removed it with the Daemon Tool.

Still get the error.

I then tried reformatting the drive and reinstalling Windows.

I still get the error.

So, board members...here's the million dollar question...how do I fix this, or am I out a 300GB drive, which would seriously piss me off at Daemon?

System Info:

Windows XP SP2
SATA Maxtor 300 GB (6B300S0)
SATA Western Digital Caviar

I have an Asus 8N1 mobo, but I haven't installed the drivers for that.

LocutusofBorg
10.07.2006, 06:04
I then tried reformatting the drive and reinstalling Windows.

Wait, wait - so you FORMATTED and REINSTALLED Windows?

Same with this:


I tried disabling spdt in Regedit, and I removed it with the Daemon Tool.

What you mean with "tried" - did you removed it or not?

Short story is this: for me, it seems to be a hardware-failure.
(Note that hardware-failure here does NOT mean necessarily
a wrecked HDD!)

When you disabled DT AND deleted SPTD - no DT-component is
loaded anymore. If you reformatted your system - well, common, I guess I do not have to tell you what that means,
yes? Then I can guarantee you that NO software at all
caused it - its then simple hardware-failure or one of the
following possible reasons:

- you do have a 3,5" disk in your floppydrive
- you have some disc in cd-drive
- you maybe have external USB-hdd somewhere plugged-in?
- or maybe an USB-stick?

- in general: did you maybe changed something with your
hardware? Please post here IF you changed something, even
if it seems of no interest to you!

*So please check if the cabel from HDD to your port is ok
*check your CPU-temperature
*check your MEMORY (!yes - this CAN cause also such errors!)
*check that the correct HDD is entered at boot-sequence in BIOS
*check that your bios still detects your hdd - and correct!
*check your batterie-status (this can cause datalost in your CMOS and therefore sometimes "bad things" like this one happen ; )
*When you checked ALL of the above possibilities, come
back and we will go on and try to help you!

BTW: I hope you downloaded DaemonTools HERE from OUR
website - at least SD4HIDE however is NOT available here.
Did you checked your system for VIRUSES?
Apart from the fact that your HDD after reformat should be
clean (maybe partition-table damaged)....... you see it is nearly impossible to simple
say: ah! thats it for sure, now do this or that...

- or you manipulated your boot.ini? You maybe even have
some strange kind of bootsector-virus?

All I can rest assure you: Daemon Tools is not the
culprit here, but we can try to find a solution for your
problem. That the prob still persists AFTER a reformat
however let me think its simple a HDD-failure or maybe
one cable is not properly plugged-in, it could be even
an overheated CPU or bad memory!

For sure it is not DT-related when you reformatted your
disks - I guess that will everyone confirm you, here on the
board or elsewhere.


Apart from this: please just write plain simple about your problem - I do not want to read something like "...and that would piss me off at Daemon".... yes, I know this is all shit,
I would be angry myself if I where you. But it could not harm
to first find out what caused the problem instead of bashing
in our direction first - especially if we did NOT cause the prob
and you get help here for free, as well as you got Daemon
Tools for free.

JustSomeRandomGuy
10.07.2006, 06:35
Wait, wait - so you FORMATTED and REINSTALLED Windows?


When I started looking through the board here, and hadn't found any answers, yeah, I went with that, as I figured it was going to be quicker. I reformatted the boot partition and reinstalled Windows.

However, the other two partitions on that same drive have not been reformatted. One of those partitions is the one I installed Daemon on.



What you mean with "tried" - did you removed it or not?

Sorry, I misspoke. I tried disabling the key like one of your other notes mentioned by setting the "Start" value to 4. That didn't work. So I removed it with the tool. That didn't work, either. When I removed it separately, Daemon also wouldn't uninstall.



Short story is this: for me, it seems to be a hardware-failure.
(Note that hardware-failure here does NOT mean necessarily
a wrecked HDD!)

All this stuff is under 3 months old. I would be VERY surprised if something ate it after this short a period of time.



- you do have a 3,5" disk in your floppydrive
- you have some disc in cd-drive
- you maybe have external USB-hdd somewhere plugged-in?
- or maybe an USB-stick?


No 3.5" drive on this machine.
The boot order is set to use HD first, and will actually boot off the CD.
I do not own any external USB Drives.



- in general: did you maybe changed something with your
hardware? Please post here IF you changed something, even
if it seems of no interest to you!


I changed absolutely nothing. I rebooted to let it install sptd. After it installed Daemon, I played through the first 3 levels of the game, and shut off the machine to eat. When I came back and powered it up, I got that error. I have gotten it ever since. The machine won't boot into Safe Mode, only Normal.



*So please check if the cabel from HDD to your port is ok
*check your CPU-temperature
*check your MEMORY (!yes - this CAN cause also such errors!)
*check that the correct HDD is entered at boot-sequence in BIOS
*check that your bios still detects your hdd - and correct!
*check your batterie-status (this can cause datalost in your CMOS and therefore sometimes "bad things" like this one happen ; )
*When you checked ALL of the above possibilities, come
back and we will go on and try to help you!

The drive shows up in Windows, so I'm certain it's connected.
CPU Temps are low.
RAM is fine.
The BIOS doesn't let me enter the HD boot order, just HD, CD, Floppy, etc.
The BIOS detects my HDs fine, proper size, maker, and connection.
The CMOS battery's fine, otherwise my clock would be resetting.



BTW: I hope you downloaded DaemonTools HERE from OUR
website - at least SD4HIDE however is NOT available here.

I got it from here. As you say, I had to get SD4HIDE from another site.



Did you checked your system for VIRUSES?


I haven't done that yet. I'll do that while waiting for a reply.



Apart from the fact that your HDD after reformat should be
clean (maybe partition-table damaged).......

That's kinda what I figured. I thought the reformat was the worst-case scenario...



- or you manipulated your boot.ini? You maybe even have
some strange kind of bootsector-virus?

I did no such thing. I doubt I have a boot sector virus, too.



All I can rest assure you: Daemon Tools is not the
culprit here, but we can try to find a solution for your
problem. That the prob still persists AFTER a reformat
however let me think its simple a HDD-failure or maybe
one cable is not properly plugged-in, it could be even
an overheated CPU or bad memory!

The only one of those alternatives you suggest that is feasible is that the HD went bad. I have a nice big case, 3 fans, and a Zalman Golden Orb on the CPU. My RAM's from Kingston and it's only 3 months old, just like all the rest of the parts.

How a HD would go bad after 3 months of use, and yet still be bootable, though, is really odd. So, in my book, it looks like something software screwed with something. When I tried to boot into safe mode before, I was getting a BSOD, but it was going by so quick, I couldn't read any of it.

This isn't a standard hardware problem. I'm looking in the general direction of DT, just because of the nature of the program and how it has to basically trick Windows. Do you guys write anything to the CMOS? If so, should I remove the battery to clear it?

LocutusofBorg
10.07.2006, 07:17
I reformatted the boot partition and reinstalled Windows.

Yes, I see

The other partitions doesn't matter, as your windows-partition
is your boot-partition, yes? After your reinstall&format -
everything DT-related IS gone. DT is therefore not the
problem here. When you make it to your windows, check
for yourself:

c:/windows/system32/drivers -> is there anything that looks
like SPTD.sys?? No? Then DT is not active anymore at all.
(And I doubt it is the case, as you, like you mentioned above,
reformatted windows, otherwise we invented real great
possibilities for virus-creators LOL)

No, seriously: We do not write anything to CMOS.
I have atm only explanation that your HDD or another
component is gone then, sorry. However, maybe one of
our other team-members or users have a clue. For sure when
I think about it I can find other explanations, but you should
first eliminate every other possibilities before

(example: make SURE your system is virus-free, take your
hdd and check if device works in another system (at least
start to boot normal), check and SWAP cables! You wouldn't
believe how often I saw exactly THIS error because of a
damaged cable that was optical ABSOLUTELY ok!!!)

Same with RAM -> what make you sure that its ok?
Because its 3 month old? Do you think everything MUST
be intact and can only fail after quite some time?

Especially my IBM-HDD's (special series) got down after
3 days (brand new!) and not ONE but four!!

Please check CAREFULLY first what I suggested above,
it doesn't help you to say "I can't believe the cable is
damaged and/or the RAM just because its relative new!

I will speak later with one of our absolut hardware-experts,
maybe he have something to add here, so stay tuned
(but don't hold your breath, I reply later this evening)

LocutusofBorg
10.07.2006, 07:28
OK, the user reported:

Problem gone after CMOS resetted.

Good to know that this story found a good end... and again it shows:

Just take our advices - otherwise we can't help, at least a try could not harm