View Full Version : Weird Install Issue

24.07.2006, 00:23
Hello everyone! I have been useing DT for a few years now on all my other machines and I have just recently built this new machine and finally updated to SP2. I also Finally got around to installing DT on this machine. First let me preface this by saying I have read through and tried everything I could find on these forums and non has worked so far.

It all started with a fresh download and install of DT 4.03HE. I started the install and is said it had to install some sort of SCSI passthrough something, so I did. Then it restated and ran the install. At the end of the install, it asked "Run DT now" and I checked yes. BOOM, BSOD due to "page_fault_in_nonpage_area" or something like that. So I went into Safe mode and uninstalled and cleaned all drivers out of the drivers folder for DT and then followed a post from in here about deleting all SPTD entries out of the Reg. I then restarted and all was good. Began reinstall again and same thing, only this time I didnt autorun it, I started it from my desktop myself and BSOD, this time was for a driver conflict, my "AFS2K.sys" driver was to blame. So I looked into that driver and it was supposedly an audio system file for oak technology inc. So I removed it thinking it was one of my newer audio files and all was good. Installed ok, and when I ran it, seemed to work. But I noticed that I could not assign a drive letter to it and then noticed my real CD/DVDRW drive (d) was not showing either. I went into my device manager and saw that there was a conflict saying it couldnt load all the drivers needed and turns out the the driver I removed was for that. As soon as I replaced that file, boom, BSOD again. I am not sure if it is windows XP SP2 causing this or my raid configureation, but I would really appreciate some help on this. Feel free to email me or MSN me @ mattolive@comcast.net.... that is ONLY used for MSN Messenger, not my actual email... that can be found in my profile.

Some usefull info on my system specs incase you need it to help:

ASUS Mobo A8N-SLi deluxe
AMD Athlon 64 3800+
2 Gigs ram PC3200 ddr 400
2 Raptor 10k rpm HD's in raid 0
1 Maxtor 200 Gig HD (Storage)
2 BFG Nvidia 7800 GTX OC Vid cards in SLi
1 Optorite DVD/RW

Any ideas or insight would be much appreciated!! So thanks in advance.

24.07.2006, 10:47
Remove afs2k.sys again and then edit your registry (regedit.exe) and search for upperfilter and lowerfilter. Remove any traces of afs2k.sys from those keys. Reboot, and you should be good to go.

24.07.2006, 12:41
But I need that file for my real CD/DVD ROM to work so I dont beleive that to be an option. I do understand what your saying as far as removing it, but it is needed to make my drives work plus the virtual drives as well. But thanks for the reply.

24.07.2006, 15:36
Check the manufacturer for an update of that driver, certain issues where actually fixed in the past when users updated afs2k.sys. Although I doubt that this driver is really required to get a CD/DVD drive to work.

24.07.2006, 23:06
It's only required because it's in your upperfilters and lowerfilters keys. If you remove it from there, Windows will no longer check for it's presence and it will no longer be required. Trust me, I know what I'm doing (*cue Sledge Hammer music*).

25.07.2006, 03:01
LMAO..... ok, not sure if I truely understand this Upper and lower filter thing, please explain it. I know it has something to do with the system registry, but I dont understand how to do anything with it for these purposes. Thanks again guys!

25.07.2006, 11:23
I'll try to clarify.

1) Go to Start -> Run
2) Type regedit in the run box and press enter
3) Browse through the directory structure to the following key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Class
4) Click on the menu item Edit then Find
5) Type lowerfilters and press enter.
6) Double-click on lowerfilters and remove afs2k from the list. If it's the only item listed, replace it with cdrom.
7) Search for upperfilters and repeat the same steps as 6.
8) Close regedit and reboot.

DISCLAIMER: Editing your registry incorrectly could lead to a malfunctioning or non-operational system. The instructions above should not affect the systems ability to boot, but you do so at your own risk. You have been warned.

26.07.2006, 23:56
Thanks for help bro, much appreciated.... I will give it a shot!