PDA

View Full Version : Possible problem with updated BIOS on certain Promise controllers



Ryiort
01.08.2006, 22:11
I have encountered a problem with my Promise SuperTrak EX8350 controller after I updated the BIOS on it.

When I did that I got a BSOD after I logged onto my system (when it loaded the different things for the account).
The BSOD was a STOP error one with the IRQL_LESS_OR_EQUAL (I forgot if that's the 100% correct wording - pretty sure I'm missing a word after IRQL) message. It did not report what file caused the error. I have the mini dump file, but I don't have the event viewer log entry any more (probably got removed when I reverted to last known good configuration - and also why I can't get the exact message for the BSOD).
I also tried an older BIOS version (newer than the retail though), but that didn't help either.
I also tried uninstalling motherboard, controller and display drivers, still with no luck.
After that I reinstalled Windows to try and locate the problem (which is where the new dump is from) and I'm currently running without DT installed (obviously). As soon as I tried installing DT the BSOD came back.

Booting in Safe Mode didn't give the BSOD.

Odd thing is that when I had the retail version of the BIOS installed and DT I would only get transfer speeds of 6 MB/sec from harddrive to harddrive. Booting in Safe Mode would give me normal transfer speeds (which, to say the least, are a bit faster). And now, without having DT installed, I have normal transfer speeds.

I don't really think it's SPTD that's directly causing the problem, but it's most likely some combination of what I have installed that are causing a conflict. However it only happens when I install the SPTD and are running with a newer BIOS on my controller than the retail one, so SPTD still seem to be a key. There's also the issue with the slow transfer speeds, but I don't know it SPTD is to blame for that, although it does look like it plays a part in that too.


Some system specs:

AMD Athlon 64 X2 4800+ (with the AMD dual core optimization patch installed).
Asus A8N-SLI Premium (with the newest drivers).
Promise SuperTrak EX8350 PCI-Express RAID controller (with newest BIOS and drivers).

Running WinXP SP2, with all hotfixes and what not.
Also using Norton AntiVirus 2006, with all updates.


Hope someone can help solve whatever the problem might be, since I'd like to get DT back on my system :)

Thanks in advance.

Copytrooper
01.08.2006, 22:43
Please send the dump unpacked (i.e. not ZIP'ed nor RAR'ed etc.) to support@daemon-tools.cc with reference to this thread.

Ryiort
02.08.2006, 07:18
It's mailed and I should probably add that it's the dump directly after the DT installer asks you to reboot the system to install.

And I don't have any CD/DVD burning software installed currently - or other stuff that should have an effect on I/O operations (from what I can gather at least). The system is pretty bare-bone now after I reinstalled and that's also where dump is from.

Let me know if you need me to try out various things and I'll do so.