PDA

View Full Version : Invalid track number in sub-channel file



nicfournier
09.11.2002, 03:41
Hi.

Daemon tools is really good work. I discovered it two weeks ago and I am really happy. There is only one thing I am not able to do right now. First I have created a clonecd of my warcraft 3 cd and it works really well. But I also have a CloneCd image of Civilisation Call To Power that I just can't mount. It gives this "Unable to mount image. Invalid track number in sub-channel file."

I know that the file is good because I know who made it and he burned the image to a cd successfully. I also burned the image to a cd and it works great. If you want the sub file that does not works, I can provide it to you. Bit hard to provide full cd :-) Problem is we do not remember which version of clone cd was used to grab the image. I can say that I can burn the image with the latest clone cd (being 4.1.0.1). I have windows XP (no service pack) on a AMD Athlon 2000+ with 256 MEG RAM. I run latest d-tools (being 3.23).

Thanks for any help.

Development
09.11.2002, 10:43
Your subchannel file is corrupt. The fact it works after burning means nothing. Maybe it was made by buggy version of CloneCD, which wrote wrong data into SUB.

nicfournier
09.11.2002, 16:52
Hi.

I just don't understand how Clone CD can open and write a corupted file.

Nicolas.

Development
10.11.2002, 03:07
Your sub file contains wrong track numbers in subchannel - exactly what the error message says. For every track there must be exact match of actual track number and the value stored in subchannel.
The broken file may be because of incompatiblity of dumper with current drive. You should try another drive or program to create new image.
This error may be not fatal for physical drive though but Daemon performs this check to make sure the image is absolutely correct.
This should never happen and I don't know any protection that could currupt specifications in such a way, that Daemon should ignore it.