PDA

View Full Version : SCSI/RAID Host Controller??



Skelly89
03.08.2006, 18:25
Firstly what is it and why did windows say that its found new hardwear after installing DT and never completes automatically installing this hardware what can i do?? :confused:

Copytrooper
03.08.2006, 19:13
It is Daemon Tools virtual SCSI controller where the virtual DVD-ROMs are "connected" to.
What exactly happens? Any error message during installation, any devices with exclamation marks in device manager, any error messages regarding SPTD or DTSCSI in system event log (run eventvwr.msc)?

Skelly89
03.08.2006, 22:30
the automatic installation is still running from when i posted earlier so i guess that'll never end, i presume it needs to be installed to get DT working correctly as DT still says it is loading. When i go on the device manager the SCSI/RAID Host Controller has an exclemation mark next to it.. how do i solve this?

Copytrooper
03.08.2006, 22:48
So what kind of error is mentioned in device manager? And what about system event log, anything there?

Skelly89
04.08.2006, 07:49
it says... This device cannot find enough free resources that it can use. (Code 12)

If you want to use this device, you will need to disable one of the other devices on this system.

and because this is not working DT not working

Underheaven
05.08.2006, 16:10
So maybe you're out of IRQ's or IO Addresses. Try disabling one of your PCI cards.

Jito463
05.08.2006, 18:55
Check your BIOS to make sure ACPI is enabled. If not, then SPTD cannot start properly.

izmenar
05.08.2006, 19:42
hi guys

im using xp/pro sp2 (fresh installation) ,the os is on a sata drive . after reboot of installation (dt 4.oo/4.03) i get this error:

"The device SCSI/RAID Host Controller cannot be stopped right now.Try stopping the device later"

and

"Unable to add adapter.Device problem 12."

I dont know what to try anymore .hellp

Durandle
06.08.2006, 01:01
I have the same issue. I updated my BIOS, had some system trouble, changed which HD is the initial boot drive, now I get this error every time I try and install.

izmenar
06.08.2006, 12:14
I downgraded bios and reinstalled xp


-the problem seemd to be installing windows with "Plug and Play OS" bios setting ON
-installing Win with this on somehow completly disabled ACPI in my PC and also nothing on a PCI slot workt
-The thing is i installed win with this option ON some time ago and everything was ok

Everythin work ok now

Durandle
06.08.2006, 14:12
Hmm Downgrading my BIOS and re-installing XP doesn't seem like a good fix to get a single program working. I'm pretty sure there must be a fairly simple solution to this.

Interestingly, I get the same error when trying to install Alc. 120%.

Durandle
06.08.2006, 14:41
Ok, here we go for another solution....

I just fixed it by changing the hal.dll (Hardware Abstraction Layer) I had installed. For some reason, fixing my XP install after the BIOS issue went and installed an non-ACPI version of the DLL (actually, I think after the BIOS update the bios defaulted to ACPI off, which would explain it).

Basically, only do the following if YOU KNOW WHAT YOU ARE DOING as it can totally break your XP installation. Note this is for single CPU systems. If you do a bit of research into hal.dll you'll find there are other versions on the XP CD for different computer setups.

1. Insert XP CD
2. Copy I:\I386\HALACPI.DL_ to your desktop
3 Rename to HALACPI.ZIP
4. Unzip
5. Rename the unzipped file to hal.dll
6. Copy hal.dll to /windows/system32/
7. Overwrite the old hal.dll
8. Restart
9. Windows will want to reinstall a bunch of drivers (maybe) and restart again.
10. The issue should be fixed (if it was a problem in the first place)

Please please please don't go doing this if your unsure, cos I don't want a bunch of people coming back here and saying "I screwed up my XP install!!"

Copytrooper
06.08.2006, 15:02
Better rename the old hal.dll, then copy the new ACPI hal.dll into drivers directory, so you can "switch" in case of problems easily by renaming them again. ;)

Durandle
06.08.2006, 16:09
Ah now ya see, that would be the sensible idea... I don't do sensible :P

biba.butzemann
16.08.2006, 12:52
Regarding the way just to rename the hal.dll and replace it with that one from the xp cd. It directly screws up you installation. It tried it by my own.
The better way is to use the following parameters in you boot.ini
that it look like this e.g
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows Xp ACPI HAL" /fastdetect /HAL:halacpi.dll /KERNEL:ntoskrnl.exe
. Attention, this is the configuration for a single cpu system!!! If you are running dual/multiple cpu system you have to use a different kernel!!

biba.butzemann
17.08.2006, 09:35
Finally, i tried so much. Almost everything i could find regarding this problem. And i came to the point, that i had to reinstall my operating system. After that, it worked fine :-) But that couldŌ‘t be the only way i hope