PDA

View Full Version : Have to reinstall DT4.0 every use



sukamathum
06.08.2006, 00:35
hi i just posted to see if anyone might have some advice for my problem. ive spent a couple days reading through some other threads, but still no go.

so here it is: i can install/remove daemontools 4.0.3 perfectly fine. if i run it immediately after installing, it works normally - but once i reboot, or exit out of the program, and try to open it again, i get the initialization error:

Initialization error.
This program requires at least Windows 2000 with SPTD 1.21 or higher.
Kernel debugger must be deactivated.

i've tried reinstalling sptd (used "spdtinst_x86 add" in safe mode), turning off debugging in system properties, and running starforce removal program (which reports no protection drivers found). but im still limited to uninstalling the entire program and reinstalling every time i want to use Daemontools. any help? thanks much.

Underheaven
06.08.2006, 01:49
You're not using the latest version. The latest version comes with SPTD 1.25 and gives a warning about 1.24 or 1.25 (i'm not sure which).

This problem happens if you're PNP system is corrupted. You can try to reinstall your service pack and see if that puts your system back to normal.

sukamathum
06.08.2006, 06:44
ok, so i re-downloaded the installer and now i get the error message as 1.24, yay

the only difference now is when i try to run sptdinst add, even in safe mode, i cant avoid the "failed to open config" message. errors upon errors.

at this point i want to see if i can solve this without having to reinstall service pack - is there a way?

thanks

Copytrooper
06.08.2006, 10:40
Rename sptd.sys in Windows\System32\Drivers folder and reboot, then run regedit and remove the following key in registry:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\sptd
Then try again.

sukamathum
06.08.2006, 18:19
im really sorry, but im kind of lost. what do i rename it as, and in regedit, i should just right click and delete the whole folder named sptd?

Copytrooper
06.08.2006, 18:41
Rename it to whatever you want, e.g. sptd.sy$. ;)
And in registry you should delete the whole "folder", exactly. But you must reboot before you do that!