PDA

View Full Version : Real optical drive's DMA now broken....



ShumOSU
17.09.2006, 02:18
Hello. This is pretty similar to some other posts, but I don't think it is the same. Since I installed DT 403-x86 my physical drive has not been behaving. I did initially have some problems on install with SPTD.

Symptoms:
- Put in a CD and the drive spins up. Nothing autoplays and if I try to do anything with the drive in explorer, WinXP pretty well freezes up until I eject the disc.
- Put in a DVD and not much happens. Nothing autoplays and if I explore the drive it shows no files.

The drive DOES show up in explorer, and I have NOT touched Roxio.

I think that the drive is physically OK because:
- The drive was working just fine.
- The drive shows up in my BIOS.
- I can still boot from CD
- I tried a friend's optical drive on my system and it had the same problem.

The transfer mode of my drive's IDE channel defaults to "DMA if available" and uses Ultra DMA Mode 2. I found that if I switch this to "PIO Only" then the physical drive will work, just a lot slower. (I am pretty sure that when I boot from CD then it is using PIO mode)

I have uninstalled DT4, made some various registry changes suggested in threads, got rid of SPTD.sys.

I did try to "repair" my WinXP installation but no luck. I am really, really hoping that I do not have to do a full re-install.

I searched the forums for DMA/PIO stuff but no threads, so I figured I would start a new one. Let me know if this has already been covered.

WinXP SP2; McAfee; Had Nero but deleted it;

Thanks!

Sir Camehan
19.09.2006, 11:31
To get out of being locked into PIO mode, for me, I just delete the IDE controller in Device Manager that has my DVD burner (which is on a seperate controller from my harddrive, to stop any possible problems if I did delete the channel with my HD on it too.), then I restart my PC. Then the problems associated with PIO mode disappear.

Also, you could try switching which IDE channel that the drive is on also, to get out of being locked in PIO mode.

I hope this helps.

ShumOSU
20.09.2006, 07:22
I did try deleting the IDE controller for the DVD drive but no luck with that. I haven't tried switching the channel that the drive is on so I will give that a shot.

Thanks for the reply Sir.

Sir Camehan
21.09.2006, 00:42
I also found a very nice site that explains most of the possible solutions to DMA stepdown to PIO mode:

http://users.bigpond.net.au/ninjaduck/itserviceduck/udma_fix/

I hope that helps too.