View Full Version : DT + U3 enabled usb devices

03.10.2006, 19:56
I have a Sandisk U3 1gb usb key which I use very often. Since I installed DT (running 4.0.6, however I never had a prev. version installed since I got the usb key, so I don't know if this is version specific), it stopped working.

The U3 system has 2 parts - one part is a normal removable usb drive which always works even with DT installed/running, however the 2nd part is a CD emulated drive which contains the U3 launchpad software, and applications. With DT emulating a drive AND/OR all emulations enabled, the U3 CD drive is "unreadable" to Windows (XP Pro in this case). The system fails to access the U3 launchpad, and basically renders the U3 CD drive useless.

If you disable both all emulation features AND all drives in DT, then plug in the U3 usb key, everything starts up fine and the U3 emulated CD drive works and the U3 launchpad is started.

Now, it's not such a bad thing since I at least found out how to get my U3 drive working (I thought it had gotten corrupt at first!), however there are many times when I wish to use both the U3 usb key AND DT.

Am I the first to report this problem with U3 devices? I searched the forums and found nothing with "u3" in it, so I'm not sure...

12.10.2006, 03:26
There is another thread talking about USB issues with a certain motherboard, but in that thread a few users with different boards (including myself) noted that their USB stopped working after the latest STPD update.

I agree it sucks, I have to use a different computer right now to access my stuff.

18.10.2006, 21:09
Yeah, I noticed those threads as well - it doesn't apply to my issue at all however since I'm not using the same type of motherboard, and it's only a 32bit processor (believe it was 64bit XP experiencing the problem only?).

My USB systems function 100% - it's just the U3 specific CD emulation thing it does that breaks. I can still use the USB key as a drive, I just can't start up the U3 Launchpad at all unless I disable all DT drive emulation, and disable all emulation options.

It sucks - right now I've just got DT not running at all - whenever I need to mount an ISO, I make sure my U3 drive is removed first, then I start up DT.

19.10.2006, 20:00
Well, nutbar, I got DT 4.06 and a Sandisk U3 1GB USB Drive just like yourself and they both work perfectly together.

Like you said, the U3 creates 2 drives everytime I insert it:
L: which is the emulated drive with U3's Launchpad/system, and
K: which is the physical drive itself; both work ok all the time.

Just for your guidance, my mobo: ASUS P5ND2-SLI, processor: Pentium IV 3.0 HT (32 bit); Memory: 1GB, Sound: Audigy 2ZS; Video card: ATI Radeon X850XT; Windows XP SP2 fully updated.

I don't know if it matters, but my system was firstly installed with DT 4.03 and I just updated to the newest 4.06 (upgraded from SPTD 1.28 to 1.29, as recommended by the DT Team). And also note that I already had DT installed when I bought the U3 drive.

Anyway, (I don't know if it's the case - sorry if I'm saying something stupid...) have you tried upgrading the SPTD to 1.29? Maybe it will work...

I hope you fix your problem soon.

EDIT: I have just tried the U3 drive on my neighbour's computer (He doesn't know the specs) and he has DT 4.06 and both are working ok.

02.11.2006, 15:56
SPTD 1.35 should fix U3 issue.