View Full Version : Incorrect CD-Track length after copying Mechwarrior 2 and mounting.

07.10.2003, 03:01
Okay, heres the problem. I have tried using alcohol, and clonecd to copy my mechwarrior 2 cd, but the copied image, does not have the propper track length for tracks 26 and 27. Ive tried with and without subchannels on data and audio, i cannot seem to get around this issue.

Original cd-track length: #25 = 1:59
Original cd-track length: #26 = 0:05

Mounted cd-track length: #25 = 1:40
Mounted cd-track length: #26 = 0:25

All of the other tracks are perfect, and the cd music plays fine (except the last two tracks, where they play fine, but the end of track is in the wrong place.) All of my other games ive copied have worked without any flaws. Does anyone have any idea why this might be happening?

Ive mounted with alcohol, and ive mounted with d-tools, both display the error. Ive tried ripping with different cdrom drives, and using different formats.

Theres only one thing i have not tried, that would be re-burning the image to a cd, and seeing if that worked, but if it does not mount correctly, why would it burn correctly? Sure i could burn it from the image file i created, instead of 'on the fly' from the mounted image. But if that worked, would it mean that there is some sort of flaw with the mounting process in both alcohol/d-tools?

One more note, i tried using ClonyXXL 2015 to see what protection is on the cd, there dosnt seem to be any, however, the cd does seem to have bad sectors on it on it at position ~62740 (that should still be in the data-track if im not mistaken, instead of on the last cd-tracks, shouldnt it?) It freezes my computer when it gets to that section if im looking at it in my cdrw. If im looking at in my dvdrom, it freezes for 2 mins, then releases and says bad sectors.

All that said, the cd does not physically look scratched, or damaged, but it is 6-8 years old.

Does anyone here have any suggestions on what the cause of the problem might be?

Any help would be appreciated, thanks for your time.



OS: Win98 SE
MB: Abit NFS-7 2.0 (Bios 1.6)
Processor: AMD XP 2500+ (Barton) @ 1.826ghz
Ram: 2x 256 Corsair XMS PC3200 @ 2-2-2-6-? @ 333mhz
Video: ATI Sapphire Radeon 9500np (128 bit)
Sound: Creative Soundblaster Live
DVD: Samsung - DVD SD-608 - 40x8
CDRW: Lite-On - LTR-52246S - 52x24x52

07.10.2003, 05:47
One thing i forgot to mention, and after re-reading my post i think someone might mistake it for meaning that i want to make a cdr copy of the game. That is not the case. I just want a 1:1 image that mounts and plays back properly.

The biggest advantage of mounting programs is to get way from persistant cd spinning up and down lagging up gameplay and in general creating noise, not mattering if its on a cdr or original, im trying to avoid it entirely :P

So again, if anyone has suggestions that might apply to this, let me know, i would really appreciate the help.

I thought i read somewhere that mounting programs, or 1:1 copying programs had problems copying very small audio tracks in some cases, could this be what is causing this problem? I wouldnt think that to be the case, as some other cds i have copied have very small audio tracks, and there didnt seem to be a problem.

I dont know where i read that at, and i have been unable to find it again, if anyone has any information regarding that, id like to hear what you got.

Anyways, thanks for your time.


07.10.2003, 11:53
Did you post this problem also in Alcohol forum?
Anyway I'll show your post to Alcohol team.
Thanks for report.

08.10.2003, 00:16
No, i did not post there. I dont know wether the problem is a bad cd, ripping problem, or a mounting problem. I have not heard of this kind of thing much before. Since its such an old and obscure title, no one plays, or even has the game anymore, so its hard to meet up with anyone else who might be trying to do the same thing.

The cd plays fine in my players, so it must either be mounting or ripping. I dont know if the game has any protection of sorts, as ClonyXXL does kindof crash out most of the time, but when it dosnt, it gives me a 'bad sector error in whatever sector i stated before'

On top of that, it would be hard to imagine two different programs having the exact same problem, wether that be Clonecd and Alcohol for ripping, or Alcohol and D-Tools for mounting.

I would certainly be interested in knowing how the problem resolves, while its not a life-threatening issue, it has bothered me enough that ive debated going back and re-comparing all of my cds with my images for audio track flaws.

Thanks for the replies though, do you think i should now post this in the Alcohol forums, or anyplace else inparticular?

Thanks again.


09.10.2003, 08:12
A friend of mine still has MechWarrior 2, next weekend I could try to get it from him and make a copy to see if I get the same problems...

09.10.2003, 11:02
That would be great, id certainly like to know if im the only one, or what exactly.

Note that we are talking about MechWarrior 2 - 31st century Combat (Pentium Edition)

If i learn any more about the problem, or the solution, i will post again in this thread.


13.10.2003, 12:25
Sorry, haven't reached him so far. Plus I don't know whether he got the MechWarrior 2 - 31st century Combat (Pentium Edition) - but I'll ask whenever I see him again. Could take a while though, he's just gone to the army, dunno when I'll see him again. He'll be at home on the weekends normally.

14.10.2003, 05:22
Hey, i appreciate it, it will be nice to know what the problem stems from, or atleast be able to rule out certain things. :)

There is no major rush, just whenever you get the time. That would be great.

Thanks again.