View Full Version : Notification icon

17.10.2006, 11:04
Every time I turn on my computer i get this message:

Failed to add notification icon, error 0!

I'm running a Windows XP Media Center Edition (Proffesionel with some other features)

How can i get this message away??

17.10.2006, 12:23
Start Daemon Tools manually, or wait for next version which contains workaround for this problem.

17.10.2006, 23:30
I get the same error, but manually starting helps...

14.11.2006, 19:37
I should re-install my windows, and i haven't seen the message since :)

17.11.2006, 17:53
I believe the error occurs because the task bar has not yet started fully when the icon is being added.

If you can delay daemon tools starting up the problem will not occur.

a simple way to automate a delay is as follows :-

In Regedit navigate to
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Run find the Daemon Tools key and edit the value
"C:\Program Files\DAEMON Tools\daemon.exe" -lang 1033
changing it to "C:\Program Files\DAEMON Tools\delaydaemon.vbs"

create a new file using notepad in C:\Program Files\DAEMON Tools\ name it delaydaemon.vbs

put the following code into the delaydaemon.vbs file and save it into the C:\Program Files\DAEMON Tools folder.
do not include the dashes


wscript.sleep 30000
Set objShell = CreateObject("WScript.Shell")
Dim stAppName
stAppName = "C:\Program Files\DAEMON Tools\daemon.exe -lang 1033"
Set objExec = objShell.Exec(stAppName)


this will start daemon toolss 30 seconds later than normal and I find this is enough to make it work

If you dont feel comfortable playing with the registry, startup files or VBS then wait for the fix.

If you upgrade or uninstall daemontools the registry entry will automatically be overwritten and removed.

EDIT .......

I have just tried this fix for the problem


Uninstall UPNP and the problem goes away

Try the UPNP uninstall fix before you do the above workaround

19.12.2006, 03:31
Has anyone found a fix for this hideous error yet? I am still getting it. About to look for another program as it doesn't appear that anything is being done about it.

19.12.2006, 14:10
What version of DT do you have??

19.12.2006, 17:35
I don't know what work is or isn't being done on this issue, but I will say that I always recommend disabling UPnP. It's horribly buggy and isn't worth the "potential benefits". Coming from someone with over a decade of experience repairing computers, take it as you will.

20.12.2006, 06:35
Hi all. Thanks for your response. I am using 4.08.
I have seen people suggest disabling UPnP, but I find that a valuable asset when running a router, so I don't wish to stop UPnP. I cannot believe that a fix or at least a delay cannot be added into the program. I will try the delay method posted above.

20.12.2006, 07:53
OK. I have followed iconhell's suggestion and created a delay in starting and it seems to have worked.

If anyone is interested. I have made it simple to create a delay by making a self extractor and regfile. I have also made undo regfiles files and a vbs.

Now, all I need to do is to stop this ridiculous delay in posting. :rolleyes:

20.12.2006, 09:15
This ridiculous delay in posting is caused by the fact that all posts from users with less than 20 posts need to be approved by a moderator first. This is unfortunate (believe me, for us as well), but otherwise the forum would drown in spam and illegal posts.

More details here.

20.12.2006, 09:31
OK. Thanks anyway. Just another 15 to go. This delay in DAEMON Tools (not in the postings) has made a difference. I have tried two restarts and it went fine.