View Full Version : Device problem 39 and more!

19.10.2006, 20:20

I'm running Windows Pro x64 and having huge problems with DD 4.06.

When installing everything goes dandy, but when it starts it states: "Unable to add adapter. Device problem 39."

The icon in the tray is visible however. You can hear the sound of an usb-device being disconnected and a popup "You can now safely remove the device" is visible a short time. You cant click it though... I can't find a SCSI unit in device manager. I can't find "dtscsi.sys", but I do have "sptd.sys" and "sptddrv1.sys".

When running sptdinst_x64.exe add it states: High SPTD version is already present.

When clicking on Daemon, it gives the message "Virtual SCSI driver not detected" and then exits.

Tried to deactive antivirus (avast!).
Tried to reinstall etc as stated in the forums.

19.10.2006, 21:31
I've tried with Alcohol 120% and it unmounts the drive before it's even listed in "My Computer"... Anyone got any ideas?

19.10.2006, 23:06
Please check system event log (run eventvwr.msc) for error messages regarding SPTD and Daemon Tools SCSI controller (some random name).
Post the whole message incl. all binary bytes.

19.10.2006, 23:21
Okay, I'm not kidding about this... But there are no events in Event Viewer. Not one.

daemon.dll 789 912 bytes
daemon.exe 157 592 bytes
pfctoc.dll 167 936 bytes
sptd.sys 761 592 bytes
sptddrv1.sys 170 496 bytes
dtscsi.sys non-existant

any other files I should list?

20.10.2006, 17:31
I doubt system event log is empty. You must run eventvwr.msc, then click on system protocol or similar in left frame.

26.10.2006, 22:18
I did as you told me and it was empty. I've reinstalled now however. It did the trick.

I believe it was a driver problem (JMicron JMB361). When reinstalling I stuck with the drivers which I added during the install with a floppy. The "enhanced" drivers which I installed the first time around added hotswap-support to the disk... Even though it was a PATA-disk! Anyway, guess were all a bit wiser now :)