PDA

View Full Version : Invalid device



Silentalert
26.10.2006, 16:34
Hello,

I have installed Daemon tools and when I want to run it I get this error: Link (http://img114.imageshack.us/img114/4956/daemonerrorba2.jpg).

I have this several times I've reinstalled it rebooted my computer it's strating to drive me crazy;) .

If some of you know what to do please tell me!

~Regards, Silentalert

jagar
30.10.2006, 17:38
I am having the same issue. this link (http://www.daemon-tools.cc/dtcc/t13960-p2-quotinvalid-devicequot.html) has helped but I am still working on it. I think I need to revert to 3.47 for the time being.

tmike
11.05.2007, 05:34
arg. 4.09.1 gives me the dreaded "internal error", and reinstalling 3.47 now gives me 2 "invalid device" messages and no tray icon (altho the tray icon does appear if i run DT via its shortcut).
on boot i do get two sptd error log entries (event 4) that say "Driver detected an internal error in its data structures for ."
one is:

0000: 00 00 00 00 01 00 52 00 ......R.
0008: 00 00 00 00 04 00 04 c0 .......А
0010: c6 00 00 00 00 f0 98 f7 Ж....рч
0018: 00 00 00 00 00 00 00 00 ........
0020: 00 00 00 00 00 00 00 00 ........

and the other:

0000: 00 00 00 00 01 00 52 00 ......R.
0008: 00 00 00 00 04 00 04 c0 .......А
0010: c6 00 00 00 00 00 4b f7 Ж.....Kч
0018: 00 00 00 00 00 00 00 00 ........
0020: 00 00 00 00 00 00 00 00 ........

bummer.

Copytrooper
12.05.2007, 12:53
Install SPTD layer v1.45 first:
http://disc-tools.com/download/sptdbeta
then run Daemon Tools v4.09.1 installer after reboot.
If you get error again, try to disable anti virus during installation.

tmike
13.05.2007, 21:16
yeah, i had uninstalled & reinstalled quite a few times a few days ago before i gave up, but tried again just for the halibut... same result.

Copytrooper
14.05.2007, 09:52
You must not install v3.47 after v4.0x installation, it won't work.
Remove v3.47, ensure it is removed completely - see thread about error 25002 in common problems and solutions forum. Reboot after the procedure.
After reboot run SPTD stand-alone installer to ensure correct SPTD installation, if it says v1.45 detected, just exit. Then run Daemon Tools v4.09.1 installer - what happens?

tmike
15.05.2007, 01:27
>> You must not install v3.47 after v4.0x installation, it won't work.
This implies that 4.0x does not cleanly uninstall. unfortunate.
However, just to reiterate, 4.09.1 has never actually installed on this box; only the SPTD 1.43 and 1.45 portions have ever succeeded, followed by the "internal error" in the 4.09.1 installer, immediately after clicking "I agree". When i click that button, the installer performs the following tasks:
- query information on Msimtf.dll
- open Msimtf.dll
- query information on Msimtf.dll
- close Msimtf.dll
- query information setuphlp.dll (in the installer pkg's temporary directory)
- create setuphlp.dll (fails with 'duplicate filename')
- query information on setuphlp.dll
followed by explorer.exe doing query info/open/query info/close on the DT installer .exe file.
At that point the failure dialog appears.
At any rate, after once again following the uninstallation steps you referenced in the article (contains broken links, btw), the install for v4.09.1 again fails as before. A reinstall of 3.47 - as before - results in 2 "invalid device" messages on (every) startup plus the same two system error log entries and no tray icon. And again, after I dismiss the two "invalid device" dialogs and run DT from its desktop shortcut, the tray icon appears and everything is peachy.
so... bottom line... doing the uninstall/reinstall once again... results in the same end result as before.

tmike
03.06.2007, 02:08
for me, installing SPTD 1.47 got rid of the 2 'invalid device' dialogs upon startup. inability to install DT 4.09.1 remains unchanged.

tmike
01.07.2007, 21:03
as i found in zjohnr's thread from 4/17, this turned out to be due to defective filename handling in the installer, to-wit a reported 60-something character limit on the installer's filename. grrrrr. :mad:

Herrie
02.07.2007, 08:50
After doing the steps as mentioned, i.e. runninmg 'SPTDinst-v149-x86.exe' it gives a message regarding Windows 16 bit sub system.

Translated from Dutch it says

SYSTEM\CurrentControlSet\Control\VirtualDeviceDriv ers. The entry of the virtual device driver is invalid.

Wher can I find thes bl**dy seting, so I can change ore delete that rotten Key!!

Herrie
02.07.2007, 11:26
In my regestry I DO find references to sptd...
Can I delete those safely?

Herrie
02.07.2007, 19:47
Those are the entries I found:


HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Explorer\ComDlg32\OpenSaveMRU\*HKEY_CURR ENT_USER\Software\Microsoft\Windows\CurrentVersion \Explorer\ComDlg32\OpenSaveMRU\*

HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Explorer\ComDlg32\OpenSaveMRU\reg

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\Root\ LEGACY_SPTD

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\Root\ LEGACY_SPTD\0000

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\E ventlog\System\sptd

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\s ptd

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\s ptd\Enum

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Enum\Root\ LEGACY_SPTD

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Enum\Root\ LEGACY_SPTD\0000

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\E ventlog\System\sptd

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\s ptd

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\R oot\LEGACY_SPTD

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\R oot\LEGACY_SPTD\0000

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\Eventlog\System\sptd

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\sptd

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\sptd\Enum

HKEY_USERS\S-1-5-21-1390067357-1202660629-1060284298-500\Software\Microsoft\Windows\CurrentVersion\Expl orer\ComDlg32\OpenSaveMRU\*

Can the be deleted without cousing troubles?