PDA

View Full Version : Major issues with Vista RC2 (Build 5744) (With solutions to some issues)



jonnyz0109
30.10.2006, 03:44
I have searched the forums to no end, and found a few solutions that solved my initial problems. Now with my new problem, I can't even find any other evidence of others having this same problem. Hopefully I'm just bad at searching forums.

Current problem - upon starting Daemon Tools, my system goes to 100% CPU utilization and is unresponsive. A look in task manager shows that random processes are eating up cpu, not daemon.exe (or whatever the process name is). Things like taskmanager.exe, explorer.exe, wdm.exe (Windows Desktop Manager, a new Vista thing), and other system-critical processes would show as eating up cpu cycles. Even after disabling the virtual drive, and ending the Deamon Tools exe, I still could not use my computer. My only solution was to uninstall... and immediately, as soon as the uninstaller ran, my computer was back to working order.

Just to verify, I restarted and went through the installation again. The moment Daemon Tools started after the installer finished, my computer went to full CPU utilization. The moment the uninstaller was through, everything was back to normal.

I am running Vista RC2 Build 5744 on an upgrade install from RC1. After my first try I noticed I had Virtual Clone Drive (?) still installed, from when I still had RC1. I uninstalled that and tried installing again, but with no change.

Help!!

For those who are still having other Vista issues, read on. After upgrading to RC2, Deamon Tools was showing errors on startup. Like others, when I tried reinstalling, I had no luck. The installer would start, make me accept the user agreement, then ask about installing the SPTD driver. After telling it to install the drive, installation would just close, and that was it.

The solution was as follows. First, browse to C:\windows\system32\drivers, and delete sptd.sys. Next, open registry editor (Run > regedit) and search for sptd.sys. You should come up with a few entries, and delete all parent keys containing sptd.sys. I believe they were in ControlSet or something like that. Then, reboot, and re-run Daemon Tools installation. This time installation will not close, but install the SPTD driver, then ask you to reboot. Upon rebooting, installation continues to run, skipping the bit about SPTD.

At the end of installation you should be all set. I got no errors, and I did see my virtual drive in My Computer. Now if only my CPU usage wasn't at 100% after Daemon Tools is launched... :(

c70070540
30.10.2006, 09:54
Wonderfull, it was not working at all, and got when starting an error about sptd.sys. Never got the time to resolve it, but after reading your solution I got it working in 20 minutes. Thanks.

It where 2 entry's in the registry for me and only re-installing the complete package. I did not even had to uninstall the previous install.

jonnyz0109
30.10.2006, 14:38
Good, I'm glad that helped. That seems to be the failsafe solution for the SPTD.sys issue. Really, the solution should be stickified and labeled as a solution for common Vista issues.

Now... any ideas on 100% CPU Utilization? :(

Andareed
31.10.2006, 02:39
Upgrade issue was actually a bug in vista upgrade process. If you install sptd 1.35 (after upgrade), sptd should correct itself, and then you can reinstall daemon tools.

jonnyz0109
31.10.2006, 02:46
So will using SPTD 1.35 fix the 100% cpu utilization issue? If so, where can I find that file?

And I agree, the Vista upgrade was largely broken, but I just don't have time to do a full install right now, and needed RC2 for many things (including getting DTools to work!!).

Thanks for your help. If I can find something that works I will put a solution and maybe request for a sticky? Maybe I can even get a batch file written to help others that are having these same problems. While everything is probably here in the forums, it's hard to find anything.

As always you guys rock!

jonnyz0109
31.10.2006, 03:13
UPDATE:
SPTD 1.35 can be downloaded here (http://www.duplexsecure.com/downloads/).

I updated my SPTD to version 1.35 using the download above. It reported my system as having 1.29 installed, and after installation, asked me to reboot. After rebooting I ran the latest installation for Daemon Tools. It did not ask me to install SPTD, as expected, but just continued with the application install. Same as before, CPU utilization shot to 100% as soon as the client was started up, and it shot back down to idling around 15% as soon as it was uninstalled.

I understand this is beta software, so that's why I'm willing to work through this. However, this is close to RTM, and I think everyone would like to see DT working on Vista before it is released to the public.

Thanks again for your help.

Jito463
02.11.2006, 17:50
I'm sure they're working on it. In the meantime, the new release for Alcohol is Vista RC2 compatible.