View Full Version : BSOD when adding or disabling virtual drive - or hardware drive!

01.11.2006, 11:58

This might not be related to Daemon Tools directly but, indeed, has resulted from using D-Tools or consequently appeared while using D-Tools.

So these are the symptoms :

On a previous install of XP, changing virtual drive settings always resulted in a BSOD without any specific info. This meant that, while the virtual drive that was active worked fine, trying to disable it or adding more drives or even changing the drive parameters resulted in XP crashing. So I could live with the problem.

I then bought a new hardware drive (LG DVD-RW) and installed it - the found new hardware icon appeared when XP was starting up but then - BSOD with differing messages, most commonly a page fault in a nonpaged area.

So I did a rescue install of XP. Now the drive was found and worked properly BUT

I also removed sptd (completely, drivers and registry keys)and Daemon tools. Reinstalled. Now I got a BSOD when Daemon Tools says "please wait" ie. it tries to add the new virtual driver.

So the symptom is : whenever I try to tinker with installed drives, I get a BSOD. My guess is that either something is corrupted in my Windows install, or then it's a driver conflict or ...

The only thing keeping me from a fresh installation of XP is that I have so much of software to reinstall.

One thought came up - I succesfully installed a new motherboard with a different chipset (VIA -> nf2) on a quite fresh installation of XP, and while things worked for some time then my XP became broken. Might be related.

If anyone has any suggestions - they are very welcome. I couldn't find any thread with a similar problem - or then I suck at searching - so I thought I'd bring this up here. Even if I completely reinstall XP someone might have a workaround for somebody else suffering from the same problem.


01.11.2006, 17:45
It is NOT recommended to change the mainboard while keeping the Windows installation; you can try a repair installation of XP though.
Please remove SPTD layer first, then run a repair installation, install all available Windows updates, then re-install SPTD layer (try v1.35).