View Full Version : Still "Invalid device" with Sptd driver 1.35

02.11.2006, 12:13
I downloaded DAEMON Tools 4.0.6 X86 and installed it, and it shows
"Invalid Device" after I launch DT4.0.6 .

There is still a "SCSI/RAID HOST Controller" error in the device manager.

After times of searching the forum for the solution, I decided to wait for the new version of Sptd-driver.

Today, I happily received the news that the Sptd-driver 1.35 was released, so I downloaded it, preparing to try it.

Because I've removed my DT4.0.6 and the previous SPTD1.29 (very clearly, including deleting files and registry manually), I installed DT4.0.6 again.

It jumped out a alert which says "Invalid device" as usual after I launched DT4.0.6. .

Then I launched "SPTDinst-v135-x86.exe", and it says the previous version SPTD was detected,
from this step on, the following two methods are both unavailable to solve this problem.

1.Select "Update"
2.Select "Uninstall" first, and after the computer reboots, launch "SPTDinst-v135-x86.exe" and select "install".

Can you help me? :confused:
This problem has bothered me a lot and a lot. :mad:

02.11.2006, 12:33
SPTD has nothing to do with "Invalid device" problem.
You need wait new version of DT coming soon.

08.11.2006, 14:18
Same problem for me too :( No workarounds? Is this fix/new release in the near future?

Best regards

08.11.2006, 14:24
yes, new version is around the corner

11.11.2006, 07:14
I have the same problem as well, also with Alcohol. The alcohol team have fixed it with a beta version that I have installed, so hopefully the next daemon release will do the same.

11.11.2006, 07:28
yes, new version is around the corner
I am having the same problems as posted above, I have downloaded 4.0.6 x86 as of the date 11/11/06. My question to you is, is this new version your talking about or should I still be waiting? Thanks for your time.;)

14.11.2006, 08:53
SPTD has nothing to do with "Invalid device" problem.
You need wait new version of DT coming soon.

this is not correct
i installed alcohol 52% and get the same error message invalid device.
i think the SPTD has a problem.

damn! who can help?


regards Max

15.11.2006, 15:20
it is possible to use for daemon tools another virtual CD-ROM drive as Sptd driver 1.35 ???

regards Max

18.11.2006, 23:37
Thx !

new version (4.0.8) now function :-)