PDA

View Full Version : PnP Bios Extension error and no Virtual SCSI Controller



MarcM001
19.10.2003, 23:42
Operating System: XP Pro SP1
Burning Software: CDBurnerXP Pro
Anti-virus Software: Grisoft AVG
DAEMON Tools Version: 341

This is on a new IBM thinkpad.

Bios PnP Error is: Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)

I have no SCSI/RAID devices.

Tried uninstall/reinstall restarts several times. It say "install successful" then "no virtual scsi driver" when I try to start the program.

thanks in advance!

Marc

Development
20.10.2003, 18:34
Please post all errors you get in system event log from 'pnpshark'

MarcM001
21.10.2003, 00:12
Thanks for the response. There isn't even an entry in the device manager for the pnphark...in the event log it just said it can't find the file specified for st3shark and pnpshark.

For the same reaon, Smbus and DCOM also didn't start on my system, though I don't think it's part of the problem.

thanks!

Marc

Development
21.10.2003, 08:31
So what can we do then if even files have not been copied to system?
Even no pnpshark.sys in Systme32\Drivers folder?
Better uninstall your antivirus completely to check then.

MarcM001
21.10.2003, 18:35
Virus software is set only to scan on demand, but I disabled anyhow and did a repair. Now only 1 error in the system log: The following system-start drive failed to load: pnpshark

pnpshark is in the drivers directory.

There are now two pnpbios extentions in the device manager, both saying the driver is corrupt or missing, and still no enttires for SCSI/RAID of any kind.

The following services are set to 'disable' on my system:

Application Layer Gateway
Background Intelligent Transfer
Computer Browser
Distributed Link Tracking
Error reporting
Human Interface Device Access
Messenger
NetMeeting Desktop Sharing
Network Location Awareness
NT LM Security Support Provider
Portable Media Serial Number
Remote Registry
Routing and remote access
TCP/IP NetBios helper
Telnet
Terminal Services
Upload Manager
WebClient
Windows Time

This was done after carefully reading the Black Viper's security tips page. I have had one other problem on my system related to virutal devices - my USB to Serial port adapter also can't load its drivers either.

Marc