View Full Version : DAEMON Tools 4.0.8 killed my DVD device

07.12.2006, 14:31
I installed the newest version of Daemon on Vista RTM, since they say it is "compatible" but after installation my DVD-RW device disappeared. I uninstalled the Daemon but still it won't re-appear.
Windows shows following error message: "device driver software was not successfully installed"
"Matshita DVD-RAM UJ-845S ATA Device FAILED!"
I read about similar problems in the forum but there seems no solution found yet! I hope you can get it fixed soon (Daemon staff)!

I thought the new version is Vista ready, but it isn't at all! only problems ! this was the last time I installed Daemon tools !

07.12.2006, 19:17
and it didn't comed to your mind that maybe other software
is buggy? Like a wise man said once: if ONE component is
faulty, all drivers will have a problem no matter how good
implemented they where.

We did not charged you for DT, did we? And yes, maybe you
also keep to your notes that millions of people use DT, only
few have a problem. It is like pharmacy, what did you expect?
That we know EVERY possible constellation? EVERY system-
specs? That we tested it on every system worldwide thats
available? Especially on VISTA, for sure DT is NOT the only
software that have maybe probs. It is a system for early
adopters. Be thankfull that you could downloaded it for free
and that you could use it already in your new OS.

After all, I'm pissed off by such problems, too - but more
of people who blame us because it doesn't worked as expected.

Do you have an idea how many "workarounds" we have in
DT itself because of buggy other drivers? Guess it! HUNDREDS!
Bugs that other developers CONFIRMED but where they saw
NO NEED to fix them on their side.

When you're pissed, then blame it to somewhere else. We're not
here to serve you with your mood. We're here to help you
with DT.

07.12.2006, 20:51
a problem with daemon tool 4.08 after i install it in new windows vista rtm ver. my windows deactivate after every restart:confused: :mad: . when i remove SPTD driver now fine working my windows plz help. for this problem..

my english is poor plz try to understand what i want to say?:wink:

08.12.2006, 14:46
Can you describe more detailed WHAT exactly happens when
SPTD is active?

So far I understand that without SPTD you have no problem
with your VISTA RTM-version, correct?

09.12.2006, 11:00
When you installed the first time DT, have you already activated Windows Vista?

09.12.2006, 12:14
this same thing happened to me. I'm using RTM, and it's fully registered. Vista will not use my dvd/cd-rom. Also the D-tools artificial dvd-drive will not work.

When I go to Device manager. There's a questionmark by both of the drives. And when I try to re-install the driver to my sony dvd-burner. It just fails.

Hope you guys can get to the bottom of this. I bet you can!

This other guy complaining should consider D-tools has allways been free and also a super-effective tool. Idiot...

09.12.2006, 17:53
well its not really free.. you should register it to get benefits like support etc.. and to show your thanks.. and 16 or so euro isnt that much really

09.12.2006, 18:23
If they somehow fix this problem and help me install daemon so I can use my dvd-rom, I'll be glad to pay those 16 euro's.

09.12.2006, 22:56
we will definitely look into this problem

Unfortunately, one of our main-testmachines is dead-- it served
us well, but all good has come to an end now.

Currently, I reinstall everything and hopefully tomorrow every-
thing is up and running again (unfortunately, the backup is
useless as most of the system-components now swapped)

However, I'm pretty sure that we will dig to the bottom of this
shit asap.

PS: Although we greatly appreaciate everyone who decide
to support us (license), we try our best to also serve those
ones who want to stick to free version. Do only license it
if you really WANT it! That are the customers we want, people
who chosed to support us on their own, not forced to it ;)

10.02.2007, 16:10
I have the same problem here with Vista and Daemon Tools 4.08, I uninstalled DT and still have an exclamation mark near my DVD writer en DVD reader and still can't use them !!
I tried several solutions but still have this problem... :confused:
Any help ? Thanks !

10.02.2007, 23:04
Delete the drive in device manager then re boot your system and let windows find it again.

25.02.2007, 09:38
Does DT 4.08 perfectly surrport Vista?
I wonder......

25.02.2007, 14:19
Does DT 4.08 perfectly surrport Vista?
I wonder......
Aye. Runs damn well.

12.04.2007, 16:47
I have the same problem as well, I installed Daemon tools 4.0.8. and my NEC dvd drive no longer works, I have uninstalled it from system properties, as well as uninstalled Daemon tools, refreshed system properties and it still will not install the drivers, it says under details " The drivers are missing or corrupt". I have also tried uninstalling both daemon tool and the NEC drive, then restarting the computer, as well as physically replacing the drive with another DVD drive that I have (lite on) and yet it still will not install drivers for ANY cd or DvD rom device.

13.04.2007, 01:45
What happens if you uninstall SPTD? Use the standalone installer from the downloads section to remove it.

19.04.2007, 23:10
hi, i can confirm the issue on vista as im suffering from it ... no more dvd or cd media :$

now i wanne ask whats SPTD ?
and how do i use it for this speculated fix ?


20.04.2007, 05:37
SPTD (SCSI Pass Through Direct) is the bus driver for the virtual drives. It must be installed for the virtual drives to operate. But if you think it's causing a problem, you can try uninstalling it to test.

21.04.2007, 19:58
I uninstalled everything! deinstalled dt, SPTD, the cd/dvd devices and still my devices dont wanna work again!

- using vista x64

any chance to get them back without reinstall windows? :|

16.05.2007, 14:33
I had exactly the same problem with my vista.

I also have an XP box and it keeps saying "Invalid Device..."
and I got all sort of error message such as "..exe is not a valid win32 program..", "not enough storage..." until all windows goes black color. I then had to restart machine. I followed many of uninstall/installation tips in this site. Non of them worked. D-Tool worked on my machine very well until I recently installed 4.XX version 3.XX worked like charm.

Maybe just bad luck on my both vista and xp have some clumsy drivers... who knows what...

For my vista, My DVD/CD rom is back in action after I did "system restore" just look for "SPTD" among restore points. Hope this helps some of you.

27.05.2007, 06:48
I have the same problem.
DT did not install in windows vista and also removed my DVD device. Can anyone help me to solve this problem?

05.09.2007, 14:24
System Restore has the SPTD restore point but when I initiate a system restore, after restart it says that the restore was unsuccessful and no files were changed.
An older restore point says the same thing.

Vista Ultimate
Dell D620
DVD/CD Combo: TSSTcorp DVD+-RW TS-L632D ATA Device

19.09.2007, 01:10
I found a fix for the problem but the problem has recurred once so far, even though DT is uninstalled.

I used the following REGEDIT:


[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}]

[-HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\Cdr4_2K]

[-HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\Cdralw2k]

[-HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\Cdudf]

[-HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\UdfReadr]

26.11.2007, 01:33
I solved my problem with a different registry edit.

I got the following information first from this forum: http://club.cdfreaks.com/f105/tsstcorp-ts-l632d-vista-215309/

And then I followed this link to the microsoft site: http://support.microsoft.com/kb/314060

Basically, I just deleted the UpperFilters and LowerFilters registry entries. Then I got my DVD drive back in Computer and it seems to be working fine.