PDA

View Full Version : How to deal with audio tracks?



Sebeuh
28.10.2003, 19:00
Operating System: MS WinXP
Burning Software: n/a - image made with WinIso 5.3
Anti-virus Software: none!
DAEMON Tools Version: 3.33

I just bought the game "I Was An Atomic Mutant!" and it runs perfectly with no cd inserted but in this case there's no music in game and no sound at all during avi sequences; can I do sth with Daemon Tools so that I don't need the slow, noisy cd in the drive to get music? In other words, how do Daemon Tools deal with audio tracks?

What I did:
-created iso using WinIso 5.3
-mounted the iso with DT 3.33
-installed the game from mounted iso
-played the game: no music and movie sound, I still need to insert the cd to get them back!

Thanx for any help or info, hope my question is just not *too* silly...

Andareed
28.10.2003, 19:30
Reinstall from the mounted image and/or change virtual drive's letter to lowest letter.

Copytrooper
28.10.2003, 19:49
Disable analog audio in Daemon Tools, enable digital audio for virtual drives (start -> settings -> control panel -> sounds and multimedia -> hardware).

Sebeuh
28.10.2003, 21:01
Wow, thanx for the quick help. Alas... I need more. :oops:

-Mounted the image to the lowest (E:, D: being my actual CD reader).
-Disabled Analog audio in DT (I overlooked this one!).
-Digital audio was already enabled for virtual drives by default; but I sure would have missed that too!
-Uninstalled and reinstalled the game.
No change! :(

The weird thing is, during installation there is an audio track being played (which stutters like hell when installing from the cd... and plays smoothly from the mounted image). So how comes there's no more music in the game? Grrr! :evil:

Andareed
28.10.2003, 21:22
Remove letter to real cdrom. Change letter of virtual drive to D:. Then try again. I had the same problem with age of empires. For me, audio would only play from D:.

Sebeuh
28.10.2003, 22:27
Yep, makes sense. Uh, how do I do that? (Under Win98 I used to toy with letters from the device manager, but it doesn't seem to work that way under my brand new XP...)
Thanx for your patience :oops:

Andareed
28.10.2003, 23:30
Try running diskmgmt.msc

Sebeuh
29.10.2003, 22:04
Well, actually I managed to change letters with XP's Disk Management stuff. I suppose that's what diskmgmt.msc refers to (I found it via the control panel). So thanx - this part is done. Now my real cd drive is K: and I reinstalled the game from the image mounted as D: - however it still doesn't work...
By the way the music I hear during install is not part of the audio tracks, it's simply a wav file... that's why I can hear it all the time.

Maybe I need to make a special image? With a special prog? So that DT can play the audio tracks?

I'm lost and frustrated - but there MUST be a workaround! I'll find it even if I have to hassle all forum admins I swear! :lol: :wink:

Andareed
29.10.2003, 23:12
Mount your image, then open media player and try to play audio tracks from virtual drive. If you can play them, then image is fine.

Sebeuh
30.10.2003, 14:49
I shoulda thought of that - well, Media Player only sees the setup wav file! So this is it: wrong image. Ahem. I feel silly :|

Made a new image using CloneCD instead of WinIso, and it works perfectly! (I still have to mount it as D:, otherwise it won't play the music.) Yeah, I should have started by that - but upon image creation WinIso warned me that there were audio tracks and told me to use File setting instead of ASCII - so I did and therefore thought all was ok then. Ah well.

Thanks a lot Andareed, you've been of great help! :D