PDA

View Full Version : Should I?



DarK_AssassiN
19.12.2006, 17:49
I use DT all the time. I was using the older version because almost a year ago the newer one (dunno if its still the newest one) wouldn't let my computer boot.

I don't want to take a chance with that again because I have alot of stuff I can't afford to lose in a format.

So, is this newest version safe to use now or should I continue using the old one?

Copytrooper
20.12.2006, 10:50
If it works ok for you with e.g. v3.47, there is actually no need to change it - but obsolete versions are not supported anymore.
On the other hand you don't have to (re-)format/re-install your system in case of trouble - just check this thread for emergency recovery procedures:
http://www.daemon-tools.cc/dtcc/my-system-wont-boot-after-t6828.html