View Full Version : Yasu

20.12.2006, 23:35
New version of Y.A.S.U -> 1.05

21.12.2006, 13:14
do you have a changelog or something??

21.12.2006, 14:09
sYk0 also posted that version here:

21.12.2006, 21:09
Sorry sYk0 (i didnÒ‘t see your post)

Extracted from your post of


Version History:

Fixed SecuROM 7.30 Blacklist(s)...
Y.A.S.U now hides physical CD/DVD-ROM Devices (Required for new SecuROM)

Games Tested:
SecuROM 7.x:
Rainbow Six: Vegas v1.01
Rayman: Raving Rabbids (v1.0)
Dark Messiah of Might and Magic v1.01
Splinter Cell Double Agent 1.01
Heroes Of Might And Magic V 1.4
SafeDisc 4.x:
Call Of Duty 2
Sims 2: Pets

02.01.2007, 10:41
I registered here to post in the hopes that the dev for YASU may read this. The program is great for it's intended use, but creates an indirect bug that leaves a bit of a nusiance.
Before using YASU, I had made a backup of my 2142 disc for storage. I'd been using Daemon 4.06 to mount the image and disabled my physical dvd drives in the device manager before a reboot.
Before YASU, what I mentioned above was enough to keep 2142 loading without a disc. Now that I've tried to do the exact same thing with Vegas, I had to resort to YASU to get the game to load, which it did. The problem is that with YASU loaded, 2142 doesn't work anymore. If I unload YASU, 2142 doesn't work until I reboot.
I'm no expert on any of the relevant methodologies behind the development of these programs, but there seem to be two possible fixes. First would be to get YASU working for the version of Safedisc that 2142 uses. Second would be to possibly do a check before loading YASU whether or not the physical dvd drives had already been disabled. This boolean value could then be used to change the unload procedure so windows doesn't think that it had physical dvd drives at startup.
That's the thing with Safedisc and 2142, the physical dvd drives MUST be disabled in the device manager before the system is booted. Once that is done, they can be re-enabled and used and disabled before loading 2142. My guess is that what gets checked or unchecked at windows startup is being changed by YASU.

I hope this post is useful and may help to make 1.06 a better release. ;)

Thanks for the work that has already gone into this program.

03.01.2007, 20:45
I am fairly new when using YASU, but I used to manually alter registry to bypass security. Yasu also has an issue where after it is run and you reboot the computer, it reassigns the cdrom drives (when they are assigned to non ordered letters, for example my cdburner is drive X:). I bypass the issue by backing up 2 keys in the registry and restoring them after it was run. At least I haven't had any problems since. I am assuming it would fix the issue you have with bf2142.

Before you do anything like that, be warned that editing registry could give you more problems so be carefull with any changes you make.

What I did anyway is the following. I backed up the registry keys "hkey_local_machine\hardware\devicemap\SCSI" and "hkey_local_machine\system\mounteddevices". After I finish playing a game and run yasu to restore previous settings, I restore the 2 registry keys I backed up. That seamed to work for me, at least last time I tried it.
Currently I use YASU only for NwN 2, last game a bought and which I am currently playing.

Good luck, hopefully this helps.

04.01.2007, 03:46
Thanks for trying to help. I made a reg file for each of those keys before running YASU. After unloading YASU and running the two reg files, 2142 still would not load until I rebooted the machine.

06.01.2007, 07:32
Something else you could try is what I used to do. Depending on the version of securom and the game you run, you could bypass it by backing up the the 2 registry keys that I showed you and applying the altered registry keys. Then you could restore them after the game.
A simple way to do that would be to run YASU and export the 2 registry keys I mentioned above (mounted devices and SCSI). Afterwards you could make a batch file that when you run it, it would backup those 2 keys and apply the YASU ones you created, wait until the game was done and then restore the ones it backed up. A simpler way would be to create 2 batch files. Backup.bat and Restore.bat (you can name them as you wish). They would be as followed:

@echo off

Echo Press any key to apply YASU registries.

REGEDIT /S C:\Yasu1.reg
REGEDIT /S C:\Yasu2.reg

REGEDIT /s C:\backup1.reg
REGEDIT /s C:\Backup2.reg
del /q /f C:\Backup1.reg
del /q /f C:\Backup2.reg

regedit /e file.reg "key" -> exports key to file.reg
regedit /s file.reg -> loads registry file (/s for sillently so it doesn't prompt you with a warning)

Now that should hopefully fix the problems with BF 2142, because everything should be back as they were... Take in account that this method might not work depending on what other changes YASU makes.

Hopefully this works...

Good luck!

06.01.2007, 20:33
XKS, I have tried backing up those keys like you describe and it does nothing for this particular problem.

07.01.2007, 21:28
The problem with YASU not restoring your virtual drives correctly will be fixed in the next release...

Y.A.S.U 1.06 will be avalible for download soon, from the DT website... :D

09.01.2007, 17:24
grabbed 1.06, it crashes, bad parameters passed on the stack
crashes @ .401BEE.. mov dword ptr ds:[eax], edx

eax = 03
edx = 36

access violation (obviously as 03 isn't a good area of memory to try and write to)..

os: xp32 sp2

didnt try any commandline params...
if its of any help, it only seems to happen when i try running the exe the 2nd time
(to restore), and that i have all drive letters in use, and my last 3 drives are network maps.. hopefully that might aid you in reproducing it, issue also does not happen on my vmware win2k sp4 system

also when executing it the first time the messagebox does not appear that reports what drives were hidden...

10.01.2007, 22:01
Does anyone else have this (above) problem?

10.01.2007, 23:13
Does anyone else have this (above) problem?

I am having a similar issue with an error from yasu.

I had run 1.04 to hide, without unhiding, I ran 1.06. everything seemed ok, until I tried to run the game, R6. then Yasu crashed.

let me know if there is more info I can provide.


11.01.2007, 06:23
When I try to run yasu, I get an error "YASU.exe has encountered a problem and needs to close."

the error signature offset is 00001bee. and this is on xp.

and now every time I try to run yasu, I get the same error message. even after I reboot, and enable and disable daemon-tools.

let me know if you need more info.

11.01.2007, 12:57
"YASU.exe has encountered a problem and needs to close." the error signature offset is 00001bee.

Add base address = 401BEE = same issue as mine

also, is this forum moderated?, cos my original post didnt seem to appear

11.01.2007, 16:48
yes, this forum is moderated, however, there was a glitch in
user-rights, therefore your post doesnt appeared immediately,
is corrected now:rolleyes:

sorry for any inconvenience

11.01.2007, 16:59
cheers chief :), hopefully we can help syk0 sort this soonish

11.01.2007, 21:32
Try this hotfix from Microsoft see if it helps...

It may be a problem with the Windows Vista section in the exe's manifest.

11.01.2007, 22:48
looks like its still an issue for me, even after I run the hotfix and reboot. everytime i run YASU 1.06 I get the error. also after the error happens, it seems that rundll gets hosed, so that every time I shutdown, it gives me that message saying trying to close rundll, or something like that.

ps. check your daemon-tools.cc email

11.01.2007, 23:38
Try this hotfix from Microsoft see if it helps...
It may be a problem with the Windows Vista section in the exe's manifest.

i already had that update windows update automatically downloaded it ages ago getting same offeset error Offset: 00001bee

10.03.2007, 16:32
When i click on yasu it gives a little normal sound, when i click somewhere on my desktop than my whole pc crashes, does anyone got an solution for this?