View Full Version : Settings lost on system reboot

11.01.2007, 01:57
Daemon Tools does not seem to remember my settings - after every reboot it's settings revert as if it has just been installed. eg:
- all emulations are turned off again (red icon)
- number of virtual devices reset to one
- other options revert back to default state
I have tried turning autostart on and off but no effect.
Windows XP Pro SP2
Daemon Tools 4.08 X86
(NO Easy CD creator)
ImgBurn 2.1
AVG Antivirus
Kerio Firewall
Mobo: Asus V7V8X-X
CPU: Athlon 2500 XP+
1024 MB RAM

11.01.2007, 15:38
Have you tried uninstalling and reinstalling? What about installing SPTD 1.39?

11.01.2007, 17:42
I've just uninstalled Daemon Tools and SPTD and installed SPTD 1.39 then Daemon Tools 4.08 again. But I'm still having the problrms.

14.01.2007, 16:17
I have the same problem with version 4.08 and SPTD 1.39.

Reinstalling Daemon tools doesn't work.

Rolling back to 4.06 and SPTD 1.39 solved my problems.

Hope it helps


Windows XP Pro SP2
Alcohol 120% (no virtual device)
Antivirus Avast home
Windows Firewall
2 SATA WD Raptor 150 Gb
Mobo: Asus A8N-E
CPU: Athlon 64 3800+ Venice

15.01.2007, 02:20
I am using 4.08HE and have set DT4 to NOT autostart....but every time i reboot i have an icon down in my taskbar.

Could this be the same issue with not saving settings?

I have tried this on several computers, uninstalled, and re-installed several times on each....but still the same thing

15.01.2007, 13:25
I've done a little more testing. If you install daemon, and make changes to the settings right away, those are the setting which become like a "default". Once you reboot it will always go back to those settings.
I rebooted straight after install without changing anything, which is why for me the frshly installed state was the default setting.
marcocale: Thanks for the info. Unfortunately I don't have 4.06, and there is no link to it in the download section. Perhaps if the Powers That Be are reading this, a little link could be provided, with an md5 sum?
nanoburn: For me I've found that "Autostart" is one of the options which doesn't save.

15.01.2007, 19:35
all i want is for the stupid icon to go away

is there anyway to do this with version 4.08HE

22.01.2007, 23:44
does no one else have this problem?

23.01.2007, 01:54
Hi. I'm also getting this problem. Icon appears each boot, plus it Automounts, which pops up a window for each mounted disk. Never had this problem with previous versions.

Any help would be great..

25.01.2007, 17:46
Does not matter how and how many times I install or repair D-Tools 4.08HE, settings are just not remembered by this version.
I can't find any SYS-file which I recall older versions had.
This has got to be a general BUG!

28.01.2007, 07:37
Can somebody official help work this out so future versions will not be the same..?

28.01.2007, 16:38
Please check if updating to SPTD layer v1.40 helps to solve the issue:

29.01.2007, 23:05
I have updated to SPTD 1.40, which did fix the problem of settings not being kept. Mounted disks are also now kept without the window popping up. The only thing that is still not working for me is the tray icon disappearing. The Tray Icon setting is unticked in the options, and the -noicon command is added to the registry entry, but the icon still comes up each boot.
Not a big issue, but it seems to be a bug. Thanks for the advice to update SPTD to v1.40.


30.01.2007, 15:21
I confirm that the beta version of STPD solved the problems with the Daemon Tools remembering the settings.
Thanks for the tips.

P.S. Just wonder what more eventually was solved at the same time? D.S.

01.02.2007, 16:26
A little addition to this. I update the driver and I also moved the regeistry key that runs daemon tools from the current user to the local machine to fix a problem with them not being connected when another user logs onto the computer.

03.02.2007, 01:47
ok, so i downloaded and installed the new 4.08 with 1.39 today, and i'm having the same problem. i checked the release date in the news section and i see Nov.2006. So, for two month, such a small bug (to make the icon go away) is still left unfixed? o_O

04.02.2007, 22:36
downgraded to 4.06. sigh

06.02.2007, 10:02
Is there a way to stop the auto-mounted disks from popping up a window that explores the files on them? I thought this problem had been fixed, but its still happening =(. Used previous versions on a different comp and I had no problem leaving auto-mount on without the damn windows popping up at startup.


13.02.2007, 21:45
have you tried uninstalling, reboot, clear all temporary memory, reinstall, reboot?

18.02.2007, 08:54
Ok I have repeated the process for 1.40 and 1.39 also but all failed. At reboot the image contents reappear and the system tray is there as usual even though autostart is ---.

The only one where there is some success is sptd 1.38. The system tray is there as usual but at least the image contents don't show up anymore. So I am sticking with 1.38 for now. 1 problem down but 1 more to go;)

23.02.2007, 11:15
Seems that I'm not the onlyone with this 4.08 problem.
So, if it's not noted in the bug list, I will make darn sure it will be after this note.. :D

Here is a few ways to "fix" it.. (May or maynot work)

¤ Reinstall DaemonTools.
¤ Upgrade to SPTD1.40
¤ Install SPTD first (download from their site). Install SPTD, reboot. Install Daemontools, set daemontools settings as you like it.. Reboot.
¤ Downgrade to 4.06 (Ehm... right.)

¤Just live with it.. :rolleyes:

26.02.2007, 17:34
Hm.. sorry, but the only thing that works is to uninstall 4.08 and reinstall 4.06. (Install 4.06 with latest sptd (1.42 awm))

Version 4.08 is one big fubar.

04.03.2007, 14:08
You can get those files here:
SPTD 1.42 (http://www.duplexsecure.com/en/downloads)
Daemon Tools v4.06 (http://www.oldapps.com/Daemon_Tools.php)

05.03.2007, 21:55
Same problem, about to downgrade.

09.03.2007, 08:56
Ok I have fixed the problem of daemon tools always starting at startup even when I specify it not to.
The solution was to repair Windows XP. Yeah this meant that I had to install SPTD and update windows and all that stuff again, but at least the problem is finally solved. Maybe it was a system file or registry key that got corrupted before.

13.03.2007, 18:33
I'm about to do the same repair of Windows XP myself. I never had a problem with 4.06 but I installed 4.08 and the problems were just as everyone else noted: Zero drives at bootup, all emulation modes off and only AutoStart and Tray Icon were ticked. If I set options and emulations to my preference they disappeared at reboot. Uninstalled, ran ccleaner, installed and I was able to get one drive to remain at boot but the other problems remained.

I'll try updating my SPTD to v1.42 first, maybe even uninstalling both DT4.08 and SPTD, reboot, cclean and install 4.06. I'll post my findings if anyone is interested.


14.03.2007, 14:28
Okay, so I uninstalled Daemon Tools 4.08 and ran the latest installer for SPTD and chose to uninstall. Rebooted, installed version 1.42 of SPTD then rebooted and installed DT4.08. It remembered the settings but at each boot it would autorun my EYEQ program since I have an image file mounted. I uninstalled DT and SPTD and went back to DT4.06 and all is well.

I can't find version 1.38 of SPTD so there's no way I can test that version with DT 4.08 so if anyone knows where they are storing the archived versions I would appreciate it.

On a lighter note, I've never had problems with 4.06 and since Safedisc 4.6+ doesn't get eliminated by any existing version of DT there's no real reason for me to upgrade. Keep up the good work though!


14.03.2007, 15:46
This is my last post for this topic. After reading this posting:


I uninstalled SPTD and DT4.06 then installed DT 4.08 rebooted. I had to use the SPTD installer for 1.42 to uninstall the version installed with 4.08 rebooted then installed SPTD 1.38 and it works like a charm. All parameters are saved and the image doesn't autorun at boot-time. Kudos to stpaul216612 for his fine posting.

Btw, I was able to find the installer for version 1.38 on DuplexSecure web page.


29.03.2007, 18:46
for those of you who can't find SPTD v1.38, here is a link to a version of DT 4.08 with SPTD v1.38. I was lucky enough to get this before they released the version with SPTD v1.39. Enjoy.


29.03.2007, 18:51
What for? SPTD v1.42 should fix the issue, and it is NOT recommended to install obsolete SPTD layer version, as the newer versions contain important fixes.

02.04.2007, 05:50
because istalling SPTD v1.42 wasn't fixing this problem for everyone, but everyone that reverted back to SPTD v1.38 seemed to no longer have any problems.

09.04.2007, 01:15
This is my story on the subject...

I had the same problems as described in this thread:
- After a reboot, Daemon Tools settings and the number of virtual drives had reverted to a previous state
- After a reboot, any mounted images would also trigger the autorun

Daemon Tools v4.08HE
SPTD upgraded from 1.39 to 1.42

Now the settings seem to be saved properly, but it still pops up the autorun for all auto-mounted images after a reboot. This renders the automount option pretty useless and I had to turn it off (and fortunately it saves!)...

Does HE stand for Highly Experimental perhaps? Any status on a fix? ;)

19.04.2007, 15:55
because istalling SPTD v1.42 wasn't fixing this problem for everyone, but everyone that reverted back to SPTD v1.38 seemed to no longer have any problems.
If version 1.42 has important fixes then it shouldn't have started causing problems that a lot of us began to experience upon upgrading. I say if you downgrade and your system functions without any problems then that's good enough for me. Personally I would only do the upgrade to 1.42 if a system had a particular issue that was fixed by this new upgrade. Otherwise why 'fix' something that isn't broken.
Now I've not tried to install this newest release of Daemon-Tools, so I don't know if the problem has been resolved. I'll do some testing this weekend to see what happens.
Kind Regards,