PDA

View Full Version : yasu 1.07 doesn't work on winxp sp2 for me



wahoyaho
07.02.2007, 13:04
i get an error saying

yasu was unable to hide any devices for securom 7.x, this may due to insufficient user priviledges. any changes that have been made will be reversed. if this problem persists contact your admin administrator. click ok to exit yasu.

but i am on administrator account already.

sYk0
07.02.2007, 15:31
this error usually occurs when YASU can not access the system's registry...

Have you modified any registry keys manually, or using another anti-blacklist tool?

wahoyaho
07.02.2007, 20:05
hmm......not recently, i did install a game which uses starforce a few days ago, could that cause problems?

wahoyaho
07.02.2007, 20:07
sry, another thing (can't edit post cause post hasn't shown up yet)

i can run it fine with nosr, but it won't detect any of my cdrom drives, virtual or real, it'll just say all drives successfully hidden, and it's just blank where it shows which drives were hidden.

sYk0
08.02.2007, 00:28
-nosr disables the SecuROM anti-blacklist, so now you are only hiding you devices from SafeDisc...

wahoyaho
08.02.2007, 03:13
i know, i was just pointing out the fact that it can do safedisc ok just not securom, but even with safedisc it dosn't detect any drives

sYk0
08.02.2007, 15:15
Are you semi-clued up with registry editing?

click start > run
in the run dialog type "regedit", hit return (enter)
go to this sub-key "HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices"
make list of the values displayed on the right-hand side (only the ones that start with "\DosDevices\"
post the list you made...

i.e:
\DosDevices\C:
\DosDevices\D:
\DosDevices\E:
(PS: i do not need the binary data stored in the values, just the value's name)

NOTE: If you can not access the registry key, then you have already tampered with the registry...
if so let me know and i'll post a link to a tool that can fix this problem...

wahoyaho
08.02.2007, 18:10
hmm, the mounteddevices key is empty, but there is a a key called MountedDevice1 and it's got a, b, c, e, f, g, h, which is all the drives i have (except for b, and d which is just a partition of e)

_Icaro
08.02.2007, 19:55
I have the same problem:

"YASU was unable to hide any device for SecuROM 7.x, this may due to insufficient user privileges. Any changes that have been made will be reversed.
If this problem persist, contact your system aministrator."

When I try to edit that part of regedit: "HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices" don't get to access.

I have the latest version of daemon-tools (4.08HE) and use the YASU 1.07. Can someone help me?

sYk0
08.02.2007, 21:18
like i said, you or another application (anti-blacklist tool) has modified the systems' registry...
that's ok i'll guide you through the steps to fix this problem...

sYk0
08.02.2007, 21:34
Step 1:
open your registry, go to the key... "HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices"
Right-Click on the key "MountedDevices" select "Permissions"...

http://www.imagehosting.com/out.php/i196393_yasufix000.JPG (http://www.imagehosting.com)


Step 2:
You should now have the "Permissions fo MountedDevices" dialog open...
Now go through the items in "Group or user name:"
check for the item(s)... "Administrators (xxx\Administrators) (where xxx is the/your user name)" & "SYSTEM"
Under each of the above items, check the permissions (below)...
Now make sure that in the "Deny" column that "Full Control" & "Read" are Unchecked...
Click "Apply" then "OK", reboot your PC...

http://www.imagehosting.com/out.php/i196394_yasufix001.JPG (http://www.imagehosting.com)


Hopefully, you should be able to access this key via regedit, if so then YASU will function normally...

wahoyaho
09.02.2007, 05:46
ah...my administrator account had a deny checked on special permissions, so i had to go into advanced and remove that value, and suddenly all the values in mounteddevices show up and yasu works again :) thanks syk0, you are the best :)

sYk0
09.02.2007, 13:09
Glad to be of assistance... :D

Stromberg
10.02.2007, 13:48
I seem to have a problem, which can't be fixed by just making a few clicks in the permission thing.
Well I don't actually know what that means, but when I open that Registry Folder, no keys are displayed on the right. And so when I try to start YASU, it says same like it was posted above. Needless to say, antiblacklisting won't work with other tools like pr0tstop (it says "Something isn't right with your registry! That error appears due to conflicts with other emulation hide software.")
Does anyone know how to solve that problem ? :confused:

Stromberg
10.02.2007, 20:45
Oh..I noticed that it seems to be a general problem and has nothing to do with yasu...
Because when I mount an image and try to access the virtual cd, it says that the folder is may be damaged (I don't know what the error is exactly because my windows is in German).



Can an admin maybe put this post and the post before into another section because obviously it has nothing to do with yasu? Thx!

Stonewall78
14.02.2007, 02:58
What should I do if nothing is listed under HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices ?

antonloukanov
19.02.2007, 21:28
When i tried using YASU get an error saying
yasu was unable to hide any devices for securom 7.x, this may due to insufficient user priviledges. any changes that have been made will be reversed. if this problem persists contact your admin administrator. click ok to exit yasu.
but i am on administrator account already.
As you wrote i run the regedit but i could not open the "mounted devices".You wrote that there is a tool which can fix my problem.
Would you help me and send me the tool to my e-mai:
antonloukanov@yahoo.com

voltier67
20.03.2007, 01:30
Step 1:
open your registry, go to the key... "HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices"
Right-Click on the key "MountedDevices" select "Permissions"...
http://www.imagehosting.com/out.php/i196393_yasufix000.JPG (http://www.imagehosting.com)
Step 2:
You should now have the "Permissions fo MountedDevices" dialog open...
Now go through the items in "Group or user name:"
check for the item(s)... "Administrators (xxx\Administrators) (where xxx is the/your user name)" & "SYSTEM"
Under each of the above items, check the permissions (below)...
Now make sure that in the "Deny" column that "Full Control" & "Read" are Unchecked...
Click "Apply" then "OK", reboot your PC...
http://www.imagehosting.com/out.php/i196394_yasufix001.JPG (http://www.imagehosting.com)
Hopefully, you should be able to access this key via regedit, if so then YASU will function normally...

Hi there,
This thing is very well explained (see quote). I had the same issue and tried to figure out the steps as shown above. At first action, when applied the steps, yasu didn't work at once for me...although the solution shown above worked for some others who wrote in this topic...so I had to go some deeper in the advanced settings.

WHENEVER YOU'RE ABOUT TO EDIT THE REGISTER FIRST OF ALL MAKE A BACKUP OF YOUR CURRENT REGISTER. DON'T DO ANYTHING IF YOU'RE NOT HAVE THE EXPERIENCES OR ADMINISTRATOR RIGHTS. OTHERWISE WHEN MESSING UP THE REGISTER YOU GET A CHANGE TO HARM YOUR SYSTEM IN A BAD WAY. PLEASE KEEP THIS IN MIND AT ALL COSTS.

To make a backup of your current register: run regedit > choose FILE in menu-bar > choose EXPORT > NAME IT and SAVE.

First, as told, you've to be sure you have administrator rights 'cause otherwise you can't edit these steps. second (this was important for me to get yasu running well), you must change the users(xxxxx\users) permissions aswel with the administrator and administrators and your own windows account:[your account](xxxxx\your account) and SYSTEM account.First change your admin rights by the following steps:in the second screen (shown above) choose advanced then choose the owner-tab and highlight your logged (active) account and click "apply". Go to the first tab (permissions) and highlight the users(xxxxx\users) account and click "edit". Now check the boxes on the first row under allow, click "OK" in this window and then "apply" and "OK" in the first dialog window. At this point, all the active devices-value's in the MountedDevices-key have come visible in the right field. Close regedit and reboot. YASU 1.07 should work now, at least it worked for me this way.

The reason I've post this is to offer some additional help. Without the help and knowledge of sYk0 (see quote above) I was a kind of lost with the yasu issue.
So THX to him.