PDA

View Full Version : Problems with drive letter



eaglexxx83
09.03.2007, 11:59
Hello,
I have problem with showing drive letter from virtual drive in windows explorer. I installed deamon properly an it works. I can mount image. But I can't open mounted image. And also there is no drives letter in explorer so I can't open it. When I try to change drive letter: virtual cd/ dvd rom/device0:(mounted image file)- set device parameters. In opened window, in area settings, drive letter field is empty. DVD region is also empty. When I try to assign new free letter (in my case F to Z ) it shows message "Unable to set new drive letter".
This problem start when I changed drive letters in windows.
I installed windows and deamon tools. After that I splited my disk in 2 partition. C and F (because D is cd/dvd rom, E is Virtual drive.) Deamon worked properly till I changed drive letters to drives. in disk managment. I had problems so I temporally uninstalled deamon. In disk management I changed drive letters C, D for hard, E for CD/dvd drives. Than I installed
deamon again and than I start with problems as it is described abow.
Also in device manager it shows two CD/DVD drives. Real and virtually and both devices work properly.

thanks in advance !

M4M
10.03.2007, 17:16
from what I am understanding, you have your HD's showing up properly, your real DVD-ROM drive showing up properly, BUT your V-Drive (daemon) is coming up as "device 0 []" or something like that when you right-click on your systray icon to mount an image, right? As in, it is not allowing a drive letter to be set on the drive.

OK, now, I am assuming that you already have rebooted your PC several times (from playing with partitions, you kinda have to) and it still is not allowing the daemon drive to get a drive letter.

TRY THIS: first, right-click on the daemon tray icon, sellect Virtual CD/DVD-ROM, then sellect Set number of devices... and set it to Disable.

Once the virtual drive has been disabled, reboot your PC, THEN set the number of virtual drives you want, and that should fix the problem.

Copytrooper
10.03.2007, 20:22
http://www.daemon-tools.cc/dtcc/no-drive-letter-s-assigned-t3701.html

M4M
10.03.2007, 20:52
http://www.daemon-tools.cc/dtcc/no-drive-letter-s-assigned-t3701.html
Ahhh, didnt see that, sorry. Hope I didnt give any mis-information, but the method I supplied did work for me when I had the exact same problem (daemon drive quite working after playing with partitions).

eaglexxx83
11.03.2007, 13:02
Thank's a lot!

metalhead1099
09.08.2009, 05:43
hey wen i try to click that link (cuz im having the same problem) it says the link is broken

Sway
09.08.2009, 08:16
http://forum.daemon-tools.cc/f26/no-drive-letter-s-assigned-virtual-drive-s-virtual-drive-s-disappear-3701/ - it's correct link