View Full Version : Can't get YASU working

07.04.2007, 06:14
HI all. Got a problem and I'm sure I'm just doing something wrong along the way, but here goes...

I bought F.E.A.R Gold the other day. It's basically the directors edition and Extraction point together on 1 DVD. The only computer that I have that will run it is my laptop. The problem with that is that it has a bad habit of scratching up discs pretty bad if you move the computer the wrong way. So I made an image using Alcohol 52% mounted in DT, started YASU and I still get the Emulator Detected messages. It does start fine with the original disc.

Here's my info.

Image created with Alcohol 52% v. FE
DT version 4.08HE (all emulation enabled)
Y.A.S.U. v1.1.7035 (using all cloaking with the UI)
SPTD version 1.42

I even uninstalled everything and put back SPTD and reinstalled DT and still no-go. Any ideas? Thanks!

07.04.2007, 11:22
First of all you don't need to enable emulation in DT when using images. The emulation is only for burned discs.

Does the error actually say 'Emulator detected'? Or is it something like 'Please insert original disc instead of a backup'?
There's a big difference between those errors. 'Emulator detected' means exactly what it says, this is what you will get without using YASU. But the other error message means that you've got a bad image (with bad DPM or no DPM at all).

Anyway, what settings did you use in Alcohol 52% to create the image?

07.04.2007, 23:09
Yes, it definitely says "Emulator detected! Please deactivate virtual drive and emulation software."

In Alcohol, I use DMP set to High Precision. The only type of image I can do is mds. After that the dialog pops up asking for the DPM measuring speed I used maximum.

Going back to your point about the differences of the messages... I would also assume that if YASU is working correctly it would hide the DT drive, but it doesn't seem to be doing that. Would a bad image not allow YASU to function correctly or would it be more like it could find the image, but not like it?

08.04.2007, 00:19
A bad image wouldn't prevend YASU to function correctly.

Does YASU actually gives an error message or does it cloak and uncloak correctly?

Anyway i would suggest you to try some of the fixed images at gamecopyworld. There are both Director's Cut and Extraction Point images available.

08.04.2007, 01:13
No, YASU says that it cloaks all the drives, including the DT drive, just fine.

I'm assuming that if YASU can't cloak the drive anyway, I'd still have a problem even with the fixed images, right? I'll definitely try that tonight and post my results, though.

If that doesn't work, does anybody have any other ideas why YASU doesn't seem to be working? Should I have to disconnect physical drives? Are there any permissions that I need to enable/disable? Registry keys to delete or change permissions on?


08.04.2007, 10:17
usually not, but you may delete this key and reboot:


it helped me in the past. I dont know if this makes a difference, but give it a try.

08.04.2007, 10:30
usually not, but you may delete this key and reboot:
it helped me in the past. I dont know if this makes a difference, but give it a try.

jeeeesus, at least tell him to make a backup first
and deleting keys like that is very very excessive
and reckless..those keys contain driver file
information and so on, along with configuration.....
chances are the key might be remade on reboot
like the dosdevices key.... or it might make the
system unable to boot....

08.04.2007, 10:46
well i never had any problems after deleting that key, but your are right, always make a backup of such keys before you delete them!

09.04.2007, 06:08
I write installation packages all day, so I know what kind of damage reckless registry hacking could do. No, I wouldn't just go deleting registry keys without backups or anything. Lots of times just renaming them works too. It is good that others that might be reading know too, though.

For the record, I looked at game copy world like you suggested, shiFt, but I couldn't find any images for the main game for my version (1.08). Probably should've mentioned that earlier, huh. I noticed there was a cracked exe, but that's not the route I was hoping to take. (Call me quirky or whatever, but it just seems that making my own image from my own disc is more legal... and no, I don't want to get into a debate about what's legal and what's not.)

Anyway, I'm still having problems getting this to work.

09.04.2007, 13:59
huh? There are alot of Images at GCW:

for example 'F.E.A.R.: Extraction Point [MULTI] No-DVD/Fixed Image'.

Anyway, can you scan the game executable with ProtectionID (link is in my signature)?

10.04.2007, 06:08
Yeah, that's for just for Extraction point, isn't it?

Scanning -> D:\Sierra\FEAR\FEAR.exe
File Type : Exe, Size : 6004736 (05BA000h) Bytes
-> Suspicious MZ Header..
[!] SecuROM Detected - Version 7.xx
[!] Possible CD/DVD-Key or Serial Check -> CDKey
- Scan Took : 0.657 Seconds

10.04.2007, 13:02
i don't know, did you try it? Try both extraction point and directors cut images, maybe one of them work.

mmh ProtectionID doesn't recognize the newest Securom protections exactly in the v5.2c.

We have to wait until cdkiller release the next version.

10.04.2007, 18:10
Oh, ok. I'll try the other images when I get home, then.

BTW, is cdkiller another program I need to be running?

FYI: I had previously run A-Ray Scanner with the following results.

[10:08:14 AM] SecuROM detected -> F:\FearXP\Disk1\FEARXP.exe
[10:08:31 AM] --- File(s) Scan Finished [16.43s] ---

Running it on the Disc itself and then running it on the image gave me the same results.

10.04.2007, 20:56
cdkiller is the author of ProtectionID :D

10.04.2007, 21:02

Send me .exe from game and i will give you exact SecuRom version.