View Full Version : Unusual DVD Read Problems

01.05.2007, 00:48
Alright... this is my first post on these forums, and it is a post of last resort. I am an IT Technician myself, and I have no idea what is wrong with this. I have called ASUS and they have no idea either. I'll run through the basics with ya. If you have any idea what is wrong with my computer, please please help, haha.

Comp Specs:
Core 2 Duo E6600
ASUS P5B Delux Wi-Fi Edition Mobo
2GB DDR2-800 RAM
ASUS DRW-1612BL DVD+RW combo drive.
Sound Blaster X-Fi Card
Sapphire Radeon x1950xt 512MB Gphx Card
74GB 10,000RPM Raptor SATA HDD
300BG Seagate IDE HDD
Windows Business Vista 32Bit

Essentially I am having issues reading DVD's. CD's work fine, but DVD's won't work at all. Now, the first thing that comes to mind, of course, is that my Optical Drive is busted, or the laser is dirty. Well, here's the kicker - DVD images mounted with D-Tools don't work either. Once again, CD images work fine, but it simply won't work with DVD's.

On top of that it also blue screen now. I would love to analyze the dmp file with DumpChk, however since I am using Vista I can't install Windows XP Support Tools from the Microsoft website. If anybody knows any download sites for DumpChk - please share this information with me. However, this is the two important bits of bluescreen info:

Now, a 0x8E is generally a hardware driver or BIOS issue. So what did I do? I upgraded my optical drive's firmware, I upgraded my BIOS to the current version, I upgraded my Intel SouthBridge, and I upgraded my JMicron IDE Controller (Since the Optical Drive is in the IDE slot). Aside from that I can't think of anything else to upgrade that relates to Optical Drives. I re-seated my drive, and even swapped it out with another drive - nothing worked.

Now it's and interesting problem because when I put a CD in Vista will tell that, for instance, there are "0 bytes left of ### MB" - so for a CD, no more than about 750MB. When I put a DVD in it similarly says "0 bytes left of ###GB" - so for a DVD, no more than about 4GB. When I right click the drive and click 'Explore' or 'Open" with a CD all of the files and folders display properly, like any other folder on a hard drive... But when I right click to 'Explore' the drive when a DVD is in there a message will pop up saying "Please insert the disk labeled [whatever the label of the disk is] into drive D:". So in other words - it knows the disk is in there, it just doesn't know the disk is in there. Confusing, yes? Remember that it does this with both physical DVD's and DVD mounted images.

I know there was a point in time where I was able to read DVD's in Vista because I installed 'Hitman: Blood Money' with one. I think something just happened to Vista or something that is making it not work. Since I did all that crap with my hardware, I am figuring it's a software problem now, right?

So... what other steps did I take? Well I tried to roll back my registry once I saw that my DVD drive wasn't working - I figured I caught something nasty, even though all my spyware and antivirus scans weren't detecting anything. Didn't work. I then tried to uninstall Daemon and CureROM to see if that was the cause of the problem. Didn't work. One of the first things I did was simply uninstalled and reinstalled both the physical and virtual drives in device manager. Didn't work. I checked my group policies to make sure nothing was enabled or disabled that shouldn't be...

Everything was fine... and I know that it should work for one reason - when I was figuring out how to update this particular BIOS I found a little utility there that I eventually used to upgrade the thing... what it does it reads the A: or D: drive (floppy or CD) to find the BIOS ROM. It doesn't read NTFS file formats, so it won't read C: or a DVD formatted in NTFS (A new Vista thing), but when you pop in a regular FAT CD/DVD it displays the data on the disk. I put in the DVD's that I have been trying to use in Vista - and I could see every file and every folder. The drive is totally fine - Vista is just fucked.

I probably did more to the software, but can't think of it at the moment. So now I'm stuck... I have no idea where to go from here. Short of reinstalling Vista - I have no clue.

If any one has any idea - please, please, please help a very stuck person.

01.05.2007, 18:49
Actually, NTFS goes all the way back to the early versions of NT, not just Vista. As for your problem, try checking for the lowerfilters and upperfilters keys in the registry (should be under HKLM\System\CurrentControlSet\Control\Class, not sure which subkey for Vista). See if anything is in there that could be causing problems. Might be worth making a backup and just deleting them both if they exist even.

01.05.2007, 19:25
also, see if the disks etc are readable when booting into safemode, minimal driver set

01.05.2007, 23:44
I just re-read your post, and I realized you weren't talking about your HDD in NTFS, but the format option in Vista to use your RW disc like a hard drive (packet writing). My bad.