PDA

View Full Version : Daemon Tools musical tracks?



ccc333
11.06.2007, 21:51
hello, I know this may be a dumb question, but i am using daemon tools to emulate an Age of Empires 2 mixed mode multi track .bin image; and for some reason the music will not play in the game.

is there anyway to fix this:confused:

Copytrooper
12.06.2007, 16:13
If the game doesn't support digital audio, you're out of luck. In Windows 2000, XP and above digital audio is available by design, so if it fails it's the games fault (in Windows 2000 you've to enable it in device manager).

Jito463
12.06.2007, 16:22
You could also try making your virtual drive the lowest optical drive letter in your system (e.g. make your virtual drive D: and your physical drive E: ).

GhostMachine
14.06.2007, 06:51
If you have games which doesn't support digital audio you'll need an emulator which support analog audio as well. For all my old games Virtual CD works very well. You have to make sure the audio tracks of the game CD are created as music files, thats it. But you can't use the current version I read somewhere that this feature isn't longer supported so use an older version.
I've no idea if there is another emulator which support that but you may give it a try.

andwan0
05.05.2009, 18:35
If you have games which doesn't support digital audio you'll need an emulator which support analog audio as well. For all my old games Virtual CD works very well. You have to make sure the audio tracks of the game CD are created as music files, thats it. But you can't use the current version I read somewhere that this feature isn't longer supported so use an older version.
I've no idea if there is another emulator which support that but you may give it a try.

Could you give us the specific exact name of this Virtual CD program? I tried googling Virtual CD but that gave me vague lists of programs which use the catch phrase Virtual CD as a sub-title.

Is it one of these programs here:

List of ISO image software - Wikipedia, the free encyclopedia (http://en.wikipedia.org/wiki/List_of_ISO_image_software)

?

And please tell us the exact version you have that works with Audio Analogue music.

My Total Annihilation backup CD contains both Data & Analogue Audio. I run in XP with Daemon Tools 3.47 and don't get audio in my game.

Jito463
07.05.2009, 18:10
@andwan0
Try setting your DTools virtual drive letter to the lowest drive letter below your physical CD/DVD drives. Older games would only play audio from the first drive letter, because they assumed you only had one drive (at the time, CD drives were fairly expensive).

andwan0
07.05.2009, 18:31
@andwan0
Try setting your DTools virtual drive letter to the lowest drive letter below your physical CD/DVD drives. Older games would only play audio from the first drive letter, because they assumed you only had one drive (at the time, CD drives were fairly expensive).

Is A the lowest or Z the lowest letter?

Blazkowicz
07.05.2009, 20:30
A: is the lowest one, but i also think game won't check there due to A: and B: are normally used for Floppy Disk Drives.
Therefore i would try D:

andwan0
07.05.2009, 21:00
A: is the lowest one, but i also think game won't check there due to A: and B: are normally used for Floppy Disk Drives.
Therefore i would try D:

I have HD partitions C-I (yes, a lot of partitions).
and even more when I connect my removable HD...

I usually explicitly have physical CD drives starting from the highest end (Z:, Y:, etc). Then I allocate the virtual CD drives from the next available highest... (X: W: V: U:)

but yeah, I'll make sure it's in the U: drive then... or maybe specially have it on the D: drive.

But has anyone got analogue working with games like TA or AoE2?

I can play the audio via WMP.. but it'll be good if it's via the game itself since the game picks appropriate music depending if your TA robot units are getting thrashed by AOE2 knights

andwan0
19.05.2009, 16:10
Yes, setting drive to lowest letter worked once. Now I can't seem to get to work again :S Maybe it worked in XP but now in windows 7 it doesn't :S