PDA

View Full Version : Safedisc protected games not working with YASU



WhiteKnight
20.06.2007, 03:20
Hello!

I have tried a multitude of Safedisc 4.60 protected games with YASU cloaking and none of them seem to get passed the copy protection...i receive a message stating that CD emulation detected or something like that. However, YASU works a treat with SecuROM protected games, so I'm wondering why Safedisc dont work at all. Any suggestions? Does YASU work properly wtih Safedisc 4.60??

Thanks for the help!!

doughnut
20.06.2007, 20:13
All Safedisc games (including 4.60 and 4.70) work fine with YASU, there is probably some problem with your system or images.

Kinlaadare
20.06.2007, 23:40
If they do not work with YASU, it's not a YASU problem... more a problem with your images. Try recreate them using alcohol.

..::shiFt::..
21.06.2007, 00:20
what version of DaemonTools are you using?

please update SPTD + DaemonTools + YASU (links in my signature) and try again.


It can also be caused by programs like Virtual CloneDrive, Alcohol, etc.

GhostMachine
21.06.2007, 07:44
Normally Safedisc games aren't a big deal. If you really have the latest version of DT etc. the question is how did you create the image - software, version?

..::shiFt::..
21.06.2007, 09:41
well, since he get a 'CD emulation detected' message i think its a blacklisting, but you are right, Safedisc games aren't a big deal.


I think he got some other programs like Virtual CloneDrive installed.

WhiteKnight
22.06.2007, 01:41
First of all thanks for all the quick replies!! It's good news to know that YASU should be working great with Safedisc protected games so this keeps my hopes up.

I have the following programs/versions installed:

Daemon Tools v4.09
YASU v1.2.7060
SPTD v1.49

I don't think it is a problem with creating the images, i've even tried images created by others and same problem; i think ..::shiFt::.. is on to something however with there being a conflict with one of my installed programs. It's strange though that SecuROM games work fine, if there was a program causing a problem, wouldnt my SecuROM games not work as well??

I dont have Virtual Clone Drive installed; however, I do have Alcohol 120% installed. Is there a way i could get a list of all installed programs to show you and see if something stands out?

Thanks again for the feedbacks!!

..::shiFt::..
22.06.2007, 08:11
Try to update or uninstall Alcohol.

WhiteKnight
27.06.2007, 23:05
Try to update or uninstall Alcohol.

thank you for this suggestion, uninstalled Alcohol then tried to run game but still received "CD/DVD emulation detected" error msg...i even tried using sd4hider and same problem so i'm not sure what else could be conflicting...

SecuROM games still working fine with YASU though

Redeye
03.07.2007, 22:25
Well I have a Safedisc protected game but it is a no go.

I read this post and installed the latest software, only Deamon tools running for virtual drives. The game, Pacific Storm-Allies keeps asking me to insert the correct CD.

A bad image?

Thanks,
Redeye

WhiteKnight
04.07.2007, 04:28
just thought i'd give an update...finally got Safedisc game working with YASU...problem program seemed to be CloneCD even though I had disabled CloneCDs virtual drive that was not enough i guess so i uninstalled and now YASU and Safedisc games are working just as well as SecuROM games so yay! THanks for the direction guys!!

Dllfile
11.07.2007, 08:13
just thought i'd give an update...finally got Safedisc game working with YASU...problem program seemed to be CloneCD even though I had disabled CloneCDs virtual drive that was not enough i guess so i uninstalled and now YASU and Safedisc games are working just as well as SecuROM games so yay! THanks for the direction guys!!
Maybe CloneCD's "Hide CD-R Media" function was enabled when it was installed. That will cause protection to flag it bad. Even though, honestly, if your not even using CloneCD it should not matter, think protection companies need to rethink their approach.

xileF1337
11.07.2007, 16:03
hey dudes, I'm new in this forum :)

you simply have to close (or disable) the CloneCD tray icon :wink:

MRFRoST
11.07.2007, 17:27
If you have Blindwrite installed, you have to deactivate EZ-Play.

WhiteKnight
11.07.2007, 20:02
hey dudes, I'm new in this forum :)
you simply have to close (or disable) the CloneCD tray icon :wink:


nope, that didn't work...had to actually remove the entire CloneCD application...