PDA

View Full Version : TDU leaked patch 1.66a



famin
11.07.2007, 13:49
I downloaded the "unofficial" patch here http://www.megaupload.com/de/?d=NG1IJITH
There is a securom update in the patch.

The question is that even when the YASU 1.2 7060 tells me that "3 devices successfully cloaked", the securom can still detect my daemon 4.09 HE. Yes it's not that YASU is blacklisted, but bypassed. :confused:

TRB
11.07.2007, 21:39
Same problem here as well. This is the error it gives me:
http://www.securom.com/message.asp?m=module&c=5023

So I guess the new SecuROM can detect Yasu.

..::shiFt::..
11.07.2007, 22:07
wait for YASU v1.3 (http://www.daemon-tools.cc/dtcc/y-s-u-1-3-t17449.html)!

famin
12.07.2007, 02:10
Same problem here as well. This is the error it gives me:
http://www.securom.com/message.asp?m=module&c=5023
So I guess the new SecuROM can detect Yasu.

Sorry but we have different problems. Yours is because YASU is on the blacklist. when I use YASU 1.07, I get the same error as yours. But when I use YASU 1.2, YASU is NOT detected, but DAEMON is detected even when YASU is cloaking.

Blazkowicz
12.07.2007, 16:02
[!] SecuROM Detected - Version 07.33.0012
[!] Possible CD/DVD-Check String -> CD-ROM drive
[!] Possible CD/DVD-Key or Serial Check -> CDKey


That is the bad 7.33 again.

TRB
13.07.2007, 10:01
Well If you want the extra content, but don't want to use your disk, there is a way around it.

Before patching just backup testdriveunlimited.exe, then after applying the patch replace the new exe with the old backup. You won't get the bug-fixes, but you will enjoy a new Skyline and an RS4.

Wait for new Yasu huh? Ok.

Reef
14.07.2007, 15:30
For me it also detects YASU, and I am using the latest version.
But I managed to hide YASU using a program called HideToolz, but then I get the 'Emulator detected' error, just like without YASU.

Jito463
14.07.2007, 16:03
Sounds like it disabled YASU, instead of hiding it.

Reef
14.07.2007, 16:55
Sounds like it disabled YASU, instead of hiding it.
If that was the case, then other SecuROM protected games would also refuse to run. C&C3 1.05 still runs without problems, using regular DT.

Looks like this new version of SecuROM not only blacklists the latest YASU, it also uses another method to detect DT.

michaelv380
14.07.2007, 21:51
I downloaded the "unofficial" patch here http://www.megaupload.com/de/?d=NG1IJITH


...this patch is a fake!...

Reef
14.07.2007, 23:17
It may be unofficial, but if it was a fake then it wouldn't contain an updated SecuROM.

Reef
15.07.2007, 00:00
Forgot to mention it (and could no longer edit previous post), but this SecuROM version also blacklists DT Pro.

TRB
15.07.2007, 09:06
Actual patch is supposed to be released on Monday the 16th.

Blazkowicz, what version of PID are you using? Mine only reports SecuROM v7.xx. I'm using Protection ID v5.2c, which I think is the latest.

michaelv380
15.07.2007, 09:53
"Dear TDU players, please do not download the TDU patch 1.64A and 1.66A as they are not validated by Atari and may cause unknown problems to your game. The official TDU PC patch will be released very soon. Keep checking the atari websites for further information. Thank you for your understanding."
:rolleyes:

..::shiFt::..
15.07.2007, 12:36
@TRB: Blazkowicz is one of the lucky people that got the inofficial v5.3 beta from cdkiller.

korn2006
15.07.2007, 13:27
@TRB: Blazkowicz is one of the lucky people that got the inofficial v5.3 beta from cdkiller.

I also have it.:) :D

evlncrn8
15.07.2007, 19:41
well its a closed beta, other people could have it too :)
he announced the closed beta on fileforums, only 6! people volunteered..

A.Hecka
15.07.2007, 20:56
well its a closed beta, other people could have it too :)
he announced the closed beta on fileforums, only 6! people volunteered..

Sadly, I never saw the mentioned thread. Also a member of fileforums... (using a different name there)...
Any other way to be a part of this beta-program? ;)

Reef
15.07.2007, 23:09
Running YASU with the -usuck parameter seems to bypass the detection of YASU by SecuROM, however it still detects DT after cloaking drives.

TRB
15.07.2007, 23:21
Will this be fixed once YASU 3 comes out?

evlncrn8
16.07.2007, 11:54
who knows, and it'll be 1.3, not 3

sYk0
16.07.2007, 13:51
who knows, and it'll be 1.3, not 3
soon... ;)

RedScorpion
17.07.2007, 10:27
I confirm that with the 1.66A patch, now OFFICIAL, Y.A.S.U. DOES NOT work :D.

I hope to see soon if 1.3 will do. :D

Latest public available ProtectionID (v5.2c) just says it is SecuROM 7.X after applying the patch!!!

RedScorpion
17.07.2007, 10:42
[I thought I had already posted it but it doesn't seem, anyway]

I confirm that with 1.66A patch, now official, Y.A.S.U. does not work anymore.

I hope to see soon if 1.3 will :D.

Latest public available Protection_ID (v5.2c) just says it is SecuROM 7.x.

Let us know! :D

evlncrn8
17.07.2007, 11:55
[I thought I had already posted it but it doesn't seem, anyway]


you did.. posts are moderated unless your post count is < 20 or you are a customer..

NZ_Wanderer
19.07.2007, 01:25
I can confirm this as well with the Official TDU 1.66A patch, Y.A.S.U. does not work .
Will wait patiently for the new YASU to see if it works :) :)

swiss-cs
30.07.2007, 21:27
next time, pls give the link from the source you got it: blog.elitar.ch (http://blog.elitar.ch/downloads/)

Goenk
30.07.2007, 23:00
next time, pls give the link from the source you got it: blog.elitar.ch (http://blog.elitar.ch/downloads/)

Hi what source are you talking about?
Maybe he should reference to megaupload?:D

KoRn
31.07.2007, 00:01
@swiss-cs: Game patches
are quickly announced by
game news sites like GamersHell (http://www.gamershell.com/news/40147.html).

And YASU of course can be
found here (http://yasu.copybase.ch/).

swiss-cs
31.07.2007, 00:16
@swiss-cs: Game patches
are quickly announced by
game news sites like GamersHell (http://www.gamershell.com/news/40147.html).
And YASU of course can be
found here (http://yasu.copybase.ch/).

hm...can you read? LEAKED patch -> wiki (http://de.wikipedia.org/wiki/Leak) (german)

The Patch was leaked around 10th july and then the "official" PAtch was released on 16th july. The point is, th leaked patch is the same as the official.

btw: REALLY? YASU can be downloaded there, i dont knew that, thx alot! [/irony]

Robbie785
31.07.2007, 23:08
i think you ment [/sarcasm]... ;)

(now THAT is irony...)

KoRn
01.08.2007, 13:12
Owned. ;)

Ten chars

bigmanoncampus
26.08.2007, 00:20
i guess no way to have tdu 1.66a working yet?

RedScorpion
26.08.2007, 12:57
i guess no way to have tdu 1.66a working yet?
It works perfectely with new Y.A.S.U. and, for example, the POSEDEN MAXI image (few kb rarred and ~3,5gb unrarred).

bigmanoncampus
26.08.2007, 19:04
thanks for the tip :)

RedScorpion
27.08.2007, 10:52
NP mate! :D

Danoosh Pichgahe
26.07.2008, 09:31
Same problem here as well. This is the error it gives me:
SecuROM (http://www.securom.com/message.asp?m=module&c=5023)

So I guess the new SecuROM can detect Yasu.

I Have This Problem too! What Can I Do For Remove it? :confused:

Blazkowicz
26.07.2008, 12:18
What about not using YASU and just use latest DT Lite/Pro?