PDA

View Full Version : daemon tools v410, softice and my stupidity



n3Xus
30.08.2007, 10:17
hi!
i recently installed softice and afcourse i ignored the message thats incompatible with DT. so now ive tried: sptd deleter, removing registry...(i use vista 32 btw)

but still i get the error that SPTD is not installed...its a good chance that the answer is here already(ive done a search but i dont feel like going through 30 pages) so if anyone can point me in the right direction i would appreciate it very much,

n3Xus
30.08.2007, 12:12
btw i also tried to delete some registry keys manualy but i got an error that it cant be deleten(and yes, ive changed permission settings): Cannon delete sptd: error while deleting key.

evlncrn8
30.08.2007, 16:20
you have to disable the sptd driver from loading, by either uninstalling it (which then lets you access that key)
or (if i remember right), selecting not to load it on bootup

n3Xus
30.08.2007, 17:52
hm..so how do i uninstall it? i got rid of the sptd.sys files and as much registry as i could.

and how do i choose if i want to load it on startup?

Copytrooper
30.08.2007, 19:33
You've to disable SPTD in registry first (set Start value to 4 in services\sptd key), reboot, then you can enable all permissions of sptd\cfg key and delete it.
If you can't boot anymore boot with your Windows cd/dvd into recovery console, logon to your Windows installation (requires Administrator password), enter disable sptd, then exit to reboot.

n3Xus
30.08.2007, 21:54
thx for that :D
now been able to delete the registry entries.

but now ive got another problem: ive ran DT setup and it installs the sptd thing. than i restart but he still goes through the same process of installing the drivers :confused:

n3Xus
31.08.2007, 20:35
i still cant install it...altough i "install" it it says that SPTD isnt installed(im using the standalone installer). ive read that there are supposed to be more than one sptd.sys files(some sptd<somenumbers>.sys)-i only have sptd.sys.
also in the registry under current control set(i use vista ultimate 32 btw)>sptd>enum ive got a key that says INITSTARTFAILED(with a value of 1). ive tried to dleten but nothing(im not even sure what it does...)