View Full Version : STOP: 0x00000035 on XP SP1 (NO_MORE_IRP_STACK_LOCATIONS)

08.12.2002, 09:44
Hi - On my Windows XP Professional SP1, daemon tools 3.26 crash with a BSOD (STOP: 0x00000035, NO_MORE_IRP_STACK_LOCATIONS) after changing the number of image drives in daemon tools. After the crash, Windows starts up, but after a few seconds I get STOP:0xc000000a or similar (IRQ_NOT_LESS_OR_EQUAL).

After deleting the daemon tools folder and it's SCSI drive from HKLM\System\CurrentControlSet\Services and %windir%\system32\drivers in save mode manually (installer service not running);
INSERT INTO `portal_posts_text` VALUES
deleting the virtual SCSI adapter from device manager and uninstalling the rest in normal mode with the windows installer, system works fine.

I just converted C: from FAT32 to NTFS, but daemon tools has been installed long before - may be there's a driver access rights violation? I install daemon tools again right now and test that...

Quiet strange, eh?

System: AMD AThlon XP 1900+ on ASUS A7V8X, 512MB INFINEON CL2

Installed burning software: CloneCD 4, Nero, Nero InCD, Feurio!, Windows IMAP burning service disabled.

UPDATE: I just testet that again like I told you - same problem! Directly after changing the number of drives, system crashes with STOP: 0x00000035, NO_MORE_IRP_STACK_LOCATIONS. If I just do nothing but changing images, daemon tools runs fine. Problem can be reproduced over and over again.

Any ideas?

08.12.2002, 21:26
Have you ever Easy CD Creator installed on this machine?

08.12.2002, 21:38
No, ECDCreator has never been installed on this machine - I know that that burning software is crap :)

09.12.2002, 06:42
NO_MORE_IRP_STACK_LOCATIONS may be caused by soem filter drivers, that is why i asked about Easy CD. I think you can try to uninstall all other burning soft one by one to check which one causeing problems.
Do you have minidump after crash?

09.12.2002, 11:54
Hi - I wrote an email last night to tell you, that the problem is solved, because I wasn't able to access the forum:

I made some troubleshooting:

- Downloaded "CD Emulator" trial and installed it: BSOD IRQ_NOT_LESS_OR_EQUAL - that made me think of APIC...
- Safe mode, deinstalled "CD Emulator", changed to "ACPI PC" (previously "ACPI Uniprocessor PC")
- Reboot
- BIOS: Switch from APIC to PIC
- Installed Daemon Tools
- Switched # of drives in daemon tools-> OK
- Repair installation (problems with ethernet adapters)
- Tried to switch # of drives in daemon tools, still no problems!

So as you see, APIC seems to be the problem. After disabling APIC, all works fine. May be, one ore more drivers do have problems with the extended interrupt handling.

09.12.2002, 16:56
Thanks for information.

14.12.2002, 22:44

I have similar problems ("STOP: ..." "NO_IRP..." IRQ_LESS..." as outlined here but I can't get as far as a completed installation.

Now I have a virtual drive "G:" but no icon in the startup tray, the app won't start from the desktop icon AND most importantly, I have no means of uninstalling the partial program as I have no Daemon Tools entry in "Add/Remove Programs." :(

Help?! Is there a manual means of uninstalling documented? I have tried multiple times to reinstall D-Tools to get at least to a point where I have the ability to uninstall per the supported means but I can't get that far. My system seems stable except for when I click the D-Tools icon on the desktop, do properties on the virtual drive in Explorer or (most troublesome,) mess in any way with device manager. All of the above result in BSOD.

I have never had EasyCD on this machine, I do have Nero, InCD, DiscJuggler and I had installed Alcohol 120% but that is now gone as I had problems with it that were very similar to what I'm experiencing w/ D-Tools. Also, this is my first attempt at installing D-Tools, no previous version was tried.

I'd rather not deal w/ switching from APIC if at all possible as I don't have a full backup of this machine currently and anyway, I have read about serious performance issues when moving away from it...

Any help/clues greatly appreciated.


PS: Relatively new and previously VERY stable PC:

MSI 6380E KT3Ultra2 MB w/ retail XP2000+ and 256M Crucial
MSI G4Ti4200, Enermax 350W PS
XP Pro w/ SP1

16.12.2002, 22:29
Well, I don't know exactly which of the following solved my problem but I now have a working D-Tools install and I'm happy...

Installed FireBurner. It noticed the broken D-Tools install and offered to clean up! So I said yes, finished the install of FB, rebooted.

On startup nothing had seemingly changed w/ D-Tools. The drive was still there and still no taskbar icon nor option to uninstall in "Add/Remove Programs," so I ignored it for the time being. I tried FB but it's apparently cripple-ware so I uninstalled it. At the same time I uninstalled Ahead's In-CD. Also uninstalled DiscJuggler. Installed Blindwrite. Unsuccessfully burned a BIN/CUE of UT2k3.

Now here's the relevant part: I reinstalled D-Tools at this point and all went fine, no crash toward the end of the install!!! Reboot, the final portion of startup took lot's longer than normal but probably only about 30 extra seconds in actuallity.

Mounted my three UT2k3 backup images and installed the game successfully. Re-mounted image #1 and played the game!!

Hope this helps someone out. I'm so glad I didn't have to mess with APIC and such...

Bing :D

17.12.2002, 22:33
hm, I bet that installing discjuggler helped. This is because dj uses win installer for setup. Windows installer detects (or its supposed to) interupted setups. Your d-tools setup probably was interupted for some reason...

20.12.2002, 17:07
I have the same problem as noted here, i.e "STOP: ..." "NO_IRP..." IRQ_LESS... etc.

This however, happened until I decided to upgrade the software from 3.23 to 3.26. It was working fine with 3.23 version.

Yes I do had CD Creator 5 and Nero installed on my machine. CD creator is now deinstalled.

Since version 3.23 has no problem installing on my machine, I believe that there is flaw in the new update version of the program that is creating havoc on ppls coumputers.

BTW, I was able to stat my Windows XP SP1 by cancelling the continued Dameoon installation screen, which appeared after the reboot.

I have and old Asus Motherboard (P3B-F);
INSERT INTO `portal_posts_text` VALUES
256 RAM and Petiuum II 450 in my computer.