View Full Version : stumped by PNPHLP.vxd

23.12.2003, 06:21
Operating System: win98SE, 512RAM
Burning Software: Nero, alcohol 120% 4.8+
Anti-virus Software: Norton AV 2002
DAEMON Tools Version: 3.43

hi, i started using DT since 3.33 and no problems at all so far. till i upgraded to 3.43. during reboot, win98se hanged half way thru, at abt 80% and before going into desktop.

to cut long story short.. i've done extensive trial & error and checking and have confirmed that it's the pnphlp.vxd that's causing the problem. in order to boot properly, i must use StepbyStep Confirmation and when asked whether to load pnphlp.vxd, i must say No. otherwise win98se will hang.

however, by not loading pnphlp.vxd, i won't be able to use DT coz it'll say "virtual SCSI driver not found". but on the other hand, if i boot normally (load all drivers) win98se can't boot properly, it'll hang.

i've tried removing pnphlp.vxd from the registry. after which win98se is able to boot normally (but cant use DT ofcoz).
i've also tried uninstalling/reinstalling many times, using DT version 3.41 and even 3.33.. but it seems everytime pnphlp.vxd is present, win98se cannot boot now.
i've also tried restoring my registry using scanreg /restore at command prompt. problem still persists, as long as pnphlp.vxd is present.

although i've fixed my boot up problem (by removing pnphlp.vxd from the registry);
it looks like i can't use DT ever again... is there a fix? or i need to wait for newer version than 3.43?

i hope this will help towards making future versions a more robust one.
meantime, if anyone has a fix for this i'm very much appreciate it.


23.12.2003, 21:48
This vxd is a plug and play extension driver containg some kernel imports needed by Daemon Tools to operate in 9x environment (extension to ntkern.vxd).
Please provide extensive list of software used on your PC, you system specs etc. The more info you provide the more chance we can find out what happens.

24.12.2003, 03:35
hi developers, i've found out the reason. hope the below will provide you some help.


hi everyone, again..
i've found something interesting...

my above post said i cant seem to use DT ever again.. dat's true, after upgrading to 3.43, i cant boot properly, have to bypass pnphlp.vxd. and if i bypass loading pnphlp.vxd, DT cant work.

even i've managed to remove 3.43 and then install 3.41 or even 3.33, same problem. either can't boot properly, or cant use DT. Now i've fixed this problem too.. and the solution is interesting.

it has to do with warcraft3 patch 1.13

few days back i've read a lot abt patch 1.13 on bnet and how pple whine abt image not working, and some posted saying patch 1.13 installed something "illegal" without your knowledge, designed to beat virtual drive +image. i didnt pay much heed to that at that moment.. and it seems blizzard release a patch 1.13b soon afterwards. again i dont pay much heed.

i've patched to 1.13 just before i upgrade to DT 3.43

starting earlier today i started to hav a strong hunch and finally, reluctantly, i dig out my original war3 cd, start up, and got it patched to 1.13b.

u can guess the rest.. i reinstall DT3.41, and huaa! win98se is able to boot up normally and DT works just like it always did.

i've done nothing else for the last two days except uninstalling/reinstalling DT 100times trying to fix the problems and getting DT to work again..but never did. but once i patched war3 to 1.13b DT now works.

has patch 1.13 got anything to do with it? i wld say definitely. coz i'm very sure i have done nothing else (like installing some other app) to suggest it could be other drivers dat's causing this.

next i try upgrading to 3.43... and the problem is back!!!
this time however, after i uninstall 3.43 and reinstall 3.41, pc is ABLE to boot properly and DT works. unlike previously when i was at patch 1.13 (war3);
uninstalling 3.43 and reinstalling 3.41 won't work.

end of report, hope it's useful.
any other queries fell free to ask. sooner the better coz later i might forget


25.12.2003, 01:42
Unfortunately this does not provide me any info. On my and many other PCs it never happened with or without WC3 patch.
What i need is full list of your hardware (SCSI/RAID controllers, including virtual) and list of software that may install drivers (eg. virtual drives). So it would be nice if you replied my post.

Beetle B.
27.12.2003, 06:22
Operating System: Windows 98 SE
Burning Software: Nero Express
Anti-virus Software: None
DAEMON Tools Version: 3.43


Pentium 4 2.53 GHz
Asus P4PE motherboard (includes network card + sound card)
40 GB Maxtor
Optiquest 71 monitor
Radeon 8500 LE 128 MB
USR 2977 internal hardware modem

Asus Probe (monitor temp, etc).
Radeon related software
3 Deep
Hydravision (window manager)
Championship Manager 4
Red Alert 2
Extract Now (unzipping utility)
Intel Application Accelerator
Nero Express
True Internet Color
Windows Media Player.

30.12.2003, 08:30
Operating System: Windows 98se (4.10.2222A)
Burning Software: Nero Feurio V 1.51
Anti-virus Software: Mc Afee Vshield V 4.0.2
DAEMON Tools Version: Uninstalled right now, had version 2.88 then 3.43 installed

Hello all,

I hope that this helps some to fix this problem. I am having the same problem as above. I am running Windows 98se (4.10.2222A) with Nero ( and Feurio (1.51) burning packages installed (an older copy of EasyCD was removed a long time ago and Nero cleaned up left over drivers)
I was using Daemon tools V 2.88 and decided that it was time to update it. This is when I started having my problem :-( . I do not have Warcraft3 on my machine but I DO have Blizzard's Diablo2 with the latest 1.10 patch installed.
According to the bootlog, my machine will hang while loading the EIDE drivers.
To get my machine going again I renamed my EIDE driver in the IOSUBSYS directory and was able to boot. After trying various things, including disabling various drivers in the IOSUBSYS directory, including nero's driver and re-installing and updating my EIDE drivers, I found that if I disable my second IDE controller in Window's device manager and re-enable the EIDE driver (amdeide.mpd) the system would boot up using the correct driver for the main IDE controller. I do have some system instabilities now however. As soon as I re-enable both controllers the system hangs on boot up again.
Note: Removing Daemon tools didn't help either.

These are the last few lines in the log.....
[0005EB7B] Initing hsflop.pdr
[0005EB7D] Init Success hsflop.pdr <------Floppy driver
[0005EB7D] Initing symc8xx.mpd
[0005EC2F] Init Success symc8xx.mpd <----Fireport Scsi card
[0005EC2F] Initing amdeide.mpd
[0005EC55] Init Success amdeide.mpd <----AMD Eide controller
[0005EC55] Initing amdeide.mpd

As you can see it hangs the second time it inits the EIDE drivers.
Now, the weird thing is if I run Window's hardware autodetect, with the second EIDE controller disabled in the device manager, it will find it as a regular controller and I can then access the DVD and CD-ROM drives on that controller. The system is still not as stable as it was before this problem happened though. I have also tried booting with nothing connected to the second EIDE controller and it makes no difference, it still hangs.

I was originally using the AMD-756 IDE 1.36 busmastering driver and am now using the AMD-756 IDE 1.43s busmastering driver.
(as I mentioned before about updating my driver. :-) )

Now since this post is really starting to get long winded I'll see if I can finish up ;-)

To now the only other thing that I have done is to search my hardrive in order of date to see what files have been modified since the problem happened. One file that I noticed was the Pnphlp.vxd file, I will try and disable that to see if I get the same results as Foxxkat did. There are several other files, but I will not list them unless they are part of a solution I come across or am asked to :-)

One last thing to mention, when I originally upgraded Daemon tools form 2.88 to 3.43 I had a problem with the installer. Unfortunatly I did not document it.

Athlon Slot processor @ 750Mhz
AMD 751/756 chipset
2x Maxtor HDD on primary IDE
Pioneer Slotload DVD-ROM and LG CD-ROM drive on secondary
Fireport SCSI card with external Plextor 12/10/32 burner
AGP Asus V7700 Pro Video card

Hope that this info is of use.

30.12.2003, 11:50
PNPHLP.VXD issue will be fixed with next Daemon Tools version coming soon.

30.12.2003, 22:44
PNPHLP.VXD issue will be fixed with next Daemon Tools version coming soon.

Good Stuff :-)

Just to update everyone, I've removed pnphlp.vxd and can now use the proper EIDE drivers on both controllers.

I am still having some "strangeness" happening though. So I have a question....

On my system the following files have been either changed or added since the install of Daemon Tools and I was wondering if the install had anything to do with the changes: Eio2.vxd, HwInfoD.vxd, SIntf16.dll, SIntf32.dll, or SIntfNT.dll All these files are in the Windows\System directory.

By the way, if you would like some one to beta test your changes I'd be happy to help out.


30.12.2003, 23:24
Just an addition to my last message for anyone reading this thread.

Out of the files: Eio2.vxd, HwInfoD.vxd, SIntf16.dll, SIntf32.dll, & SIntfNT.dll

HwInfoD.vxd is for the MSinfo utility and is recreated by it, so it is likely not important. SIntf16.dll, SIntf32.dll, & SIntfNT.dll all seem to deal with CD-ROM operation (SecuRom v2 from what I can tell). I'm not sure what Eio2.vxd does.

An interesting note, on Blizzard's site, I found while searching in regards to SIntf16.dll, SIntf32.dll, & SIntfNT.dll is concerning problems with reading the Diablo2 play disk. They suggest that you install their program Analysis.zip, but to back up those files first as Analysis.zip replaces them.

Halfway down the page here.... h**p://www.kolumbus.fi/mira.laine/d2/cd.htm

So it may be possible that the SecuRom v2 files are the connection Foxxkat and I have in common since we both run a Blizzard product. :roll:

31.12.2003, 04:19
Just an update for anyone that is following this thread...

Ok, Eio2.vxd looks like it is part of the Asus SmartDoctor program
(ASUS I2C Driver) Found where it came from when I reinstalled the video drivers. It would have been nice if they actually labled it! :roll:

I had installed / updated the SmartDoctor a little before I upgraded Daemon Tools (but before the problems)

Anyhow my system seems to be happy now, any instabilities I'll probably attribute to the video driver as it is new. ;-) The only problem I now have is that Dialbo2 LOD will no longer run with the disk in my CD-Rom drive, but it still works if I use the DVD-Rom drive, go figure! If I try running it in the CD drive (the one that I always used for it) it says "Please verify that your Diablo 2 Expansion disk is in your CD-ROM drive..." so it looks like the copy protection is failing for that drive now.

04.01.2004, 08:01
VeNoM386: sori for the late reply, hardpressed for time lately.. anyhow, the info u seek listed below, if it's still useful.

Windows 98SE 4.10.2222A (all critical issues patched as at my first original post)
PIII 933Mhz 512ram
Creative Geforce2 GTS
nVidia Detonator Driver 45.23
SB Live! 5.1 Digital driver
Western Digital WD800JB 80G 7200/8M HD
Intel Application Accelerator 2.3

Alcohol 120%
BlindWrite Suite 4
Daemon 3.41

Other suspicious (to me) Apps:
Quicktime 6.4
Divx 5.1 Bundle
Divx Pro-Codec 5.1.1 Beta

04.01.2004, 10:21
Did you try v3.44 yet?

07.01.2004, 00:17
Did you try v3.44 yet?

The installation of version 3.44 went well. I tested it with a few different CD images (no copy protected ones yet) and it worked great. Rebooted with no problems.

Thank you very much for your time and a wonderful utility. :D