PDA

View Full Version : Проблема с кодировкой



xKVtor
08.10.2007, 21:58
@xKVtor: Вы не могли бы постить в "нормальной" кодировке как все? Ибо переключать каждый раз encoding в режим 1251 на Ваших постах просто мучение...;( Признаюсь честно, я не совсем понял суть проблемы. :( Ни на одном форуме у меня траблов с кодировкой до этого не не возникало. В предварительном просмотре сообщения так же все выглядит вполне нормально. Что я делаю не так ? Не баг ли это форума ? Подозреваю, что я наверняка не последний посетитель с подобной проблемой. Поэтому пытаюсь создать соответствующую тему. Кстати, нельзя ли для русского подфорума установить автоматический перекодировщик. ЗЫ: Сейчас принудительно выставил в броузере Юникод (UTF-8) (пользуюсь IE 6.0.2800.1106, по-умолчанию автоматом устанавливается Западноевропейская (ISO)). Если поможет, дайте пожалуйста знать. Сорри за неудобства. :(

r-support1
08.10.2007, 23:01
A можете для теста попробовать сделать пост Файрфоксом (Firefox).
Ну и скажем в кодировке Western-ISO-8859-1?

Для интереса: есть ли возможность сделать бы пост и с помощью браузера IE7?

Также а какая у Вас стоит версия Windows? И какие региональные установки выставлены?
(попробуем может мы сами воспроизвести проблему :-)

xKVtor
08.10.2007, 23:44
A можете для теста попробовать сделать пост Файрфоксом (Firefox). Ну и скажем в кодировке Western-ISO-8859-1? Для интереса: есть ли возможность сделать бы пост и с помощью браузера IE7?Нет у меня пока ни файрфокса, ни ИЕ7, надо качать....
Также а какая у Вас стоит версия Windows? И какие региональные установки выставлены? (попробуем может мы сами воспроизвести проблему :-) Win XP Home Edition SP1 все все региональные установки на "�*УССКИЙ" по умолчанию страница открывается в "Западноевропейская (ISO)" Причем в ЛЮБОЙ кодировке Ваше сообщение видится нормально. Мое первое сообщение видится нормально только если вручную перевести в ту кодировку в которой я его написал, т.е. в Юникод (UTF-8). Заголовок этой темы в любой кодировке представлен кракозябрами. :( Если подобной проблемы больше ни у кого не возникнет, то возможно, это всего лишь глюк моей системы. :( ЗЫ: Кстати, проблема осложняется постмодерированием - я не могу сразу же наблюдать результат. Может, глюк проявляется в процессе модерации? Хотя это вряд ли...

r-support1
09.10.2007, 00:21
модерирование не причем - сразу видны у Вас иероглифы...

проще все же скачайте Firefox и давайте выясним, может там не будет этой проблемы.

а то боюсь мы попросту будем игнорировать в дальнейшем Ваши посты (много отнимает времени и сил эта смена кодировок)

LocutusofBorg
09.10.2007, 04:43
situation must be solved ASAP. Whatever caused it, we cant
and want fix other encodings-problems.

It is obvious that it works for everyone else. Please fix this
as soon as possible, it generates additional work that noone
of us can take care off permanently, thank you

xKVtor
09.10.2007, 08:21
Я понимаю, что с моими роблемами рабираться никому особого интереса нет. Но уж потерпите чуток, пожалуйста. :)


модерирование не причем - сразу видны у Вас иероглифы...

Иероглифы в моих предыдущих 2-х постах появились из-за предустановленной UTF-8. Надеялся, что это поможет. Но похоже зря. :(


проще все же скачайте Firefox и давайте выясним, может там не будет этой проблемы.
а то боюсь мы попросту будем игнорировать в дальнейшем Ваши посты (много отнимает времени и сил эта смена кодировок)

Скачаю.
Хотелось бы все же решить эту проблему под IE6.

Просьба к модераторам не модифицировать этот мой пост, хочется увидеть как он будет виден безо всяких ухищрений с моей стороны и без модераторской правки.
Потом все равно эту ветку можно будет потереть полностью или оставить только важную/существенную информацию.

=====TEST========
яяяяяяяяяяяяяяя
ааааааааааааааа
ррррррррррррррр
ооооооооооооооо
ЛЛЛЛЛЛЛЛЛЛЛЛ
ЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯ
ААААААААААААА
=====TEST========

Вопрос, кстати возник: на каком этапе должна происходить перекодировка в юникод ?

По умолчанию в броузере в этом форуме стоит кодировка "Западноевропейская (ISO)".
При предпросмотре (preview post) при переключении "в виде HTML" (в блокноте) весь русский текст читабелен, т.е. используется виндовская кодировка.

Так вот, кто же должен перекодировать win->unicode ? Броузер (во время отсылки данных) или движок форума (при возращении результата обратно пользователю) ?

xKVtor
09.10.2007, 08:46
Sorry...
=================TEST#2==================
111111111111111111111111111111
аааааааааааааааааааааааааааааа
бббббббббббббббббббббббббббббб
яяяяяяяяяяяяяяяяяяяяяяяяяяяяяя
ААААААААААААААААААААААААААА
ББББББББББББББББББББББББББББББ
ЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯ
222222222222222222222222222222
=================TEST#2==================
При входе на форум устанавливается Западноевропейская (ISO).
Выбираю насильно кодировку Центральноевропейскую (ISO).
Набираю сообщение.
Делаю превью сообщения.
Просматриваю в HTML виде и вижу Уникод!

На этот раз должно получиться!
Теперь как бы установить эту кодировку для этого сайта по умолчанию ? :(

ЗЫ: Еще раз прошу прощение за лишний мусор в ветке, потом почищу, когда появится право на редактирование своих собственных сообщений.

r-support2
09.10.2007, 12:00
Это последнее сообщение видно нормально сейчас.

brem
13.10.2007, 16:07
Будет ли выпущено обновление программы для StarForce 4.7.11

DenisBY
25.10.2007, 15:06
I guess better way to fix it is set default charset on this site to UTF-8. And also check encoding in database (MySQL I guess).