View Full Version : My ORIGINAL copy of MOHAA/BF1942 fails to run, probably due to SD2's Blacklist

23.12.2003, 23:46
Hey, thanks for reading.

MOHAA and BF1942 used to work fine, until WinXP decided to die on me, and I had to completely uninstall/reinstall my OS. Of course the registry was wiped, but luckily I had kept a recent backup of it.

After restoring the registry, some games/applications worked, some didnt. The ones which didnt I obviously re-installed, then they worked fine.

Except for MOHAA and BF1942. Since they're both SafeDisc 2 games I figured that the blacklist must be what was stopping the games running. When I try to run them there isnt even a splash screen, just a bit of hard drive activity, then nothing.

I uninstalled all programs which could have been causing this, namely Alcohol 120%, and Nero 5. I have no virtual drives installed. Still, neither game works. I have no other programs which could be triggering this problem. I even recently installed the latest DAEMON Tools (nice tool, by the way) and turned on SafeDisc emulation, but this doesnt help either.

Remember I'm trying to run off original copies here.

Anybody got a solution? EA Technical support couldent help me.

24.12.2003, 09:34
Did you try to uninstall and re-install the games?

24.12.2003, 13:01
Yep, tried it several times.

Anybody got a list of programs blacklisted by SD2?

The protection doesnt search for executables containing a program such as Alcohol 120% does it?

24.12.2003, 13:03
No, blacklistings search for other things, but the games you mentioned should work fine with newest Daemon Tools and/or Alcohol versions!

24.12.2003, 17:58
Agh. I've read on the internet that you can tell if the blacklist is checking because a .tmp process pops, up when you try and run the program, in the task manager. Here are the ones I got:

MOHAA: ~f51e43.tmp
BF1942: ~f39a36.tmp

In addition to either MOHAA.exe or BF1942.exe. Sometimes I get one, sometimes the other, sometimes both.

By the way, I have the latest DirectX, latest patches for WinXP, latest video/sound/motherboard/chipset drivers, no apps running in background etc etc. This cant be a standard error, it must be the copy protection.


24.12.2003, 18:43
I should have tried this earlier. I got a no cd patch for MOHAA, and the game works perfectly now. Something has screwed up, because we know its not the blacklist now, and since this is an original copy...

I'm trying to get a NO-CD for BF1942 right now, with any luck once I get a working one the game will start to work too.

Maybe I got new drivers for my CD Drives when WinXP screwed up. However I have got 2 CD drives, and I've tried the game on both of them, they cant BOTH have got screwed...


27.12.2003, 23:08
MOHAA online doesnt work with a NO-CD patch, which is what I mainly play on MOHAA, which sucks ass.

I can't get a NO-CD for BF1942, but I dont want one now anyway, considering BF1942 is almost completely online play, which I wont be able to do if I use a no cd patch :cry:

This really stinks. Hasnt ANYONE got a solution? I cant believe EA and Macrovision for being pathetic enough to build and "protect" a game which doesnt work at all! They're scandals for making me pay over Ј60 in total for absolutely nothing other than frustration!


28.12.2003, 22:40
Battlefield 1942 works fine over here. If reinstalling it and making images with clonecd isn't working, something is wrong with your computer.

You said that you had to uninstall/reinstall windows xp. I assume you didn't format the hard drive and just reinstall (which would have been a better idea);
but ran the xp cd and just "upgraded." I don't see how you even uninstalled xp unless you were dual booting with another os.

Anyways, loading a registry backup after a fresh install can screw lots of stuff up. I just recommend doing a clean install.

30.12.2003, 22:56
Ok basically here's what happened.

I was changing the boot screen for windows XP. I've done it hundreds of times before. To do it you have to change a file in a system folder, but you have to do it in safe mode. I booted into safe mode, but without thinking I clicked yes on the box which pops up, the box which asks you if you want to revert to a recent restore point. This completely screwed up my PC. When I tried to boot, I just got a STOP error either while trying to boot in safe more or in normal mode. When I tried to do a repair of my installation, but installation would crash about half way through, with a STOP error. So I just started again, and did a clean install, installing OVER my current screwed installation of windows xp.

It worked, the registry was wiped so I added in all of the stuff from my backup. Some things worked, some things didnt. Reinstalling the stuff which didnt fixed the problem. Except for certain game, safedisc protected games.


I've discovered that Re-Volt, also a SD game, doesnt work. Same thing happens as with other games.

I made an image of BF1942 in CCD format with Alcohol 120%. I used A120's virtual drive to try and run it. Exactly the same thing happens as before.

Surely if using a No-CD for MOHAA fixes the problem, it MUST be copy protection based... Besides, all SecuROM games, such as Unreal Tournament 2003 and Hitman 2 work, backup and original. All game demos work too.

Looking grim...

03.01.2004, 23:03
OK today I tried doing a repair installation of Windows XP, and it didn't help.

Exactly the same as before. I can't be bothered to do a full installation and put everything back how it was. Besides, thats really drastic, there HAS to be a simple solution.

05.01.2004, 00:51
What cd-rom/drive are you using? The exact model would be helpful.

10.01.2004, 10:55
I've got a CDRW, and a normal CDR.

Samsung SC-148F

Games work with neither of these drives.

BTW: I uninstalled Norton Antivirus 2003 to see if it would help. Didn't.

10.01.2004, 22:02
If you have the time and inclination, I would strongly recommend a format and clean install for your system. It may be a hassle, but I predict it will save you time in the long run on future problems that may arise from your current situation.

11.01.2004, 00:21
Yeah, I've thought about that...

The problem is is that if I just reformat drive D (windows only drive) and do a completely clean installation, then all of my stuff on drive C (everything else drive) will need to be reinstalled too, so I might as well reformat both drives.

Some time soon I might get some larger hard drives, so I will have to do the equivilent then anyway, so I think I'll wait 'till then.

All I want is a stable and reliable system! *sob* Too bad all the games/programs I need only run on Windows :(

11.01.2004, 00:26
Windows is actually pretty stable if you take the time to maintain it and use common sense when installing new applications. 8)

11.01.2004, 11:19
Windows is actually pretty stable if you take the time to maintain it and use common sense when installing new applications. 8)

HEY! Thats not very fair!

I made one small mistake, which was allowing windows to restore a recent backup, but for some reason not relating to me, windows refused to boot, safe mode or normal mode, after the restore. Now correct me if I'm wrong, but thats not supposed to happen.

After I recover from this catastrophe, again, for unexplainable reasons certain games fail to work. You can't pin this on me because nobody has said what has caused the problem. Its another of Windows' faults.

Admittedly Windows XP is a lot better than the earlier versions. I have yet to get a BSOD or STOP message once Windows is running properly, the only time I do get them is when my system is completely screwed. I hardlu have to reboot at all after using the PC for a while because of slowdown, but I reckon this is mainly due to the fact I upgraded to 256mb RAM recently.

But lets not forget the scandals which Microsoft are, read here to find out more:


They're actually the same site, but who cares! Click the name which appeals to you most.

11.01.2004, 18:57
All I want is a stable and reliable system! *sob* Too bad all the games/programs I need only run on Windows :(
I was referring to that quote, not trying to take cheap shots at your computer abilities. 8)

12.01.2004, 22:22
Yep, I got it sorted. Wanna know how?

I think I took the long way around:

I reformatted both of my hard drives and did a clean install of windows. Everything works fine now.

I think thats all I need to say, really. Nobody else appears to have ever had this problem, so with any luck I'm the only person who had to do a complete reformat.

Thanks for the help everyone! :D