View Full Version : Homeworld2 1.1 patch - Securom nonsense

24.12.2003, 07:51
Homeworld2 1.0 runs fine with daemon tools 3.41 and 3.43. However, the recent 1.1 patch adds something that looks for CD emulation software and if any is running, the game won't launch. Details are on http://www.securom.com/emulation.

I've never seen a patch do something like this before and I'm pretty disgusted by it. Is there any chance that a future version of daemon tools might bypass this Securom nonsense?

24.12.2003, 09:42
Do you try to play from mounted image or RMPS burn?
Note: You do NOT need any emulation from mounted image, mds/bwa image with DPM data is enough!

24.12.2003, 19:26
From mounted image. The new Homeworld2 exe now detects CD emulation software and if it's running, returns an error.

24.12.2003, 20:21
And all emulations are DISABLED?

25.12.2003, 00:38
yes even with all emulation off you still get the same error, i guess its checking to see if daemontools is running. same with alcohol with all emulation off.

ok, scratch that, it looks like you can use alcohol to mount it as long as you turn the RMPS emulation in alcohol off (and close daemontools completely)

/edit again
ok, now its not working even with alcohol this is weird.

/edit last time i promise
ok, from what I can tell it somehow blacklisted alcohol after that one time I ran with it mounted in alcohol, this is weird. its gotta be checking if the program is simply running because even if I put my hw2 cd in the drive it still gives that error message until I close daemontools

wow, ok even with daemontools closed and all emulation off as well as all mounts disabled (same with alcohol) hw2 won't run, it just gives that error over and over again. sorry for the multiple edits, i kept thinking i had this thing licked.