PDA

View Full Version : Installation hangs when registering driver



clyderadcliffe
02.01.2004, 18:58
Operating System: Windowx XP SP1
Burning Software: Nero 6
Anti-virus Software: Norton
DAEMON Tools Version: 3.44

I uninstalled the previous installed 3.33 version and tried to install the 3.44 version. But at the point when the drivers are registered the one of the msiexec from the installer uses 100% cpu and wouldn't return.
Killing this task lets the install process continue but with missing driver for Universal PnP.

After remove of 3.44 I tried to reinstall 3.33 but this version also hangs.

I'm glad if someone could help me with this problem or tell can me a way to install the needed driver manually.

Thx

Development
02.01.2004, 20:09
You cannot install it manually - there is some PnP problem in your OS.

clyderadcliffe
03.01.2004, 10:42
PnP works fine, like camera or scanner.
Installation of Nero ImageDrive also worked flawlessly.

The problem is that the driver of daemon-tools is not registered (since it hangs at that point and I have to kill the task). When Windows XP is restarted it recognizes the added device but not the driver. As I mentioned before this also happens now when I try to install the older version. Then it askes for st3shark device driver, and when starting daemon-tools it reports "Virtual SCSI driver not detected."

I thought it might work if I select an ini file at the point when windows is detecting the driver. The same kind of ini files that comes along with some other drivers.

Development
03.01.2004, 17:31
Driver is installed with built-in Windows API (UpdateDriverForPlugAndPlayDevices) - if it hangs for you or causes 100% CPU usage, then it is hard to say what is happening.
Make you sure your device manager is clean from any devices with question marks. And disable Antivirus completely.