View Full Version : Cannot install 344 version.

John Fitzsimons
03.01.2004, 04:51
Operating System: Windows '98 SE.
Burning Software: Software for Sony DRU-510A and JLMS XJ-HD166S
Anti-virus Software: Vet
DAEMON Tools Version: 3.44

Hi, I seem to be having the same problem installing with this release as I had with the previous one. When I re-start the computer after installation I get "Windows protection issue. You need to re-start your computer." Doing so gives me the same DOS message.

I will start at the beginning in case any extra info helps with debugging. Firstly, my "Bus driver name" is d344bus and my "Miniport driver name" is d344prt.

When I first tried things out I tried the "silent install". Everything seemed okay (prior to re-starting the computer). Unlike with 343 I ended up with the tools icon in my tray. Great ! I thought. Until I tried to re-start and got the above error again. :-(

I knew that renaming pnphlp.vxd would enable me to start windows but I also knew I would then get an error on startup complaining about the missing file and another "Virtual SCSI driver not detected" when into windows. So I decided to close down from that DOS message. Before I did however I got another message. I think I might have given things the three finger salute rather than just turning off the machine.

Anyway, in case it is of help in de-bugging, the message I got was ;

"An internal stack overflow has caused this session to be halted. Change the stack settings in your config.sys file, and then try again."

There is nothing listed there under "stacks". I think it might mean something like "buffers" but am not sure what the new number should be. It is currently 40.

P.S. The de-installation is not "clean". After I uninstalled 3.44 the entry pointing to pnphlp.vxd seems to have stayed. I got that it was "missing" on startup. Which is exactly what it should have been doing !

Hope the added detail is of help. I sure would like to install this program.

Regards, John.

03.01.2004, 17:38
pnphlp.vxd should always stay - do not delete it. Make sure it has version 1.05. Can you boot without Daemon Tools (with pnphlp.vxd only)?

John Fitzsimons
04.01.2004, 00:38
How do I work out what version pnphlp.vxd is ? No idea if it is 1.05 or not.

I did a new bootup with ONLY pnphlp.vxd in the windows system directory and everything booted okay !

No other Daemon files, or registry entries, were present.

Thanks for the suggestion. Hope this of help in finding the problem.

Regards, John.

John Fitzsimons
04.01.2004, 05:57
Okay, I have now done some more research. After going to ;


I decided to

(A) Add the following to my config.sys


(B) Put pnphlp.vxd in the windows system directory, and re-booting, before trying any install.

(C) Use Daemon's "Silent install"

Instead of getting the error "Virtual SCSI driver not detected" I got the Daemon icons in the tray. Everything looked perfect. Until I re-started windows. I then got the protection error again.

It could be a TSR problem BUT as I have disabled just about every startup program I don't think so.

Getting closer now. Hope this is of some help.

Regards, John.

04.01.2004, 10:24
How do I work out what version pnphlp.vxd is ? No idea if it is 1.05 or not.
Right click in Explorer -> properties -> version should give you some info.

John Fitzsimons
04.01.2004, 10:49
Okay, thanks. The pnphlp.vxd I have used is the one that came with the 344 install. Explorer says 1.05.

The web page I mentioned mentions the BIOS. I doubt that that is a problem as the computer I am trying to install on is only a few months old.

The registry however has been transferred from my previous system so may have some redundant devices. I would follow the MS advice of ;

"There may be an incompatible hardware configuration. Check the port and IRQ settings of the network adapter, sound card, and modem. Make sure that there are no COM2/COM4 or COM1/COM3 conflicts and that no devices are sharing IRQs. Disable or remove conflicting devices."

but I am not sure of the way to do that. My main knowledge is software. Not hardware.

I logged one of the Daemon installs. Don't know whether that would help or not. I think I have a bootup log too.

Regards, John.

John Fitzsimons
04.01.2004, 13:33
Okay, another update. I decided to try an earlier release. I tried 3.33. Everything installed okay. No problems at all.

Regards, John.

04.01.2004, 17:38
It seems some global problem with 3.44 on your system, not pnphlp.vxd.
Because even without Daemon Tools (with only pnphlp.vxd) you can boot fine, right? Then you are the first one who reported such problem.
Please provide full list of hardware/software on your PC.

John Fitzsimons
05.01.2004, 00:33
It seems some global problem with 3.44 on your system, not pnphlp.vxd.
Because even without Daemon Tools (with only pnphlp.vxd) you can boot fine, right? Then you are the first one who reported such problem.
Please provide full list of hardware/software on your PC.

If I remove pnphlp.vxd then I can boot normally. So that would suggest that something might be wrong with it and/or some reference to it is creating problems.

If things boot okay with that file in position it might suggest that as there is no reason for windows to access the file it is being ignored on bootup. A Daemon install directing '98 to access the file.

As for being the "first one who reported such problem". Perhaps you didn't notice ;

http://www.daemon-tools.cc/portal/viewtopic.php?p=10002#10002 ?

At least one other person had a similar situation (with 343).

I am sending you my hardware/software info by email.

Regards, John.

05.01.2004, 08:38
You should not remove pnphhlp.vxd - you should remove bus driver if you want to test 3.44 compatibilty. pnphlp.vxd is simple export driver, it does no harm - if you remove it then it prevents bus driver from loading at all and you surely can't test anything. Leave pnphlp.vxd 1.05 on your system and never delete it even without daemon). If you have problems then delete actual driver files from Daemon, not this vxd.
I have received your system report - to be honest i have never seen any PC in my life with such amount of soft installed.;) So this needs time to analyze.

20.01.2004, 19:43
Operating System: Windows 98 SE
Burning Software: clonecd ; feurio
Anti-virus Software: EZ trust A/V
DAEMON Tools Version: 3.43 and 3.44

I have been driving myself nuts with this same exact issue !!!!!
I recently upgraded to SOYO P4I845PELite mobo with P4 2.66 Ghz 533 fsb.
Fisrts attempt at upgrade of video driver to Nvdia 53.04 resulted in Windows Protection Error (hereafter noted as WPE). Resoration of registry and return to version 41.xx cured. Attempt to install daemon 3.44 with ZERO other applications installed resulted in same WPE . Uninstall in safemode allows reboot. Attempt to install 3.43 same results WPE, uninstall in safe mode. Install of 3.41 worked fine , noted shark driver instead of 344 driver. Many many attempts of disabling various devices in Device Mgr and reinstalls of 344 still same WPE. On one occasion 344 did install and not require restart and was working proper. First restart ...WPE..
Another install of 344 and i edit registry in safe mode before installation induced restart. In SCSI key changed value for "restart if conflict" to yes.
System restarted normal but with safe-mode ish desktop resolution and rediscovery of Video card. Note i did no alterations to video in registry or device mgr. Possibly a conflict now with Nvidia installed drivers and daemons 344??????