PDA

View Full Version : Unable to add adapter / Not enough free resources (Code 12)



xmartx
24.02.2008, 15:54
Hi, I made the mistake of disregarding the "never change a running system" rule yesterday as i wanted to upgrade my Daemon Tools installation from 4.09 to 4.12 (lite) yesterday. Now I can't seem to get it running at all again :/
I'm running WinXP SP2 on a Intel P35C chipset with E6750 C2D cpu.

What I did was simply uninstalling the old 4.09 with the uninstall link from the start menu -> reboot -> install 4.12 lite
The 4.12 installer prompted for reboot as expected. After the reboot it asked where to install and the installer finished properly.
But when I try to launch Daemon Tools i get the "Unable to add adapter. Reboot is required after previous operation" error no matter how many times i reboot.

I checked the Device Manager in the Control Panel and once I start DT a SCSI/RAID Host Controller appears and has the yellow exclamation mark next to it. The device status says "This device cannot find enough free resources that it can use (Code 12)..."

When I run SPTDinst it reads "Same SPTD version (1.55) detected"

I already read most of the threads about this on here and have tried all countermeasures i found, but the problem stays the same. I manually uninstalled/reinstalled SPTD with the SPTD inst exe. I deleted the SPTD and DT registry entries and tried installing in safe mode. No effect whatsoever :/

I'd be really grateful for any help as I want to avoid a reinstall ;)

guruuno
26.02.2008, 15:15
I bought this to use, not to spend hours to fix. Can someone fix it or do I attempt to try and get a refund. THe posts just go on forever.....

xmartx
26.02.2008, 22:32
i settled with having to reinstall xp, as this will most likely work and consume less time than further troubleshooting :/

this is however the first issue i ever had with daemontools and i have been using it for years....

xmartx
01.03.2008, 13:35
dunno if anyone cares, but the problem seems to come from dt 4.12

out of curiosity i just reinstalled dt 4.09 and it works fine with no errors whatsoever.....

SUPPORT2
04.03.2008, 10:31
Hello
Thank you guys for the information.
The problem fixing is in progress.
Don't think you are forgotten.