PDA

View Full Version : daemon doesn't uninstall well... cd-rom and dvd were gone



taurus
17.01.2004, 12:54
Operating System: win 98se
Burning Software: nero
Anti-virus Software: mcafee
DAEMON Tools Version: 3.44

Hi there!

I had the same problem as many of the users: pnphlp.vxd. It didn't need daemon anymore so I uninstalled. After uninstalling my cd-rom and dvd-rom were gone but got them back by using real mode drivers from windows startup disk.

Though when I tried to burn a cd with Nero. I only saw the virtual drive Daemon created. I guess daemon didn't uninstall correctly. Installing daemon is also not possible because of the pnphlp.vxd

How do I get my original settings back? or how do I get daemon workin again? :?

Somebody of help?

Copytrooper
17.01.2004, 13:10
With v3.44 you shouldn't have any problems with pnphlp.vxd anymore, this was an issue with v3.43 only.
What you can try is, install Daemon Tools, check version of pnphlp.vxd (should be v1.05 with v3.44);
and try to boot. If it fails, boot to DOS (F8 at start);
rename pnphlp.vxd, start Windows (i.e. win);
un-install Daemon Tools. If it still fails boot safe mode, un-install Daemon Tools.
If this doesn't work for you check out the threads in our common problems and solutions forum regarding missing cd/dvd drives, Daemon Tools leftovers 'n stuff.

taurus
17.01.2004, 14:03
I can only startup by disabling pnphlp.vxd Uninstalling leves pnphlp.vxd and by renaming it can't startup either. I will now have a look at the other posts regarding daemon leftovers.

By the way: the pnphlp version is 1.05

Thanks for your help till so far. :)

Development
18.01.2004, 00:31
You sound not logical - in first post you said that after uninstall of Daemon and reboot just other CD drives were gone, i.e, one can assume you already COULD startup while pnphlp.vxd was on your system.

taurus
18.01.2004, 15:26
ehm sorry.. I am able to startup by renaming pnphlp.vxd. I just did the same thing in a step by step startup, and disabling the file.

The case is that I'm still seartching for a way to get my cd-rom and dvd back in the original way. So not by use of the startup disk drivers.

Nero only sees the virtual drive and not my real cd-rom. In fact it seems that some drivers are damaged in windows. Such as standard drive controller and the primary and secondary ide controllers. They all give the same error 10. I already tried to reinstall them but this didn't work.