View Full Version : Daemon tools not reading images

25.03.2008, 18:50
I run Vista Home Edition.

When I mount images on Daemon, the image doesn't load up, and when I go to manually enter the files through the virtual drive via My Computer, there aren't any virtual drives. Could someone help?

25.03.2008, 19:56
Assign a drive letter to your virtual drive through windows drive letter assignment.

26.03.2008, 10:31

26.03.2008, 17:27

Sorry for the beginner's touch on Vista, but where do I find Windows Drive Letter Assignment?


I found this link yesterday, sorry to say but I didn't understand half of your format. Truth is I made it to Device Manager but I couldnt find Virtual Devices subcatogorized anywhere and therefore couldn't find cdrom.sys, storprop.dll, or redbook.sys

I also deleted infcache.1 from before but it still works to no avail.

Furthermore, I installed a whole pack of different image mounters ( Daemon, Alcohol 120%, Virtual CloneDrive etc) and none of them work which would suggest that theres something wrong with my computer settings.

Again, I run Windows Vista Home 32bit.

Any further clarifications would help alot,


26.03.2008, 18:55
You will find that in: control panel/administrative tools/computer management/disk management

There you do a right click on the virtual drive (you will see it has a strange name), change drive letter and then select a drive letter.

When i posted that above i just haven't known the correct word for that.

In device manager you have to look for DVD/CD-ROM devices.

26.03.2008, 19:39

Thanks for the heads up, but when I went into Computer Management I did not see any virtual drives. I have installed Daemon Lite and mounted an image. here's a screenshot of how my Computer Management looks like. Maybe I'm missing something:


26.03.2008, 21:45
The is no "Virtual device section" in device manager. ;) The virtual devices should be in CD/DVD-ROM section with the "real" devices.