PDA

View Full Version : [4.12.4] unable to add adapter device problem 39



rtfmoz
14.07.2008, 05:05
Description
Cannot find Virtual Device Driver
Unable to add adapter device problem 39

Environment
Windows XP SP2
Daemon tools 4.12.4
SPTD 1.56 - comes with Daemon Tools
Windows XP Service Pack 2

Diagnosis
Verify SPTD is running. Open Device Manager select View-> View hidden devices. Check under Non Plug and Play devices for spdt device. It should be running. If it is not then re-install SPTD.

Symptoms
When Daemon tools tries to start you get the error message as above as it cannot talk to the SPTD adapter.

Cause
IBM Proventia eSecure or IBM Desktop security is running and blocking access to the device. It doesnt seem to matter if application security is turned off.

Solution
1. Right click on the Proventia icon in bottom right corner and select Stop Agent.
2. Start Daemon Tools
3. Right click on the Proventia icon and select Start Agent.

Feedback
If you have feedback on this solution please reply to this thread. If you have an alternate solution for this version of DT then please post a reply to this thread so we can collate them.

Travolta
21.09.2008, 03:29
Just got the same problem - 39

I changed my SATA mode from IDE to AHCI, so I renstalled Windows XP SP2 to SP3 by occasion. After that DT 4.30.1 start getting error "unable to add device problem 39". I tryed removing DT , installing old versions, nothing helps. I see in device manager how it tryed to add SCSI device - shows for a sec and gone. I have no other scsi device. I`m using nvidia 780a chipset, Win XP SP3 (under Vista 64 on the same comp it works fine). Maybe there is extra cleanup need to reinstall DT ? I tryed to remove setting from previos installations.

p.s. I reinstalled WinXP in repair mode (if it means something)

Blazkowicz
21.09.2008, 10:25
Try a clean install of Windows XP.

Travolta
22.09.2008, 21:22
99% it will work on clean install - I have no doubt - but its not a solution in my case - I need to understand what can cause problem. Overlooking exisiting drivers in my system - remove unused. Maybe permissions problem or something in registry ?

Travolta
22.09.2008, 23:23
checked drivers in \system32\ folder - not help - problem is somewhere out this folder - any registry setting DT using ?

p.s. Tryed to install 4.06 - found interesting thing - when DT starts adding device ...device appers in SCSI/RAID controllers....disconnecting sound..."SCSI/RAID controllers can now be safly unplugged" pops out ....adding device problem 39 error. Looks like something ejects DT virtual controller

Development
23.09.2008, 21:09
This problem can be caused by faulty filter drivers in your system installed as part of some RAID package.

Travolta
24.09.2008, 00:44
yes, I thought so - even removed JMicron drivers - just in case.

Looking through logs for possible debug output found something - maybe anyone can say whats the problem:

#I058 Selected best compatible driver.
#I060 Set selected driver.
#-019 Searching for hardware ID(s): acpi\pnpa000,*pnpa000
#-018 Searching for compatible ID(s): gen_scsiadapter
#I022 Found "GEN_SCSIADAPTER" in C:\WINDOWS\inf\pnpscsi.inf; Device: "SCSI/RAID Host Controller"; Driver: "SCSI/RAID Host Controller"; Provider: "Microsoft"; Mfg: "Unknown Manufacturer"; Section name: "NO_DRV".
#I023 Actual install section: [NO_DRV]. Rank: 0x00003000. Effective driver date: 07/01/2001.
#-166 Device install function: DIF_SELECTBESTCOMPATDRV.
#I063 Selected driver installs from section [NO_DRV] in "c:\windows\inf\pnpscsi.inf".
#I320 Class GUID of device remains: {4D36E97B-E325-11CE-BFC1-08002BE10318}.
#I060 Set selected driver.
#I058 Selected best compatible driver.
#-124 Doing copy-only install of "ACPI\PNPA000\4&5D18F2DF&1".
#-166 Device install function: DIF_REGISTER_COINSTALLERS.
#I056 Coinstallers registered.
#-166 Device install function: DIF_INSTALLINTERFACES.
#-011 Installing section [NO_DRV.Interfaces] from "c:\windows\inf\pnpscsi.inf".
#I054 Interfaces installed.
#-166 Device install function: DIF_INSTALLDEVICE.
#I123 Doing full install of "ACPI\PNPA000\4&5D18F2DF&1".
#E262 Controlling Service: Failed to open service "amcrkjia". Error 1060: The specified service does not exist as an installed service.
#E275 Error while installing services. Error 1060: The specified service does not exist as an installed service.
#E122 Device install failed. Error 1060: The specified service does not exist as an installed service.
#E157 Default installer failed. Error 1060: The specified service does not exist as an installed service.
#I060 Set selected driver.

This info repeats in log as many times as I tryed install DT
I didnt find anything where to find service "amcrkjia" And what it do

Travolta
25.09.2008, 00:46
What services are necessary to run Daemon Tools devices ?

Development
25.09.2008, 18:36
Windows should not search driver at all - if it tries to search driver in pnpscsi.inf then already this fact is abnormal.
Maybe on your system you have some registry problems
which prevent DT to install its driver.