PDA

View Full Version : Unable to boot Win2KSP3 after installing daemontools



Alaric
25.01.2004, 19:29
Operating System: Windows 2000 Pro SP3
Burning Software: Roxio EasyCD 5
Anti-virus Software: AVG 6.0, can't get the exact version from safe mode
DAEMON Tools Version: 3.44

OK, so ... I've been trying to get Civ3 to run from a disk image instead of requiring the physical disk. It won't run from a VirtualCD 4 virtual drive -- or rather, it'll run but still demands insertion of the physical CD -- so last night I tried the blindread/daemontools route. (Not that I don't have the CD, I just hate exposing originals to potential damage.)
After installing daemontools, my machine will boot only in safe mode. I've eradicated every trace of daemontools that I can find, although I am unable to delete the d344prt key from HKEY_LOCAL_MACHINE/SYSTEM/*/Enum/PCI where * is ControlSet001, ControlSet002, or CurrentControlSet. I've tried the Win2K repair without success. Is there ANYTHING else I can try before I have to burn it down and reinstall? I REALLY don't want to have to do that again.

Copytrooper
25.01.2004, 21:07
Why do you do such things?
Why not boot into safe mode, press ESC when the message comes up, to prevent loading of Daemon Tools d344x.sys, and then uninstall Daemon Tools via control panel?
Anyhow, here (http://www.daemon-tools.cc/portal/viewtopic.php?t=2287) you find what you need to know.

Alaric
25.01.2004, 21:41
I've done both of those procedures. I then manually cleaned up things they left behind.
I've been able to isolate the problem a bit further. It's not that daemontools is preventing my system from booting. It's that after daemontools has been installed, VirtualCD 4 is broken so badly that even after removing daemontools again, I can no longer boot my system. Something daemontools changes either in the system or in the registry is apparently so incompatible with VirtualCD 4 that after totally uninstalling daemontools, uninstalling virtual CD, reinstalling daemon tools, uninstalling daemon tools again, reinstalling virtualCD, removing virtualCD, reinstalling virtualCD cleanly AGAIN, and so on, I still cannot make things work. The basic situation seems to be, after having had daemontools on my system even temporarily, I can never again have VirtualCD 4 installed and be able to boot the machine in anything but safe mode.

Since I paid money for a VirtualCD license and was experimenting with daemontools only to try to avoid CD-swapping with one copy-protected game, this displeases me highly, as it looks as though I now have no choice but to reinstall my system.

Andareed
26.01.2004, 02:53
If system is bsod'ing, you can send latest dmp file from C:\winnt\minidump to andareed@daemon-tools.cc and I'll look at it.

Development
26.01.2004, 08:52
Most likely you have problem with Easy CD drivers.

brew
26.01.2004, 12:46
Operating System: winxp
Burning Software: nero
Anti-virus Software: norton
DAEMON Tools Version: 3.44

Have you got a creative sound card? I think that creative have a .sys file called d344bus.sys too. So when rebooting creative tries to load up the overwritten sys file and b0rks.

If daemon tools were on any other version it wouldn't be a problem :)

(ps - I think this is the problem, at least.

v6ph1
13.06.2004, 15:07
Operating System: Windows 2000 SP4 (newest Version, German)
Burning Software: CloneCD Nero InCD
Anti-virus Software: Norton AV 2003
DAEMON Tools Version: 3.44

I have Installed Virtual CD 5 first
After that I had installed Daemontools
Nothing works anymore
Then I boot in safemode --> resource-konflict
VCD and D-Tools have the same SCSI-resource in Windows 2000
under Win ME works this kombination
-->uninstall D-Tools
I hope this bug will be corrected